Suporte Tainacan para Blocksy

Descrição

O Tainacan é uma ferramenta de código aberto, flexível e poderosa para criar repositórios digitais no WordPress. Ele permite que você crie e gerencie coleções com uma variedade de tipos de metadados, rica pesquisa e filtragem de itens e muito mais.

O Blocksy é um entre tantos temas WordPress disponíveis por aí. Mas não é apenas mais um tema, ele oferece controles ricos para se customizar seu site com tantos recursos que você não vai sentir falta de um construtor de páginas. Este projeto usa os controles do menu personalizar deles para oferecer opções de configuração de diferentes layouts para as páginas Tainacan tais como a lista de itens da coleção e a página do item.

Este projeto usa os controles do menu personalizar deles para oferecer opções de configuração de diferentes layouts para as páginas Tainacan tais como a lista de itens da coleção e a página do item.

Saiba mais

Copyright

Suporte Tainacan para Blocksy, Direitos Reservados 2023 Tainacan.org
O plugin Suporte Tainacan para Blocksy é distribuído sob termos da licença GNU GPLv3
Detalhes da licença: https://github.com/tainacan/blocksy-tainacan/blob/master/LICENSE

Imagens de tela

  • Com o plugin habilitado, seu menu personalizar vai oferecer opções para cada lista de itens de coleção Tainacan e página do item, além das listas de itens do repositório e do termo;
  • A página do item do Tainacan pode ser personalizada em diferentes layouts, para que você decida como exibir o documento, anexos e metadados;
  • Além disso, o Blocksy oferece diferentes banners de título, navegação de posts e recursos relacionados à navegação de posts que também podem ser usados na sua página do item;

Instalação

Envie os arquivos para o diretório de plugins e o ative. Você pode também instalar e ativar diretamente a partir do painel administrativo.

Uma vez ativado, vá para o menu personalizar do tema e experimente as opções relacionadas ao Tainacan para cada uma das suas coleções.

Este plugin só funcionará com o plugin Tainacan ativo, preferencialmente com uma versão maior que ou igual a 0.17.4;

E também, este plugin só funcionará com o tema Blocksy ativo, preferencialmente em uma versão maior que ou igual a 1.7.0;

Avaliações

Leia 0 avaliação

Colaboradores e desenvolvedores

“Suporte Tainacan para Blocksy” é um software com código aberto. As seguintes pessoas contribuíram para este plugin.

Colaboradores

“Suporte Tainacan para Blocksy” foi traduzido para 3 localizações. Agradecemos aos tradutores por suas contribuições.

Traduzir “Suporte Tainacan para Blocksy” para o seu idioma.

Interessado no desenvolvimento?

Navegue pelo código, dê uma olhada no repositório SVN ou assine o registro de desenvolvimento via RSS.

Registro de alterações

0.3.0

  • Adds page title default Blocksy banner options for Collection Items templates
  • Adds page title section options to Repository and Taxonomy Term Items level templates
  • Adds container size option to all Items list templates
  • Adds thumbnail carousel positioning option for item single gallery (requires Tainacan 0.20.5)
  • Adds inner spacing option for media gallery on item single gallery
  • Uses Blocksy’s button min-height, button border radius and input border radius settings on the items lists
  • More improvements to compatibility with Blocksy 2.0.0
  • Improves post navigation markup to use latest filters
  • Bug fix: label “Document” and “Documents” not displaying in the correct situations
  • Bug fix: translation issues in breadcrumbs
  • Bug fix: moves tainacan_blocksy_post_class() to integration for its classes to also work on child themes
  • Bug fix: positioning of relationship metadata thumbnail
  • Bug fix: thumbnail not being found in items navigation leading to a warning

0.2.0

  • Adds Taxonomy Single (Terms list) page functionality (requires Tainacan 0.20.1)
  • New layout for the Item Page: Media Gallery above page title
  • Option to set default order by for Repository Items list
  • Fixes to item thumbnail display inside sections
  • Initial compatibility with Blocksy 2.0.0

0.1.21

  • Fixes breadcrumb hierarchy when inside taxonomy archives
  • Disables Tainacan single Item archive as it is not necessary to get the content twice
  • Adapts some Blocksy css variables
  • Small css improvements to geo coordinate metadatum

0.1.20

  • Sorting related items by title
  • Small css improvements

0.1.19

  • Better ElasticPress compatibility on search modal.

0.1.18

  • Fixes compatibility with Metadata Sections
  • Adds option to separate default section from metadata sections layout

0.1.17

  • Makes document gallery compatible with latest features from Tainacan 0.19

0.1.16

  • Fixes trailing commas that were causing errors on PHP < 7.3

0.1.15

  • New metadata sections layouts (requires Tainacan 0.19)
  • New options to lightbox view (requires Tainacan 0.19)
  • Safer scaping of some html tags and attributes
  • Fixes some options unit compatibility with latest Blocksy

0.1.14

  • Fixes advanced search layout

0.1.13

  • Redirects search to items list if only Tainacan items post types are enabled

0.1.12

  • Fixes lack of –background-color variable due to recent versions of Blocksy

0.1.11

  • Compatibility with Tainacan 0.18.5 and its display of related metadata
  • New option to use a light color scheme on the image gallery of the item

0.1.10

  • “Items related to this” section and Zoom to single Document

0.1.9

  • Fixes collection description style

0.1.8

  • Corrige diversos erros nos elementos do cabeçalho de listagens

0.1.7

  • Corrige problemas de detecção de temas filhos quando se está no menu personalizar

0.1.6

  • Corrige enfileiramento global de CSS e atualizações para a lógica em linha do Blocksy 1.8.0

0.1.5

  • Corrige problema no arquivo de navegação com abertura de tag PHP

0.1.4

  • Limpa alguns arquivos desnecessários de compilação

0.1.3

  • Muda alguns nomes para evitar problemas de direitos de uso

0.1.2

  • Primeira versão no repositório de plugins WordPress.org