Breeze – Plugin de cache para WordPress

Descrição

O Breeze é um plugin de cache para WordPress gratuito, simples (e poderoso) e amigável desenvolvido pela equipe do Cloudways. Ele oferece várias opções para otimizar o desempenho do WordPress em vários níveis. Funciona igualmente bem com WordPress, WooCommerce e WordPress Multisite.

O Breeze se destaca nas seguintes áreas:

  • Desempenho: O Breeze melhora a velocidade do site e a otiização dos recursos. Outros recurso incluem um sistema de cache para arquivos e opções de limpeza do banco de dados, minificação, suporte para o cache Varnish e integração simplificada com CDN.

  • Conveniência: O Breeze é fácil de instalar e configurar diretamente do WordPress. Configurar o Breeze é fácil e a maioria das opções padrão funcionam diretamente após a instalação. As configurações recomendadas devem funcionar sem problemas em todos os seus sites em WordPress.

  • Simplicidade: O Breeze foi projetado para ser simples para todos os usuários. Basta instalar e ativar o plugin e você irá notar instantaneamente os resultados.

O que torna o plugin de cache Breeze para WordPress tão sensacional é que ele vem com suporte embutido para o Varnish. Se o Varnish não está instalado no seu servidor o Breeze irá usar o seu mecanismo interno de cache para turbinar o desempenho do seu site em WordPress.

Suporte: Nós adoramos dar suporte! Poste as suas dúvidas nos fóruns de suporte do WordPress, ou se for cliente Cloudways você pode perguntar no Fórum da Comunidade Cloudways.

Requisitos

PHP 7.x, PHP 7.4 e PHP 8 recomendados para melhor desempenho, WordPress 5.9+

Instalação

Para instalar o plugin através do Painel do WordPress:

  • No painel de administração do WordPress, navegue até Plugins > Adicionar novo
  • Procure por Breeze
  • Clique em Instalar e aguarde a instalação terminar. Em seguida clique no link Ativar

Para instalar manualmente o plugin:

  • Baixe e descomprima o pacote do plugin – breeze.1.0.0.zip
  • Envie o breeze para /wp-content/plugins/
  • Ative o plugin através do menu ‘Plugins’ no WordPress
  • Acesse o Breeze na Administração do WordPress > Configurações > Breeze

FAQ

Instruções de Instalação

Para instalar o plugin através do Painel do WordPress
1. No painel de administração do WordPress, Menu > Plugins > Adicionar
2. Procure por Breeze
3. Clique em Instalar e aguarde a instalação terminar. Em seguida clique no link Ativar

Para instalar manualmente o plugin
1. Baixe e descomprima o pacote do plugin – breeze.1.0.0.zip
2. Envie a pasta /breeze para /wp-content/plugins/
3. Ative o plugin através do menu ‘Plugins’ no WordPress
4. Acesse Breeze na administração do WordPress > Configurações > Breeze

O Breeze tem suporte para o Varnish e em que limites?

Por padrão o Breeze tem suporte para o Varnish. Ele foi testado para se totalmetne compatível com os servidores do Cloudways que vêm com o Varnish pré-instalado. Se você usa provedores de hospedagem diferentes do Cloudways, sugerimos confirmar o suporte ao Varnish com o seu provedor de hospedagem.

O Breeze tem suporte para o WooCommerce?

O Breeze é totalmente compatível com o WooCommerce logo após a instalação. Ele não requer nehuma configuração especial.

O Breeze tem suporte para o WordPress Multisite?

O Breeze é totalmente compatível com o WordPress Multisite sem a necessidade de nenhuma configuração adicional.

Como o Breeze gerencia o WordPress Multisite?

O Breeze gerencia globalmente todas as instâncias do WordPress Multisite. Todas as configurações para o multisite são agora gerenciadas no nível da rede.

O Breeze é compatível com outros plugins de cache para WordPress?

Nós NÃO recomendamos usar dois plugins de cache de WordPress ao mesmo tempo em nenhum site em WordPress.
Recomendamos expressamente que use o Breeze como único plugin de cache para o seu site. Se houver quaisquer outros plugins de cache instalados, certifique-se de tê-los desativado antes de continuar com a instalação do Breeze.

O Breeze é compatível com HTTPS?

O Breeze não requer nenhuma configuração especial para funcionar com páginas HTTP ou HTTPS.

O Breeze tem problemas de compatibilidade com outros plugins conhecidos?

O Breeze foi testado com plugins populares disponíveis no WordPress.org. Fique à vontade para relatar quaisquer incompatibilidades nos Fóruns de suporte do WordPress ou no Fórum da Comunidade Cloudways.

O Breeze tem suporte para CDN?

O Breeze tem suporte para integração com CDN. Isso permite que recursos estáticos (como imagens e arquivos CSS e JS) sejam servidos através do CDN.

O que faz o recurso de otimização do banco de dados do Breeze?

Bancos de dados de WordPress são conhecidos por armazenar informações como revisões de post, comentários spam e muito mais. Com o tempo o banco de dados se torna sobrecarregado e é uma boa prática liberar as informações indesejadas para reduzir o tamanho do banco de dados e melhorar a otimização.

A otimização do banco de dados do Breeze limpa a informação indesejada com um úico clique.

Os comentários e outras partes dinâmicas do meu blog aparecerão imediatamente?

Os comentários irão aparecer após moderação conforme o sistema (ou política) de comentários definida pelo proprietário do blog. Outras mudanças dinâmicas como quaisquer alterações em arquivos irão requerer um esvaziamento completo do cache.

Posso excluir URLs de arquivos e páginas individuais do cache?

Você pode excluir um arquivo mencionando seu URL(s) ou tipo(s) de arquivo (mencionando sua extensão) nos campos de exclusão disponíveis nas configurações do Breeze. Excluindo não permite que o cache tenha impacto naquele URL ou tipo de arquivo.

Se o Varnish estiver ativo você precisará excluir os URLs e tipos de arquivo na configuraçao do Varnish. Se você hospeda sites em WordPress nos servidores Cloudways, siga esta Base de Conhecimento sobre como excluir URLs do cache Varnish.

Ele funciona com todos os provedores de hospedagem?

O Breeze foi testado para funcionar com a maior parte dos provedores de hospedagem. Adicionalmente, opções importates do Breeze como Gzip, cache do navegador, minificação, agrupamento, otimização do banco de dados e integração com CDN irão funcionar como esperado em todos os provedores de hospedagem.

Onde posso obter suporte para o Breeze?

Você pode ter as suas perguntas respondidas nos fóruns de suporte do WordPress. Se for cliente Cloudways, fique à vontade para iniciar uma discussão no Fórum da Comunidade Cloudways.

Como posso testar e verificar os resultados?

Você será capaz de ver o impacto do plugin de cache Breeze quase imediatamente. Também recomendamos usar as seguintes ferramentas para gerar métricas:
Google Page Speed
WebPagetest
Pingdom

O plugin Breeze funciona com o Visual Builder?

Sim, o Breeze é compatível com o Visual Builder.

Quais CDNs populares são suportados pelo plugin Breeze?

O Breeze tem suporte para os três CDN’s populares abaixo:
MaxCDN
KeyCDN
Amazon Cloudfront

O Breeze tem suporte para o Push CDN?

Não, o Breeze não tem suporte para o Push CDN. Entretanto, você pode usar o Breeze com o Push CDN usando plugins de terceiros.

O Breeze funciona com o Cloudflare?

Sim. O processo de configurar o Cloudflare com o Breeze é fácil. Consulte o seguinte artigo da Base de Conhecimento para detalhes.

Como o cache do Breeze usa Gzip?

O Breeze comprime os arquivos solicitados usando GZip e reduzindo ainda mais o tamanho dos arquivos baixados, acelerando a experiência do usuário.

Avaliações

8 de setembro de 2022
This plugin has issues as far as I can remember being a Cloudways customer. No real love has ever been shown to the plugin. Having the minified CSS shows as render-blocking attests to the low level that the developers of this plugin have reached. Lazy load also causes layout issues on a solid theme (GeneratePress). I am really sad a thousand times of how this plugin keeps disappointing me and other users. I hope the Digital Ocean buyout of the platform brings some improvements to the overall platform because you guys just suck! With all due respect!
2 de setembro de 2022
Sorry, but this plugin has more bugs than features. Always have problems with your support, too. I am switching not to another cache plugin, and later that month to another hosting.
17 de agosto de 2022
On the Breeze FAQ section: "Breeze is fully compatible with WooCommerce, out of the box. It does not require any special configurations." This is blatantly not true, and it's not true because you can't exclude cookies from being cached. In my own woocommerce site I have 2 woocommerce cookies being used: 1. woocommerce_cart_hash 2. woocommerce_items_in_cart You know what happens when you can't exclude these cookies? A glitch occurs and clients see the previous quantity in their cart before updating to the real quantity, this is not that much of a problem, except of course, as we know, small problems can snowball into big problems. And that's what happened when I added a discounts plugin to start implementing discounts on our products more easily. What happened was that products outright dissapeared from a costumers cart. Getting in touch via direct ticket with Cloudways still hasn't wielded a concrete clear answer to this problem but it seems clear that this plugin is not compatible with woocommerce until they add an option to exclude cookies.
28 de junho de 2022
Breeze is a monster, been using alot of caching plugin until I bumped into Breeze. You amazing my sites are now faster than wordpress.org itself
23 de abril de 2022
I had some trouble with my old caching plugin in a multisite and this one works like a charm. Thanks a lot.
Leia todas as 86 avaliações

Colaboradores e desenvolvedores

“Breeze – Plugin de cache para WordPress” é um software com código aberto. As seguintes pessoas contribuíram para este plugin.

Colaboradores

“Breeze – Plugin de cache para WordPress” foi traduzido para 9 localizações. Agradecemos aos tradutores por suas contribuições.

Traduzir “Breeze – Plugin de cache para WordPress” para o seu idioma.

Interessado no desenvolvimento?

Navegue pelo código, dê uma olhada no repositório SVN ou assine o registro de desenvolvimento via RSS.

Registro de alterações

= 2.0.9=

  • Fix: Added nonce check to import settings ajax request, in order to improve security and prevent cross-site requests.

= 2.0.8=

  • Correção: Compatibilidade aprimorada com o plugin Pickingpal para carregar os pedidos.
  • Correção: Removidas as chamadas duplicadas do cabeçalho nas solicitações do Varnish.
  • Correção: Certificado inválido nunca aceito e seu valor padrão é agora TRUE.
  • Adição: Incluída a opção para esvaziar o cache de objeto.

2.0.7

  • Correção: Em alguns casos uma chamada para a função indefinida is_plugin_active() era exibida, isso agora foi corrigido substituindo-a com uma verificação para class_exist nos plugins CURCY e WOOCS.

2.0.6

  • Correção: Sobrescreve o fuso horário para UTC no plugin The Events Calendar.
  • Correção: O cache do menu de moedas é feito com o HTML, alterando-o com a moeda é difícil com os plugins CURCY e WOOCS.
  • Correção: Pré-carregando links que não têm o atributo “href” ou onde o atributo “href” contém o valor “#” exibiam erros no registro do console.
  • Correção: Alguns arquivos JavaScript inline não eram exibidos quando a opção “Arquivos JS comcarregamento atrasado” tinha ao menos uma funcionalidade quebrada de valor adicionado para outros scripts JavaScript.

2.0.5

  • Adição: Melhorias à UI para melhor accessibilidade e experiência do usuário.

2.0.4

  • Adição: Melhoria no carregamento de página au atrasar a execução do JavaScript. O atraso do JS é desativado por padrão para novas instalações.
  • Correção: Adicionadas verificações de JavaScript para ver se a biblioteca sorteável é carregada ou não, caso não seja então o código JS que requer a biblioteca não será executado.
  • Correção: Variável indefinida nos scripts de minificação do Breeze.

2.0.3

  • Correção: Todas as ações Ajax agora são restritas aos usuários que tenham as capacidades manage_options. Vulnerabilidade descoberta pela equipe PatchStack.
  • Correção: Por padrão apenas os administradores têm a capacidade de manejar manage_options.
  • Correção: Adicionada uma restrição em option-tabs-loader.php, se o usuário não tiver a capacidade manage_options, então as abas não irão carregar.

2.0.2

  • Correção: Atarim – Conflito da inteface de cliente do plugin com a UI do Breeze na área de administração.
  • Adição: LazyLoad agora compatível com iframes
  • Adição: Controle da API Heartbeat do WordPress. Usuários podem desativá-la de forma independente no administrador, na página de edição de postagem, e na interface.
  • Adição: Pré-carregamento de DNS nas páginas.
  • Adição: Melhorada a manipulação da mensagem de alerta quando as permissões não estão corretas.

2.0.1

  • Correção: Melhorada a manipulação da minificação da opção Nunca armazenar URL(s) em cache.

2.0.0

  • Adição: Implementada uma nova interface de usuário.
  • Correção: Duplicado o script ao usar a opção Mover arquivos JS para o rodapé.
  • Correção: Improvisa a otimização das funções do núcleo do WordPress para limpar corretamente o banco de dados.
  • Correção: Implementada condição nas regras do .htaccess ao desativar “mod_env”.
  • Correção: Problema de compatibilidade com o Facebbok para o plugin WooCommerce.

1.2.6

  • Adição: O cache Varnish será esvaziado na desativação do plugin.
  • Adição: Ativa o cache para função específica de usuário.
  • Adição: Desativa os emojis para reduzir as solicitações.
  • Adição: Exclui os valores das opções do breeze do banco de dados na exclusão do plugin.
  • Correção: Problema de compatibilidade com shortcodes de mapa com o plugin GeoDirectory.
  • Correção: Problema de compatibilidade com o plugin Ad Inserter.
  • Correção: Problema de compatiblidade na minificação com o plugin Beaver Builder.
  • Correção: Problema de compatibilidade de scripts JS com o plugin AMP.
  • Correção: Reduzida a duração do cookie quando o usuário posta um comentário.
  • Correção: Elementos HTML filtrados do endpoint da RestAPI nos scripts lazy-load.
  • Correção: O arquivo de configuração para cada subsite é previamente salvo com o ID apropriado no arquivo em cache.
  • Correção: Exclusão do script do Google Analytics na minificação.

1.2.5

  • Adição: URLs contendo strings de consulta não serão armazenadas em cache por padrão.
  • Adição: Ignora strings específicas de consulta quando servindo da cache para melhorar o desempenho.
  • Adição: Habilidade para armazenar URLs em cache com variáveis específicas de strings de consulta.
  • Adição: A manipulação de cache de URLs contendo múltiplos parâmetros em uma string de consulta.
  • Adição: Manipulação excepcional da Cache para casos onde os links permanentes estão definidos para PLANOS, o que pode incluir links de POSTS, PÁGINAS, ANEXOS, CATEGORIAS e ARQUIVOS.

1.2.4

  • Adição: Funcionalidade para limpar TODOS os caches através da Interface de Linha de Comando (wp-cli).
  • Adição: Funcionalidade para limpar o cache Varnish através da Interface de Linha de Comando (wp-cli).
  • Adição: Funcionalidade para limpar o cache interno através da Interface de Linha de Comando (wp-cli).
  • Adição: Enquanto a permissão de arquivo não estiver correta, a mensagem de alerta foi adicionada.
  • Correção: Compatibilidade com o futuro modo de Página Em Breve, Modo de Manutenção e Landing Pages de SeedProd.
  • Correção: Melhora na manipulação de alerta de chave de array não-definido de atraso de script JS durante o modo de depuração ativo.

1.2.3

  • Adição: Adicionadas regras de ativos de mídia para objetos cacheáveis pelo navegador.
  • Adição: Adicionadas regras de ativos de fonte para objetos cacheáveis pelo navegador.
  • Adição: Adição em regras intecambiáveis de dados para objetos cacheáveis pelo navegador.
  • Adição: Adicionadas regras de arquivo para objetos cacheáveis pelo navegador ao manifesto.
  • Adição: Adição de regras de compressão GZip.
  • Correção: Implementação da manipulação do manipulador de solicitação quando o Varnish está inativo
  • Correção: Implemetação da condição de opção “Ativar o cache para usuários conectados”`

1.2.2

  • Adição: Exportar configurações via Interface de Linha de Comando (wp-cli).
  • Adição: Importar configurações via Interface de Linha de Comando (wp-cli).

1.2.1

  • Correção: Melhorada a manipulação de alerta de índice indefinido de lazy load de imagem enquanto o modo de depuração está ativado.
  • Add: Enable/Disable option of Delay JS inline scripts.

1.2.0

  • Adição: Tag de atributos “noreferrer noopener” em links externos quando processando o HTML para ocarregamento.
  • Adição: O pré-carregamento das fonteas permite ao texto permanecer visível durante o carregamento de webfonts.
  • Adição: Pré-carregamento de solicitações de chaves de fontes ou arquivo CSS que carrega as fontes de uma origem local.
  • Adição: Pré-carregamento dos links permite ativar o pré-carregamento das próximas páginas.
  • Adição: o Lazy Load exibe as imagens em uma página apenas quando elas aparecem ao usuário.
  • Adição: Minimiza o impacto de código de terceiros.

1.1.11

  • Correção: Manipulação melhorada de formulários usando nonce nas páginas de Links Permanentes e de Opções.

1.1.10

  • Correção: Aplica carregamento adiado em arquivo individual.
  • Correção: exclui o URL do feed gerado pelo plugin “Facebook para WooCommerce”.
  • Correção: esvaziar o cache do site em sub-pasta.
  • Correção: O estoque do inventário agora é atualizado na página do carrinho.
  • Correção: Melhorado o suporte para a nova versão do plugin WooCommerce Booking Calendar.
  • Adição: Compatível com plugins de EDD e fluxo de carrinho.
  • Adição: shortcode de inclusão de páginas foi excluído pelo Breeze.

1.1.9

Adicionado: Melhorada a manipulação da minificação para exclusões de consultas baseadas em strings na opção Nunca armazenar estes URLs em cache.
Adicionado: Incrementada a compatilidade com multíplos idiomas.

1.1.8

  • Correção: Problema atualizando o cache com o Varnish desativado.
  • Correção: Substituídas funções obsoletas no WordPress 5.5 que estavam causando mensagens de alerta.
  • Correção: Substituídas as bibliotecas obsoletas de minificação para melhora a compatibilidade com o PHP 7.x e adiante.
  • Correção: resolvido o alerta gerado pelo plugin Query Monitor.
  • Adicionado: compatibilidade com o PHP 7.4

1.1.7

  • Correção: Adicionados HTTP e HTTPS para validação da integração ao CDN.
  • Correção: Configurações personalizadas para multisite serão re-aplicadas após a reativação do Breeze.
  • Correção: Melhorias gerais para melhorar o suporte ao plugin WooCommerce Booking Calendar.
  • Correção: Melhorada a manipulação da minificação para exclusões baseadas e Curingas na opção Nunca armazenar estes URLs em cache.

1.1.6

  • Adicionado: Exclu’são de strings de padrão de URL baseadas em curinga (.*) na opção Nunca armazenar em cache este URL.
  • Correção: Validação melhorada para inegração a CDN.
  • Correção: Melhorias gerais para suporte aos Formulários do Elementor/Elementor Pro e integração a CDN.

1.1.5

  • Correção: Duração revisada para objetos do navegador que podem ser armazenados em cache

1.1.4

  • Correção: Erro fatal do PHP ao executar comandos usando WP_CLI

1.1.3

  • Correção: Erro indefinido para JS alinhado quando o arquivo do Grupo JS estava ativo.
  • Correção: Vários arquivos exibidos quando os Arquivos do Grupo estavam ativos.
  • Correção: O auto-esvaziamento do Varnish deixava a área de administração lenta quando o Varnish não estava sendo executado.
  • Correção: Arquivos PDF agora podem ser baixados com o CDN ativo.
  • Correção: Problemas diversos de UI.
  • Adicionado: O script/tag do Google Analytics agora é excluído da Minificação.
  • Adicionado: Opção para ativar o cache para o usuário administrador.
  • Adicionado: Manipulando erros 404 de JS/CSS/HTML quando os arquivos de cache não permitem escrita.
  • Adicionado: Excluída a idretiva @import da Minificação de CSS.

1.1.2

  • Correção: Melhorado o gerenciamenteo de exclusão de CSS e JS quando as opções de Minificação e Agrupamento de arquivos estão ativas.
  • Correção: Permite exclusão de arquivos/URLs baseada em coringa (.*) nos campos de exclusão de JS e de CSS.
  • Correção: Aumentada a duração para objetos apoiados no cache do navegador

1.1.1

  • Correção: Removido o uso de JS remoto. Agora usa a versão embutida das bibliotecas jQuery.

1.1.0

  • Adicionado: Configurações separadas opcionais de cache para subsites.

1.0.13

  • Correção: Validação de nonce.
  • Correção: Removidas chamadas duplicadas nas solicitações de esvaziamento do Varnish.

1.0.12

  • Correção: Obsolescência de create_function

1.0.11

  • Correção: Alterado wp_redirect para wp_safe_redirect para corrigir uma vulnerabilidade de redirecionamento de URL

1.0.10

  • Adicionado: Permitir o esvaziamento do cache para a função de Editor.

1.0.9

  • Adicionada: Opção para mover arquivo JS para o rodapé durante a minificação
  • Adicionada: Opção para atrasar o carregametno de arquivos JS
  • Adicionada: Opção para incluir CSS inline
  • Adicionada: Opção para incluir JS inline

1.0.8

  • Correção: Exclusão de cache para páginas que retornam código de status diferentes de 200

1.0.7

  • Correção: Problemas no Agrupamento e Minificação com o PHP 7.1
  • Correção: Problema no esvaziamento do cache após atualização de versão
  • Correção: Problema no aumento do tamanho do arquivo de cache.
  • Correção: Notificação de erro de servidor não encontrado
  • Correção: A exibição padrão dos comentários do WP não requer esvaziamento do cache

1.0.6

  • Correção: Todo o Multisite é agora gerenciado globalmente com as configurações sendo manejadas no nível da rede

1.0.5

  • Correção: Problema com a minificação de JS

1.0.4

  • Correção: Problemas do cache do navegador com a sessão do WooCommerce
  • Correção: Limpando as regras do Breeze no .htaccess do Gzip/Cache do navegador durante a desativação.
  • Correção: Corrigido o Regex para aceitar URLs de origem sem aspas ao ativar a minificação.
  • Adicionada: Seção de Perguntas Frequentes

1.0.3-beta

  • Correção: Cache do navegador desativado para as páginas do carrinho, loja e conta do WooCommerce
  • Correção: Remoção da compressão Gzip e Cache do navegador do .htacces na desativação destas opções
  • Correção: Problemas com o CDN não servindo todos os conteúdos configurados do serviço de CDN

1.0.2-beta

  • Correção: Problemas de compatibilidade com o WooCommerce

1.0.1-beta

  • Correção: Problema no esvaziamento para permitir apenas administradores esvaziarem
  • Adicionado: Link para Comentários

1.0.0

  • Adicionado: Primeiro lançamento Beta