Requisitos

Para executar o WordPress, recomendamos que a sua hospedagem suporte:

  • PHP versão 7.2 superior.
  • MySQL versão 5.6 ou superior ou MariaDB versão 10.0 ou superior.
  • Suporte HTTPS

E é isso. Nós recomendamos o Apache ou o Nginx como os servidores mais robustos e com mais funcionalidades para executar o WordPress, mas qualquer servidor com suporte a PHP e MySQL serve. Dito isso, nós não podemos testar toda possibilidade de ambiente e cada um dos servidores desta página oferece os itens acima e outros sem problemas.

Observação: Se você está em um ambiente legado onde só versões mais antigas do PHP e do MySQL estão disponíveis, o WordPress também funciona com PHP 5.2.4+ e MySQL 5.0+, mas estas versões chegaram oficialmente ao seu fim e, desta forma, podem expor o seu site à vulnerabilidades de segurança.

Pergunte sobre isso

Aqui está um texto que você pode enviar para o seu serviço de hospedagem, é só copiar e colar!

Estou interessado em executar o programa de código aberto WordPress <https://br.wordpress.org/> e gostaria de saber se a minha conta tem suporte ao seguinte:

  • PHP 7.2 ou superior
  • MySQL 5.6 ou superior ou MariaDB 10.0 ou superior
  • Nginx ou Apache com o módulo mod_rewrite
  • Suporte ao protocolo HTTPS

Obrigado!

Não obrigatório, mas recomendado por questão de segurança

A hospedagem é mais segura quando aplicações PHP, como o WordPress, são executadas usando o nome de usuário da sua conta, ao invés de usar o nome de usuário compartilhado padrão do servidor. Pergunte para a sua empresa de hospedagem em potencial sobre quais passos eles tomam para garantir a segurança da sua conta.