Respostas no Fórum

Visualizando 4 respostas - 1 até 4 (de um total de 4)
  • Pessoal, bom dia,

    Consegui Solucionar o problema e vou citar aqui os passos para isso. Espero muito poder ajudar outras pessoas, pois fiquei duas semanas com este problema e na internet tem várias soluções, mas no meu caso, mesmo tentando de tudo absolutamente, para mim não funcionou nenhuma. espero que possa ajudar alguém.

    Ok, eu estava fazendo o backup dos arquivos do site em um servidor Windows (Plesk), e subindo estes arquivos para uma VPS Linux. até aí tudo bem, eu copiava o .htacess padrão do wordpress para o servidor novo, atualizava as configurações no wp-config.php, e então ia no PhpMyadmin e restaurava o backup do banco normalmente. demorava um pouco, pois os bancos a maioria são bem grandes. ele subia o banco normal. mas, aparecia uns problemas estranhos, não reconhecia o banco, pois pedia para reinstalar o wordpress, outro não reconhecia os prefixos das tabelas caso tivesse letras maiúsculas, coisas assim bizarras que juro que tiraram meu sono.

    A Solução: Ontem decidi apelar, criei um banco vazio no servidor novo, fui lá no backup do banco que tinha feito no phpmyadmin do plesk (servidor antigo windows), abri o arquivo .sql no notepad++, subistituí todos os registros InnoDB para MyISAM, depois disso, acessei o mysql do servidor novo pelo programa gratuito oficial fornecido pela Oracle o “MySQL WorkBench” ele reconhece lá o banco de dados criado e vazio sem tabelas, e fui criando as tabelas uma por uma através dos scripts contidos no backup do banco. Depois de ter realizado os “create table”, foi a vez de executar os inserts, na sequencia que estava no arquivo, e por fim executei os comandos que cria as chaves e relacionamentos entre as tabelas do wordpress, isso está na parte final do arquivo de backup do banco mysql feito no antigo servidor.

    Feito isso, não precisa fazer mais nada, só atualizar o wp-config para o servidor novo, ter o .htacess padrão mesmo do wordpress e show! tá online e 100%.

    Nesse processo novo levei em torno de 1 hora à 1h e 40 para migrar um site, mas tá valendo, e foi isso que realmente resolveu.

    Me ocorre que foi algum problema na carga do backup do sql no phpmyadmin.

    Ah e para copiar os arquivos do site para o servidor novo, eu subi tudo zipado utilizei o programa 7zip para compactar e descompactei usando o gerenciador de arquivos do cpanel mesmo.

    Espero ter ajudado, se alguem tiver alguma duvida e de alguma forma der pra me procurar por esse forum, pode o fazer.

    Abraço, e muito obrigado pelas dicas de todos.

    Sim @felipeelia já fiz isso, renomeando a pasta plugins, mesmo assim continua com o mesmo comportamento.

    Olá @felipeelia

    Está idêntica ao que estava no servidor anterior. tabela capabilities -> a:2:{s:13:”administrator”;b:1;s:11:”operate_alc”;b:1;} . está igual no banco anterior.

    Tem alguma ideia amigo? nem sei mais o que pensar..

    O Curioso é que tenho outro site, que é uma loja e quando ele faz o login ele volta para a tela inicial como se fosse um cliente, entende, ele entra na area administrativa da loja como um cliente e tal, … mas não loga no painel do wordpress wp-admin.

    todos os sites estão com mesmo problema.

    • Esta resposta foi modificada 3 anos, 10 meses atrás por steliobecker.

    Felipe Obrigado pela resposta, O Problema foi resolvido, no wp-config.php, eu percebi que as tabelas tinham sido importadas com o prefixo todo minusculo, por exemplo: antes era : WpSite_, e importou wpsite_, por algum motivo, alterando isso no wp-config.php isso foi acertado e agora os sites abrem normalmente, Porém, apareceu um outro problema, ao acessar o /wp-admin, ele abre a tela para fazer login, eu coloco as credenciais de administrador, e ao clicar para logar , ele volta para a página home do meu site ao invés de ir para o painel de controle. se depois disso eu acesso novamente o /wp-admin ele diz “Sem permissão para acessar esta página.”, já fiz de tudo, li várias coisas na net sobre esse erro mas nenhum resolveu. muito estranho..

    • Esta resposta foi modificada 3 anos, 10 meses atrás por steliobecker.
Visualizando 4 respostas - 1 até 4 (de um total de 4)