Respostas no Fórum

Visualizando 8 respostas - 1 até 8 (de um total de 8)
  • Thread Starter maykelesser

    (@maykelesser)

    Vou fazer o teste aqui! Quanto menos código, sempre melhor!
    Muito obrigado! \o/

    Thread Starter maykelesser

    (@maykelesser)

    Bom dia @felipeelia, tudo bem?
    Alterei como sugeriu e funcionou perfeitamente <3

    Não entendi a sua questão após isso. Fiz dessa maneira, pois foi a maneira que consegui fazer dar certo, hehe. Não conheço outra! Se for mais simples que isso e tão flexível quanto, pode me instruir?

    Thread Starter maykelesser

    (@maykelesser)

    Oi @felipeelia, descobri o problema.

    Realmente, você estava certo! Eu mantenho esta instalação WP online, e outra na minha máquina local – esta última não tinha criado a página Home. Criei ela e funcionou! Apenas estava vendo no lugar errado.

    Muito, mas muito obrigado novamente! Problema resolvido! 😀

    • Esta resposta foi modificada 4 anos atrás por maykelesser.
    Thread Starter maykelesser

    (@maykelesser)

    @felipeelia, você não tem o que se desculpar! Já está fazendo um favor enorme! Agradeço de coração.

    Fazendo esta configuração, ambas “/” e “/blog” caem no archive.

    Cara, não sei se o problema é a criação do tema desde o início. Ele está bem simples, coloquei ele num FTP caso a analise dos códigos seja mais eficaz. Mas sinta-se livre para não fazer nada também – mas talvez vendo todo o escopo, te ajude a me ajudar 😀 Você não precisa mexer em nada no código, só apontar se possível o que estou fazendo de errado!

    Como é um tema de teste que estou criando, tem muita coisa pra aprender ainda.

    Thread Starter maykelesser

    (@maykelesser)

    @felipeelia, obrigado pela sua paciência! Tem sido um aprendizado!

    Testei a troca, e desta vez, ao acessar a página inicial, está trazendo o archive. Ao acessar o blog, dá certo, mas aí entramos no mesmo problema anterior, só que invertido!

    Na verdade, quando fiz o código acima, ele traz normalmente a index, mas não traz o archive – acaba trazendo a index também.

    Resumindo:

    Utilizando este código em home.php

    <?php
    	
    	if(is_home()){
    		get_template_part( 'index' );
    	}
    	else{
    		get_template_part( 'archive' );
    	}
    
    	die();
    
    ?>
    • Acessando “/”: OK, cai na index.
    • Acessando “/blog”: Cai na index.

    Utilizando este código:

    <?php
    	
    	if(is_front_page()){
    		get_template_part( 'index' );
    	}
    	else{
    		get_template_part( 'archive' );
    	}
    
    	die();
    
    ?>
    • Acessando “/”: Cai no archive.
    • Acessando “/blog”: OK, cai no archive.
    Thread Starter maykelesser

    (@maykelesser)

    Olá @felipeelia,

    Infelizmente não deu certo. Com isso, a minha página inicial (que é a index) também foi jogada para o archive. Tentei até fazer uma condicional verificando se a página ativa é a home ou não, mas sem sucesso.

    <?php
    	
    	if(is_home()){
    		get_template_part( 'index' );
    	}
    	else{
    		get_template_part( 'archive' );
    	}
    
    	die();
    
    ?>
    • Esta resposta foi modificada 4 anos atrás por maykelesser.
    Thread Starter maykelesser

    (@maykelesser)

    Olá @felipeelia! Obrigado pela resposta!

    Sim, agora está ficando um pouco mais claro. Também estou lendo a página de hierarquia de modelos pra ver se clareia a mente. Como sou bem iniciante no WordPress, muitos dos recursos eu não tenho familiaridade! Então, resolvi botar a mão na massa que desta maneira, aprendo melhor.

    Bom, vamos lá. Montei a minha index.php como se fosse realmente a página inicial. Ela é a página estática de abertura do site, e a configurei nas “Configurações de Leitura” também. Por via das dúvidas, dupliquei ela e a nomeei front-page.php também (acredito que isso não vá mudar nada, mas…).

    O que não consigo entender é o caminho para chegar no archive.php. Criei o arquivo, configurei a exibição da página /blog para a Página de Posts (conforme mostro abaixo) e não me traz nada.

    Reading Settings

    Como posso contornar para que, ao clicar na página Blog criada, caia no archive.php?

    Thread Starter maykelesser

    (@maykelesser)

    Olá @felipeelia, tudo bem?

    Eu já tinha visto este fluxograma, mas sinceramente, não entendi muito. Eu devo criar TODAS estas páginas? Acessei um tema de exemplo do próprio WordPress (o twentyseventeen) e o mesmo não tem o arquivo home.php… mas tem o archive. Hehe…

Visualizando 8 respostas - 1 até 8 (de um total de 8)