Respostas no Fórum

Visualizando 4 respostas - 1 até 4 (de um total de 4)
  • gbsantos1

    (@gbsantos1)

    @felipeelia

    Os warnings eu consegui resolver. Para quem usa hospedagem Locaweb é só fazer como está informando o link:
    https://wiki.locaweb.com.br/index.php?title=Session_em_PHP&redirect=no
    Para outras hospedagens provavelmente deve mudar somente o caminho da pasta de temporários(/tmp) o resto do processo deve ser igual.

    Tentei como Administrador e Autor.

    Detalhando mais o problema, quando eu cadastrei o primeiro usuário(administrador) ele foi salvo no banco com id=0
    Quando eu tentei cadastrar o próximo, no painel do WordPress me é mostrada a mensagem que o usuário foi adicionado com sucesso, mas eu olho no banco de dados e não tem nada lá.

    Já em localhost eu não tenho nenhum usuário com id=0 e eu consigo cadastrar novos usuários normalmente.

    Acho que é algum problema com o banco de dados, vou tentar criar outro e migrar os dados.

    @edit

    Criei um novo banco de dados e fiz a exportação/importação pelo PHPMyAdmin e resolveu. Não sei qual era o problema exatamente, é bem provável que tenha sido algum erro quando eu fui importar as tabelas e ela acabou ficando inconsistente.

    Obrigado pela força @felipeelia!!! 😀

    • Esta resposta foi modificada 2 anos atrás por gbsantos1.
    • Esta resposta foi modificada 2 anos atrás por gbsantos1.
    gbsantos1

    (@gbsantos1)

    Olá @felipeelia

    Eu informei incorretamente, na verdade o cadastro do usuário está sendo feito no banco de dados. E eu consigo logar com o usuário recém criado.
    Mas quando eu faço o login eu não tenho acesso ao painel administrativo, aquela barra cinza que mostra no topo da página não aparece.

    Quanto ao PHP estou tentando ver com minha hospedagem, pelas pesquisas que eu fiz esses warnings tem a ver com o session.save_path do PHP e você tem que configurar o diretório onde será gravado os dados de sessão(em um arquivo chamado php.ini) e as permissões do servidor. As vezes esse problema com o cadastro de usuário seja até por culpa desses warnings.

    • Esta resposta foi modificada 2 anos atrás por gbsantos1.
    • Esta resposta foi modificada 2 anos atrás por gbsantos1.
    gbsantos1

    (@gbsantos1)

    Era isso mesmo @felipeelia ! Eu não estava usando a função MD5 nas minhas querys 😀
    Consegui fazer a migração, agradeço as recomendações destes outros links.

    Novamente obrigado por responder!

    • Esta resposta foi modificada 2 anos atrás por gbsantos1.

    Entendi, obrigado pela resposta!

Visualizando 4 respostas - 1 até 4 (de um total de 4)