Respostas no Fórum

Visualizando 15 respostas - 16 até 30 (de um total de 39)
  • Criador do tópico f5atualizese

    (@f5atualizese)

    @felipeelia Quando atualizei os dados, apareceu numa tela em branco, a opção que eu selecionei. Por ex A tela branca com a palavra sim

    Criador do tópico f5atualizese

    (@f5atualizese)

    @felipeelia Obrigado por responder, muito bom, funcionou perfeitamente. Basicamente todos os campos atualizaram e permaneceram no banco de dados. Valewww….

    Só uma coisa, os campos radio: Já saiu e é assinante, quando escolho alguma opção e salvo, ele não grava. E quando entro novamente para ver se gravou ele aparece como se não tivesse escolhido nenhuma opção.

    • Esta resposta foi modificada 7 anos, 2 meses atrás por f5atualizese.
    • Esta resposta foi modificada 7 anos, 2 meses atrás por f5atualizese.
    Criador do tópico f5atualizese

    (@f5atualizese)

    Olá @mariovalney, boa noite! Só consegui fazer o procedimento agora no meu site.

    Agora deu certo, quando o cliente faz o cadastro no site através do Woo, a função guerreiro é definida no perfil dele, e ele consegue acesso em todas as funções do assinante.

    Obrigado pela ajuda brother, passei um sufoco com isso aqui, agora tem outro BÓ para resolver, vou esperar alguém responder no outro post que fiz rsrs…

    Aliás, você tem conhecimento nessa área?
    Dá uma olhada no link: https://br.wordpress.org/support/topic/woocommerce-formulario-de-atualizacao-de-cadastro/

    Se não tiver, não tem problema. Eu agradeço da mesma forma, já me ajudou pra caramba rs

    Abraços

    • Esta resposta foi modificada 7 anos, 2 meses atrás por f5atualizese. Razão: Inclusão de informações
    Criador do tópico f5atualizese

    (@f5atualizese)

    @mariovalney Me esqueci, no caso deste cadastro, a função do usuário ficou como Nenhuma. Nem Customer e nem Guerreiro.

    Criador do tópico f5atualizese

    (@f5atualizese)

    @mariovalney Implantei o código no functions.php e os emails que recebi foram os seguintes:

    Action rodou!

    Entrou no IF

    WP_User Object
    (
        [data] => stdClass Object
            (
                [ID] => 13953
                [user_login] => contato
                [user_pass] => $P$Bf4egKcidphseqIMcTR4CTkr1yu3Fp/
                [user_nicename] => contato
                [user_email] => contato@f5atualizar.com.br
                [user_url] =>
                [user_registered] => 2017-04-19 01:15:35
                [user_activation_key] =>
                [user_status] => 0
                [display_name] => contato
                [spam] => 0
                [deleted] => 0
            )
    
        [ID] => 13953
        [caps] => Array
            (
                [customer] => 1
            )
    
        [cap_key] => wp_capabilities
        [roles] => Array
            (
                [0] => customer
            )
    
        [allcaps] => Array
            (
                [read] => 1
                [plugin_delete_me] => 1
                [customer] => 1
            )
    
        [filter] =>
    )

    Usuário salvo com sucesso: 13953

    Criador do tópico f5atualizese

    (@f5atualizese)

    Mudei o tema de lugar, para plugins.

    Criador do tópico f5atualizese

    (@f5atualizese)

    @mariovalney Desculpe, não especifiquei muito bem. Quando eu tinha colocado o outro código, o site parou de abrir.

    Já esse segundo que você enviou, eu implantei sem problemas no functions.php. Acabei de fazer um teste de novo cadastro do cliente, fazendo o procedimento de compra de um produto por ex onde o cliente é novo no site e ele precisa fazer seu primeiro cadastro.

    Mas a função guerreiro não funcionou, não habilitou as funções deste tipo de usuário.

    Criador do tópico f5atualizese

    (@f5atualizese)

    Olá, @mariovalney tudo na boa… Obrigado por responder.

    Entendi, bom se eu puder acrescentar uma segunda função no usuário que faz seu cadastro através do Woocommerce melhor ainda. Essas funções que me referi são todas acessadas pelo Front, páginas personalizadas como, Minha Conta, Sair, opções no menu do topo do site, Favoritar um anúncio que o cliente tenha interesse e etc.

    Bom, enfim.

    Inseri o código no arquivo functions.php do meu tema, mas bugou tudo.

    Criador do tópico f5atualizese

    (@f5atualizese)

    @claudiosanches Vi que você estava trabalhando em cima de um projeto parecido, descobri depois de fazer algumas pesquisas. Rsrs Como está o desenvolvimento?

    Fórum: Plugins
    Em resposta a: Plugin Types
    Criador do tópico f5atualizese

    (@f5atualizese)

    @brgweb Temos funções de assinatura dentro do nosso site e estamos migrando nosso método de assinatura para um Plugin de Membros. Ele funciona juntamente com o Woocommerce e funciona perfeitamente.

    Quando temos uma página que precisa ser restrita para somente assinantes, mudamos as opções conforme imagem no link abaixo:

    https://drive.google.com/a/f5atualizese.com.br/file/d/0B4eYY-F_jzLBRW9CcFNWRHNtSk0/view?usp=sharing

    Dentro do Plugin Types, temos o método de assinatura antigo, que é extremamente falho e cheio de problemas.

    Por isso estamos descontinuando o uso deste método de assinatura. Dentro de alguma página/post ou tipo de post do types. Temos a área Premium.

    https://drive.google.com/a/f5atualizese.com.br/file/d/0B4eYY-F_jzLBazA3R1FUSkVrNUE/view?usp=sharing

    Nessa área temos a opção Conteúdo Exclusivo.

    O que precisamos é tirar essa área Conteúdo Exclusivo e inserir um shortcode, html ou php do Box de Acesso Restrito conforme o link da primeira imagem.

    Dentro do Types temos algumas opções e não conseguimos editar.

    A área Premium fica dentro de Campos Personalizados

    https://drive.google.com/a/f5atualizese.com.br/file/d/0B4eYY-F_jzLBZFhwaFFWM1dDbkE/view?usp=sharing

    Quando entramos nessa opção, podemos ver a configuração de todas as opções e um código HTML que possui as configurações da Área Premium, só que não somos liberados para edição.

    E dentro de Controle de Campos de Usuários temos centenas de opções, inclusive a área Premium.

    https://drive.google.com/a/f5atualizese.com.br/file/d/0B4eYY-F_jzLBLXI3MEF5eVUtT0E/view?usp=sharing

    Que também não somos liberados para edição/alteração.

    Precisamos editar essa área, porque alguns tipos de Posts cadastrados no Plugin Types, quando abrimos no Front, ele cria um “Link” de Extenção e é justamente alguns desses links que temos que ter a opção de bloquear ou não.

    • Esta resposta foi modificada 7 anos, 6 meses atrás por f5atualizese.
    Criador do tópico f5atualizese

    (@f5atualizese)

    @felipeelia Fiz esse procedimento inserindo o código include(TEMPLATEPATH.'/includes/options.php');

    E funcionou perfeitamente. Obrigado pela dica, assim o código fica mais limpo e mais segmentado, facilitando futuras manutenções.

    Obrigado pela ajuda galera, fica registrado meu agradecimento a todos e se precisarem de mim é só me gritar rs.

    Criador do tópico f5atualizese

    (@f5atualizese)

    Hummmm muito bom, vou fazer o teste, sem dúvidas é melhor para manutenções futuras, porque o arquivo functions.php ficou gigantesco com essa alteração. Vou fazer e postar aqui o resultado.

    Obrigado pela ajuda!

    Criador do tópico f5atualizese

    (@f5atualizese)

    Pessoal, boa tarde! Consegui solucionar o problema, depois de muito tempo. Vou tentar explicar de uma forma simples o que eu fiz para que as Opções do Tema funcionassem.

    Não foi necessário baixar e nem atualizar nenhum tipo de arquivo Tema ou do Odin

    Antigamente dentro do arquivo functions.php do tema, tinhamos alguns require_once()

    E uma dessas linhas tinha a seguinte chamada require_once('includes/options.php');

    o arquivo options.php Era o arquivo que continha as Opções do tema, Slug, Permissão, Abas, Conteúdos e etc.

    O que eu fiz, foi transferir todo esse conteúdo para o arquivo functions.php do Tema, feito isso as opções voltaram a aparecer na nova atualização do wordpress 4.6.1 e consequentemente a mensagem: Sem permissão para acessar esta página. parou de aparecer.

    Com isso resolvi um problema de mais de 3 meses.

    O que eu acho é que a nova atualização do WordPress não aceita configurações do tema em arquivos externos que não seja no functions.php Bom, posso estar errado. Mas minha conclusão foi essa.

    Obrigado a todos que de alguma forma tentaram me ajudar.

    Abraços.

    • Esta resposta foi modificada 7 anos, 7 meses atrás por f5atualizese.
    Criador do tópico f5atualizese

    (@f5atualizese)

    @luizlenomoraes Não existe clientes para o WordPress, o sistema é um sistema livre. Toda e qualquer personalização do sistema é por sua conta e risco. Agradeço pela iniciativa de ajudar, mas de fato você deveria pensar um pouco antes de escrever o que acha.

    Eu contratei um programador para solucionar o problema que estamos tendo, o tópico ainda esta aberto porque assim que o problema for solucionado, vou colocar o que foi feito aqui.
    Com o único e exclusivo objetivo de ajudar os que podem futuramente passar pelo mesmo problema.

    Criador do tópico f5atualizese

    (@f5atualizese)

    @luizlenomoraes já fiz esse procedimento e também não funcionou.

Visualizando 15 respostas - 16 até 30 (de um total de 39)