Respostas no Fórum

Visualizando 7 respostas - 1 até 7 (de um total de 7)
  • Criador do tópico alexgoncalvessp

    (@alexgoncalvessp)

    @felipeelia, sim sim. Eu entendi.
    O ponto que quis chegar foi: hoje o que está em produção e funcionando está tudo desatualizado.
    Se eu preservar wp-content, o arquivo .htaccess e o wp-config.php apenas e subir o conteúdo do wordpress para acessar a wp-login, irá pedir para que eu atualize o meu banco.
    Nesta etapa, acredito eu que por mexer no banco, eu possa ter algum problema no ambiente de produção.
    Seria o melhor dos mundos se eu tivesse como tirar um “snapshot” de lá, caso desse algum problema, simplesmente eu voltaria.

    Criador do tópico alexgoncalvessp

    (@alexgoncalvessp)

    @felipeelia eu fiz tudo em localhost… quando subi os conteúdos do Worpress, me pediu até para atualizar o banco, pois a versão que tinha era anterior.
    Não sei se seria uma boa ideia fazer isso em produção e eu tirar o site totalmente do ar.
    Estou montando uma vm em Linux, e vou verificar se terei o mesmo problema lá.

    Criador do tópico alexgoncalvessp

    (@alexgoncalvessp)

    Bom dia!
    @felipeelia, fiz as recomendações.
    Consegui abrir a página do wp-login.php, e acessar normalmente.
    Porém quando tendo acessar o localhost:8080/site continua entrando em loop.

    Já não sei mais o que fazer para corrigir esse problema.

    Obrigado!

    Criador do tópico alexgoncalvessp

    (@alexgoncalvessp)

    @felipeelia nosso site foi invadido. Não consigo acessar a página do WP-LOGIN.PHP, deve ter corrompido alguma coisa. Por isso estou trazendo para local.
    Não sou eu quem administrava, daí estou dando um help para o pessoal.

    Criador do tópico alexgoncalvessp

    (@alexgoncalvessp)

    Voltei o .htaccess e alterei novamente somente as linhas.
    Agora diz no Mozilla: Redirecionamento incorreto
    IE: erro 301 quando debugo.

    Criador do tópico alexgoncalvessp

    (@alexgoncalvessp)

    Bom dia!
    @felipeelia fiz as alterações:


    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at postmaster@localhost to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.4.25 (Win32) OpenSSL/1.0.2j PHP/5.6.30 Server at localhost Port 8080″;

    Referente ao meu update:

    If you do a search and replace on your entire database to change the URLs, you can cause issues with data serialization</blockquote

    Utilizei a ferramnenta “Search and Replace for WordPress Databases Script” mencionada na própria documentação.

    Obrigado mais uma vez.

    Alex Gonçalves

    • Esta resposta foi modificada 6 anos, 10 meses atrás por alexgoncalvessp.
    Criador do tópico alexgoncalvessp

    (@alexgoncalvessp)

    Bom dia!
    Obrigado pela resposta @felipeelia.
    Eu utilizei parte desse tutorial para migração também.

    O .htaccess está da seguinte maneira:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Talvez o problema esteja nele, criei um diretório “site” para deixar o conteúdo do site.

    A tabela “wp_options” atualizei o “siteurl” e “home” para “http://localhost:8080/site/&#8221;

    As demais tabelas que possuíam apontamento para produção, também dei um update.

    Obrigado,

    Alex

Visualizando 7 respostas - 1 até 7 (de um total de 7)