Suporte » Plugins » WP Security Scan fazendo injection… depois do WP 3.4

  • Resolvido ValterTF

    (@valtertf)


    Colegas de fórum, estou com um problema no meu WP depois que atualizei para o 3.4. Já faz algum tempo que venho utilizando o WP com os plugins “Code Styling Localization” e “WP Security Scan” sem qualquer problema.. depois do WP 3.4 e de várias atualizações de plugins e tema (do repositório WP), recebi uma mensagem de erro.

    Hoje notei um problema na tradução e fui verificar no “Ferramentas->Localização” onde estava o erro, se havia algum problema e recebi a seguinte mensagem de erro:

    Scripting Guard [ details ] The Plugin Codestyling Localization was forced to protect its own page rendering process against 5 incidents !

    Seguem os detalhes:

    Malfunction at 3rd party Plugin detected!
    Name: WP Security Scan | Author: WebsiteDefender
    Below listed scripts has been automatically stripped because of injection:
    
    http://...com.br/wp-content/plugins/wp-security-scan/js/json.js
    http://...com.br/wp-content/plugins/wp-security-scan/js/md5.js
    http://...com.br/wp-content/plugins/wp-security-scan/js/scripts.js
    http://...com.br/wp-content/plugins/wp-security-scan/js/wsd.js
    
    Malfunction at 3rd party inlined Javascript(s) detected!
    Reason: javascript runtime exception | Polluter: desconhecido
    Below listed exception(s) has been caught and traced:
    wsdPassStrengthProvider is not defined

    Procurei em vários fóruns (aqui na comunidade, nos dois desenvolvedores e no WP.org em inglês) mas ainda não encontrei nada. Alguém aqui também esta com este problema? Agradeço qualquer sugestão.
    Valter

Visualizando 7 respostas - 1 até 7 (de um total de 7)
  • Myst1010

    (@myst1010)

    aqui está normal, tente reinstalar o plugin, ou desativar e ativar novamente para ver se volt ao normal.

    Criador do tópico ValterTF

    (@valtertf)

    Desativar e reativar e mesmo reinstalar não funcionaram.
    Verifiquei em outros dois Blogs que atualizo, e o mesmo ocorreu. Outro plugin (T(-) Countdown) também provocou o mesmo aviso de erro do Codestyling Localization no outro Blog.

    Criador do tópico ValterTF

    (@valtertf)

    Se eu desinstalar e reinstalar o Codestyling Localization, perco minhas alterações nos arquivos .mo e .po?

    Myst1010

    (@myst1010)

    Por padrão não perde nada não, mas como está dando erros estranhos é bom se precaver fazendo um backup antes de tentar.

    Criador do tópico ValterTF

    (@valtertf)

    Conversei com o suporte da minha hospedagem, e pedi que instalasse um WP do zero com os dois plugins – todos atualizados, no mesmo servidor que o meu site e em outro servidor. Em ambas as instalações o erro foi reproduzido. Reinstalar não irá resolver pelo visto.

    Creio que alguma atualização de um dos dois plugins tornou estes dois incompatíveis. Como o plugin T(-) Countdown também está gerando o mesmo erro, creio que o problema seja no Codestyling Localization.

    Olá ValterTF, só retificando uma coisa que não respondi corretamente.

    O plugin Codestyling Localization depois e traduzir algum plugin ou tema e depois de salvar e colocar os arquivos para seus devidos lugares nem é mais necessário ficar instalado em seu sistema.

    Ele serve para traduzir, mas ele não é necessário para se manter a tradução, então se ele está causando problema, mas você já traduziu tudo que queria desinstale ele, pois não é mais necessário.

    Criador do tópico ValterTF

    (@valtertf)

    Olá Myst1010. Com as novidades da nova versão do WP, muita coisa nova precisa ser traduzida. Vou seguir a sua ideia, mas ao invés de desinstalar vou desativá-lo. Provavelmente novas traduções serão necessárias no futuro.

    Obrigado pela dica!

Visualizando 7 respostas - 1 até 7 (de um total de 7)
  • O tópico ‘WP Security Scan fazendo injection… depois do WP 3.4’ está fechado para novas respostas.