• Bom dia galera, eu tenho um site que estava hospedado na revenda Plesk da Locaweb.
    Aí migrei para o CPANEL da própria Locaweb. Agora eu consigo me logar, mas além da barra do admin não estar completa (para dar acesso ao painel do WP, criar página, etc) eu não consigo entrar no painel nem criar nada. Fiz essa migração com 13 sites, só 2 estão com esse problema…os outros estão de boa.

    Alguém tem ideia? Brigadão desde já!!

    http://bellapizzaatibaia.com.br/
    http://nursingathome.com.br/

    • Este tópico foi modificado 1 mês, 1 semana atrás por  neryes.
    • Este tópico foi modificado 1 mês, 1 semana atrás por  neryes.
Visualizando 15 respostas - 1 até 15 (de um total de 18)
  • Moderador Felipe Loureiro dos Santos

    (@felipeloureirosantos)

    Olá, tudo bem?

    Como você fez a migração? A Localweb que fez, migrou tudo manualmente ou utilizando algum plugin de migração?

    Considerando que no seu plano anterior estava funcionando e agora não está, então recomendo que entre em contato com a sua empresa de hospedagem e eles poderão lhe ajudar melhor.

    Fiz tudo manualmente.
    Via FTP
    – fiz o backup do site da revenda antiga
    – fiz o backup do banco de dados da revenda antiga
    – criei o domínio na revenda nova
    – subi o site na revenda nova
    – subi o banco de dados na revenda nova
    – alterei o wp-config.php

    Da mesma forma que os outros sites.

    A Locaweb não presta esse suporte. O máximo que eles me falam é que o problema é com a aplicação e que é para entrar em contato com o meu desenvolvedor. No caso sou eu mesmo.

    Moderador Felipe Loureiro dos Santos

    (@felipeloureirosantos)

    Considerando que é uma empresa de hospedagem gerenciada, eles deveriam oferecer este suporte. Recomendo que repense se está hospedando o seu site no lugar certo. 😉

    O primeiro passo é descobrir o que está causando este erro.

    Podemos começar renomeando a pasta do seu tema, de themes para _themes. Para isso, acesse o seu gerenciador de arquivos, em seguida, acesse /wp-content/. Isso vai desativar o seu tema. Caso o seu problema seja no seu tema, você vai voltar a ter acesso ao seu painel do WordPress.

    Se isso não resolver, tente fazer a mesma coisa com a pasta do seu plugin. Vá até /wp-content/ novamente, renomeie de plugins para _plugins. Tente acessar o painel novamente, e depois os plugins. Ele vai desativar todos os seus plugins, se o problema for em algum plugin, então o seu problema vai ser liquidado. Se o problema se resolver, basta renomear para o nome anterior, e ativar cada plugin, um por um, até descobrir qual está causando o problema.

    Obrigado pela ajuda cara, ainda continuo com o problema. Eu fiz o que vc falou e o que mudou foi que só ficou tela branca. Aí eu resolvi remover o site e o banco e começar tudo de novo.

    – Instalei WP novo e subi o banco.
    – Subi depois os diretórios wp-content e wp-includes do backup.

    Continuou com o mesmo problema, eu logo mas não entro na dash do WordPress.

    Moderador Felipe Loureiro dos Santos

    (@felipeloureirosantos)

    Onde ficou a tela branca? Ao acessar o painel administrativo?

    Se você renomeou o plugins e themes e mesmo assim não funcionou ao acessar o painel, então o problema é com a sua instalação do WordPress.

    Ficou tela branca qdo tentei acessar o site normalmente. O painel sem chance mesmo.

    Moderador Felipe Loureiro dos Santos

    (@felipeloureirosantos)

    Sim, como você informou que não conseguia acessar o painel, então meu foco é em recuperar o seu acessar ao painel.

    Você consegue confirmar exatamente o que fez?

    Peço que verifique se fez exatamente isso.

    Então, eu fiz com vc falou.

    Eu renomeei a pasta do tema para _themes, e tentei acessar o site e o painel mas a tela ficou branca.

    Aí eu voltei ao nome normal da pasta do tema e renomeei a pasta plugins para _plugins. O site voltou mas com a barra do menu incompleta ainda. Como se eu não fosse o adm e sim um assinante que tem poucos privilégios.

    Aqui um print de como está a barra
    https://i.imgur.com/JLzC4ci.jpg

    • Esta resposta foi modificada 1 mês, 1 semana atrás por  neryes.
    Moderador Felipe Loureiro dos Santos

    (@felipeloureirosantos)

    Sim, é normal que o site não funcione se usar _themes, porque o WordPress não encontra nenhum tema. Isso é apenas para você recuperar o acesso ao seu painel do WP.

    Peço que coloque renomeie ao mesmo tempo, _plugins e _themes.

    Caso ainda não consiga ter acesso, peço que baixe a versão mais recente do WordPress e troque todos os arquivos da raiz do seu site no seu gerenciador de arquivos com exceção do diretório wp-content e do arquivo wp-config.php.

    Ta difícil cara rsrs

    Eu nomeei as duas e não obtive sucesso.
    Fiz a instalação do novo WP como vc falou e a barrinha continuou limitada.

    Pensei que talvez fosse questão de privilégios de usuário e criei mais um como admin (no phpMyAdmin), mas não mudou nada a barrinha. Qdo eu clico no nome do usuário, não abre opção nem para editar meu nome. Apenas opção de sair.

    https://i.imgur.com/egSTI3Q.jpg

    Cara, to achando q o problema está envolvido com um plugin Rename wp-login.php.
    Porque um terceiro site que acabei de subir está com o mesmo problema que esses que mencionei. Mas eu já renomeei a pasta desse plugin, em outro site já deletei ele e nada mudou. É só um palpite…não sei se tem realmente a ver.

    Moderador Felipe Loureiro dos Santos

    (@felipeloureirosantos)

    Sim, pode ser. Contudo, se você o plugin está desativado e o problema continua, então não sei se seria o caso.

    Vou compartilhar o seu problema com outros voluntários da equipe de suporte, talvez alguém consiga lhe ajudar.

    Moderador Ralden Souza

    (@ralden)

    saudações @neryes,

    talvez eu não tenha entendido o problema. os 2 links que passou estão com acesso ok para o /wp-admin/.

    quando você diz “eu consigo me logar, mas além da barra do admin não estar completa (para dar acesso ao painel do WP, criar página, etc) eu não consigo entrar no painel nem criar nada”, isso me leva a crer que o usuário que você está logando não é um Administrador.

    você disse que criou um novo usuário admin e não resolveu. por descargo de consciência, vou deixar o link abaixo sobre a criação de usuário via phpMyAdmin,

    https://www.wpbeginner.com/wp-tutorials/how-to-add-an-admin-user-to-the-wordpress-database-via-mysql/

    a outra possibilidade envolve justamente a forma como fez esse migração. talvez você não saiba, mas a forma como são configuradas as pastas no servidor pelo Plesk e pelo cPanel são COMPLETAMENTE diferentes. eu sou usuário Plesk e quando migro clientes vindo o cPanel preciso ter uma série de cuidados e observações.

    na minha experiência, o melhor método que encontrei para fazer essa migração foi com o plugin Duplicator. pois no site antigo ele gera 2 arquivos para a migração. ai no servidor novo o plugin identifica os detalhes do servidor e até do domínio que vai ser usado (dai ser ótimo para clonar sites).

    com isso, ao migrar o site, o duplicator já atualiza o banco de dados com todos os caminhos de pasta atualizados para o novo sistema, seja o Plesk no meu caso, seja o cPanel no seu caso.

    da forma como fez, provavelmente o caminho no banco de dados para as regras de usuário está apontando para um caminho errado. e por isso você entra, mas não recebe os privilégios de Administrador.

    por exemplo, no caso do Plesk você pode ver a estrutura de diretório para site na documentação abaixo,

    https://docs.plesk.com/en-US/onyx/administrator-guide/68695/

    eu ACHO (repito, eu ACHO) que precisaria corrigir no banco de dados a estrutura de pastas que veio do Plesk e mudar para a estrutura do cPanel. pois percebo isso em algumas configurações de plugins quando migro do cPanel para o Plesk, preciso fazer essa revisão nas opções de configuração de alguns plugins (como cache), pois nisso o Duplicator não mexe.

    claro que isso leva à questão de porque só deu errado com esses 2 sites. e aqui há uma grande possibilidade de variáveis, como nos outros sites o usuário é admin, enquanto nesses 2 é outro usuário e esse usuário, na migração não ficou como admin devido essa questão da estrutura de diretórios. fora outras possibilidades.

    se você tiver backup desses sites, especialmente de um plugin tipo o UpdraftPlus, indicaria tentar restaurar com os backups. pois ter usado essa metodologia de migração “na unha”, diretamente com arquivos e banco de dados, não é melhor escolha devido a mudança de sistema de servidor de Plesk para cPanel, o que afeta E MUITO a organização de diretórios do servidor.

    boa sorte.

    neryes

    (@neryes)

    Fala @ralden, obrigado pelo feedback.

    Parece como se eu não fosse o Administrador do site. Mas em ambos sites eu sou o Administrador.

    Segui um tutorial parecido com esse que vc mandou (para cadasrar um usuário Administrador) e tbm refiz com esse que vc mandou mas continua do mesmo jeito a barrinha.

    Sobre a parte de migração de Plesk para cPanel, eu já removi do Plesk os sites, e como não consigo logar, não tenho como instalar o Duplicator. Eu posso copiar o Duplicator de outro site q eu tenho e subir no site q está dando esse problema?

    Uma suspeita que tive foi do plugin rename wp-login. A semelhança entre esses sites é que esse plugin está instalado neles.

    Brigadão!!!

    • Esta resposta foi modificada 1 mês atrás por  neryes.
    neryes

    (@neryes)

    @felipeloureirosantos cara muito obrigado mesmo!

    Infelizmente nenhum progresso ainda.

Visualizando 15 respostas - 1 até 15 (de um total de 18)
  • Você deve estar conectado para responder a este tópico.