Suporte » Instalando o WordPress » WordPress não instala em localhost

  • Resolvido bobbreno07

    (@bobbreno07)


    Olá!

    Acabei de comprar um notebook com windows 10 home single language 64 bits e tentei instalar o wordpress em localhost via Easyphp v17 e Xampp mas sem sucesso.

    Faço tudo corretamente, sigo os seguintes tutoriais:

    EASYPHP

    XAMPP

    Mas sempre dar o este erro:

    Erro ao estabelecer uma conexão com o banco de dados
    Isto indica que seu nome de usuário ou senha estão incorretos em seu arquivo wp-config.php ou que nós não conseguimos contatar o servidor de banco de dados em localhost. Isso pode indicar que seu servidor de banco de dados está fora do ar.

    Você tem certeza que o seu nome de usuário e a senha estão corretos?
    Você tem certeza de que digitou o nome do host correto?
    Você tem certeza que o servidor de banco de dados está funcionando?
    Se você não tem certeza do significado desses termos, sugerimos que contate sua hospedagem. Se mesmo assim você precisar de ajuda, você sempre poderá visitar os fóruns de suporte do WordPress.

    Só lembrando que o notebook é novo e o que instalei nele foi o avast premium, malwarebytes premium e java 8.

    DÚVIDAS:
    É necessário instalar algum componente para rodar estes programas?
    Será que o firewall do windows ou dos antivírus estão bloqueando a conexão?
    Porque não consigo concluir a instalação?

    OBS: Tinha o Skype instalado mas desinstalei.

    Se alguém souber como resolver, por gentileza explica direito e em uma linguagem compreensível, pois não sou programador e também não entendo muito de programação.

    Obrigado!

Visualizando 15 respostas - 1 até 15 (de um total de 16)
  • Bom dia @bobbreno07,

    Primeiramente acesse o php admin (provavelmente a url seja localhost/phpmyadmin).

    Veja se a página é exibida normalmente e se o seu banco de dados aparece na lista. Se necessário crie outro banco.

    Na tela de instalação do WP, você deve colocar o servidor (localhost), nome do banco de dados e o login e a senha para acessa-lo. Geralmente o usuario é root e a senha vc deixa em branco.

    Se puder grava um vídeo da sua instalação e mostra os erros pra gente verificar.

    bobbreno07

    (@bobbreno07)

    Boa noite @dotrex

    Não possível acessar pela url “localhost/phpmyadmin” dá o seguinte erro: Not Found
    The requested URL /phpmyadmin was not found on this server.
    Eu acesso via “http://127.0.0.1/eds-modules/phpmyadmin470x180114191530” e crio o banco de dados lá.

    Já fiz tudo isto que você falou, mas sem sucesso.
    Segue um vídeo que fiz https://drive.google.com/file/d/1o52Ir_uhu5qbr_5IxYE48P5JXtWgn9ij/view?usp=sharing

    OBS: já havia instalado o programa na máquina mas o processo de instalação é o normal: Instalei o EasyPHP v17 e coloquei o wordpress na pasta eds-www

    • Esta resposta foi modificada 5 meses atrás por  bobbreno07.
    • Esta resposta foi modificada 5 meses atrás por  bobbreno07.
    • Esta resposta foi modificada 5 meses atrás por  bobbreno07.
    • Esta resposta foi modificada 5 meses atrás por  bobbreno07.

    @@bobbreno07 Experimenta deletar o wp-config da sua pasta do WordPress e fazer a instalação novamente. Aparentemente ocorreu algum erro durante alguma instalação anterior.

    Se não der certo, crie uma nova pasta e um novo banco de dados (ex: wordpress2) e tenta a instalação novamente.

    Se ainda não der certo, experimente colocar 127.0.0.1:1111 no lugar de localhost (na instalação do WP).

    • Esta resposta foi modificada 5 meses atrás por  Diego Pereira.
    florisvaldo

    (@florisvaldo)

    O meu também da esse mesmo erro… não consegui resolver com as dicas acima

    bobbreno07

    (@bobbreno07)

    @dotrex

    Fiz tudo que você pediu pra fazer, porém, novamente sem sucesso.
    Realmente não sei o que está acontecendo.
    Acho que tem que editar algum arquivo e talvez mudar o caminho de alguma pasta…mas não tenho o conhecimento para fazer.

    Moderador Felipe Elia

    (@felipeelia)

    Oi @bobbreno07,

    Você chegou a tentar trocar o servidor para 127.0.0.1 ao invés de localhost? Ao instalar, você configurou alguma senha para o usuário root do banco de dados?

    bobbreno07

    (@bobbreno07)

    Boa noite @felipeelia!

    Já troquei o servidor e nada…quanto as configurações, não mexi em nada, deixei do jeito que baixei o wordpress e também o easyphp.

    Segue abaixo as configurações do arquivo wp-config e também um print do PHPmyadmin:

    <?php
    /**
    * As configurações básicas do WordPress
    *
    * O script de criação wp-config.php usa esse arquivo durante a instalação.
    * Você não precisa usar o site, você pode copiar este arquivo
    * para “wp-config.php” e preencher os valores.
    *
    * Este arquivo contém as seguintes configurações:
    *
    * * Configurações do MySQL
    * * Chaves secretas
    * * Prefixo do banco de dados
    * * ABSPATH
    *
    * @link https://codex.wordpress.org/pt-br:Editando_wp-config.php
    *
    * @package WordPress
    */

    // ** Configurações do MySQL – Você pode pegar estas informações
    // com o serviço de hospedagem ** //
    /** O nome do banco de dados do WordPress */
    define( ‘DB_NAME’, ‘nome_do_banco_de_dados_aqui’ );

    /** Usuário do banco de dados MySQL */
    define( ‘DB_USER’, ‘nome_de_usuario_aqui’ );

    /** Senha do banco de dados MySQL */
    define( ‘DB_PASSWORD’, ‘senha_aqui’ );

    /** Nome do host do MySQL */
    define( ‘DB_HOST’, ‘localhost’ );

    /** Charset do banco de dados a ser usado na criação das tabelas. */
    define( ‘DB_CHARSET’, ‘utf8’ );

    /** O tipo de Collate do banco de dados. Não altere isso se tiver dúvidas. */
    define( ‘DB_COLLATE’, ” );

    /**#@+
    * Chaves únicas de autenticação e salts.
    *
    * Altere cada chave para um frase única!
    * Você pode gerá-las
    * usando o {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org
    * secret-key service}
    * Você pode alterá-las a qualquer momento para invalidar quaisquer
    * cookies existentes. Isto irá forçar todos os
    * usuários a fazerem login novamente.
    *
    * @since 2.6.0
    */
    define( ‘AUTH_KEY’, ‘coloque a sua frase única aqui’ );
    define( ‘SECURE_AUTH_KEY’, ‘coloque a sua frase única aqui’ );
    define( ‘LOGGED_IN_KEY’, ‘coloque a sua frase única aqui’ );
    define( ‘NONCE_KEY’, ‘coloque a sua frase única aqui’ );
    define( ‘AUTH_SALT’, ‘coloque a sua frase única aqui’ );
    define( ‘SECURE_AUTH_SALT’, ‘coloque a sua frase única aqui’ );
    define( ‘LOGGED_IN_SALT’, ‘coloque a sua frase única aqui’ );
    define( ‘NONCE_SALT’, ‘coloque a sua frase única aqui’ );

    /**#@-*/

    /**
    * Prefixo da tabela do banco de dados do WordPress.
    *
    * Você pode ter várias instalações em um único banco de dados se você der
    * um prefixo único para cada um. Somente números, letras e sublinhados!
    */
    $table_prefix = ‘wp_’;

    /**
    * Para desenvolvedores: Modo de debug do WordPress.
    *
    * Altere isto para true para ativar a exibição de avisos
    * durante o desenvolvimento. É altamente recomendável que os
    * desenvolvedores de plugins e temas usem o WP_DEBUG
    * em seus ambientes de desenvolvimento.
    *
    * Para informações sobre outras constantes que podem ser utilizadas
    * para depuração, visite o Codex.
    *
    * @link https://codex.wordpress.org/pt-br:Depura%C3%A7%C3%A3o_no_WordPress
    */
    define( ‘WP_DEBUG’, false );

    /* Isto é tudo, pode parar de editar! 🙂 */

    /** Caminho absoluto para o diretório WordPress. */
    if ( ! defined( ‘ABSPATH’ ) ) {
    define( ‘ABSPATH’, dirname( __FILE__ ) . ‘/’ );
    }

    /** Configura as variáveis e arquivos do WordPress. */
    require_once( ABSPATH . ‘wp-settings.php’ );
    ————————————————————–
    LINK DO PRINT: https://prnt.sc/i2vl31

    • Esta resposta foi modificada 5 meses atrás por  bobbreno07.
    Moderador Felipe Elia

    (@felipeelia)

    Oi @bobbreno07,

    Desculpa a pergunta, mas você alterou o conteúdo do wp-config.php para colar aqui? Ele deveria estar assim:

    /** O nome do banco de dados do WordPress */
    define( 'DB_NAME', 'wordpress' );
    
    /** Usuário do banco de dados MySQL */
    define( 'DB_USER', 'root' );
    
    /** Senha do banco de dados MySQL */
    define( 'DB_PASSWORD', '' );
    
    /** Nome do host do MySQL */
    define( 'DB_HOST', '127.0.0.1' );
    Moderador Felipe Elia

    (@felipeelia)

    Outra coisa, @bobbreno07, é ver a configuração que o phpMyAdmin está usando. O arquivo de configuração dele se chama, se não me engano, config.inc.php e fica na raíz do phpmyadmin (deve estar nos Arquivos de Programa do Windows, se você ainda está usando o Easy Engine).

    bobbreno07

    (@bobbreno07)

    @felipeelia

    Este é o arquivo wp-config que veio originalmente no wordpress que baixei, não alterei nada. Mas, eu acabei de alterá-lo e funcionou!!!

    Coloquei do jeito que você passou:

    /** O nome do banco de dados do WordPress */
    define( 'DB_NAME', 'wordpress' );
    
    /** Usuário do banco de dados MySQL */
    define( 'DB_USER', 'root' );
    
    /** Senha do banco de dados MySQL */
    define( 'DB_PASSWORD', '' );
    
    /** Nome do host do MySQL */
    define( 'DB_HOST', '127.0.0.1' );

    Finalmente consegui instalar o wordpress no meu pc!

    Muito obrigado @felipeelia e também, obrigado @dotrex pela contribuição!

    Post resolvido!

    Boa tarde,

    Não estou conseguindo fazer a instalação em localhost, pois aparece ‘Erro em banco de dados’. Há uma semana que estou seguindo as recomendações e sem sucesso.

    Por favor

    Moderador Felipe Elia

    (@felipeelia)

    Olá @agnesrh,

    Se você seguiu os passos daqui e não resolveu, peço que você abra um outro tópico detalhando o que já fez e o que já tentou, para que o pessoal consiga te ajudar melhor, beleza?

    Estou com o mesmo problema, será que é essa nova versão do wordpress. Por curiosidade instalei o wordpress no subdominio marketplace.ehead.com.br e mesmo usando um banco de dados real hospedade não funcionou. O QUE pode ser isso?

    Descobri o problema. Por algum motivo esta última versão do wordpress gerar um arquivo wp-config.php com dados “default”, mesmo preenchendo os dados do banco corretamente.
    Algum administrador pode passar isso para os editores Brasil

    Moderador Felipe Elia

    (@felipeelia)

    Oi @ehead,

    Você instalou pelo painel da sua hospedagem ou pelo passo a passo do próprio WordPress?

    E o acesso ao sistema internacional de tickets do WordPress é aberto a todos: https://core.trac.wordpress.org. Se você tem certeza de que o problema é na plataforma, você mesmo pode ir lá e criar um tópico descrevendo o seu problema 🙂

Visualizando 15 respostas - 1 até 15 (de um total de 16)
  • Você deve estar logado para responder a este tópico.