Suporte » Outros assuntos » WordPress não funciona em PHP acima de 7.1

  • Minha instalação do WordPress não funciona em versão do php acima de 7.1.

    Quando eu defino qualquer versão acima desta recebo o erro:

    Warning: Use of undefined constant WP_CONTENT_DIR – assumed ‘WP_CONTENT_DIR’ (this will throw an Error in a future version of PHP) in /home/user/public_html/site/wp-includes/load.php on line 141
    Parece que em sua instalação do PHP está faltando a extensão MySQL, que é requisitada pelo WordPress.

    Deprecated: Directive ‘allow_url_include’ is deprecated in Unknown on line 0

    * Outros sites hospedados no mesmo Cpanel não apresentam o erro.
    * Um site recém instalado, não apresenta o erro.

    Eu ja tentei:
    * Desativar todos os plugins.
    * Definir o tema padrão.
    * Reinstalar o WordPress.
    * Copiar arquivos de outro site que estava funcionando.

    Nada resolveu.

    Acredito que seja algo no banco de dados. não tem outra explicação.

    • Este tópico foi modificado 5 meses, 2 semanas atrás por delaitec.
Visualizando 3 respostas - 1 até 3 (de um total de 3)
  • victorpeixoto

    (@victorpeixoto)

    Estou com um problema idêntico, não consegui resolver.
    Você conseguiu?

    delaitec

    (@delaitec)

    Infelizmente nao, tive que reinstalar o site por completo.

    Basta alterar o PHP na sua hospedagem para herdado ou inherit que o sistema identifica a versão herdada e funciona normalmente.

Visualizando 3 respostas - 1 até 3 (de um total de 3)
  • Você deve estar conectado para responder a este tópico.