Suporte » Ajustando o WordPress » WordPress não consegue atualizar

  • Andresh

    (@andresh)


    Estou tendo problemas quando tento adicionar plugins/temas/etc ou mesmo atualizar o wordpress e/ou plugins.

    Quando tento realizar qualquer dessas tarefas dentro do Painel o WordPress retorna o erro:
    O pacote não pôde ser instalado. O pacote não contém arquivos.
    (ou para o caso de plugins)
    O pacote não pôde ser instalado. O plugin não contém arquivos.

    Se tento fazer upload do arquivo .zip pelo WordPress encontro o erro:
    Não foi possível criar o diretório wp-content/uploads/2014/09. O diretório pai possui permissão de escrita?

    Este último indica que o problema pode ser algum problema de permissão, porém a única alteração que fiz foi no wp-config.php

    define('FS_METHOD', 'ftpext');
    define('FTP_BASE', '/BASE/');
    define('FTP_CONTENT_DIR', '/BASE/wp-content/');
    define('FTP_PLUGIN_DIR ', '/BASE/wp-content/plugins');
    define('FTP_USER', 'user');
    define('FTP_PASS', 'pass');
    define('FTP_HOST', 'host');

    Sem essa alteração o wordpress não encontra o diretório de instalação e nem o diretório wp-content, assim como pede sempre o login do FTP.

    Minha pergunta é: O que tenho q fazer para garantir que o WordPress tenha permissão para ele poder manipular os arquivos e/ou diretórios?

Visualizando 1 resposta (de um total de 1)
Visualizando 1 resposta (de um total de 1)
  • O tópico ‘WordPress não consegue atualizar’ está fechado para novas respostas.