Suporte » Plugins » woocommerce – Problemas com o campo Estado

  • Resolvido adassoft

    (@adassoft)


    Tenho uma loja usando o Woocommerce juntamente com WordPress. Estava funcionando perfeito, porém após fazer a atualização para a versão 2.3.5 do Woocommerce apareceu um problema no formulário de cadastro de clientes.

    Quando o site é acessado utilizando o Internet Explorer, ao clicar bo botão Finalizar compra, apágina já abre com o campo Estado selecionado e não conseguimos sair dele dessa forma não é possível fechar o pedido. Já no Firefox esta funcionando normalmente.

    Alguém poderia mim ajudar nessa questão?

Visualizando 15 respostas - 1 até 15 (de um total de 17)
  • Moderador Claudio Sanches

    (@claudiosanches)

    Já tentou com outros templates?
    Qual versão do internet explore?

    Sim testei vários temas o problema está acontecendo com todos os temas.
    O problema está acontecendo com o IE 11 (11.0.9600.17031)

    Na versão 9 do IE está funcionando normalmente.

    Aparentemente o problema apareceu depois que atualizei o WordPress para a versão 4.1.1 e o woocommerce para a versão 2.3.5

    Moderador Claudio Sanches

    (@claudiosanches)

    Já tentou usar as ferramentas de debug do IE para ver se tem algum erro de JavaScript aparecendo?

    Sim, utilizei as ferramentas do IE, não encontrei erro, talvez por não ter muita prática com essa ferramenta, o endereço do site é http://www.adassoft.com.br o problema aparece quando é clicado no botão finalizar compra.

    Se alterar o campo Estado colocando o mesmo igual o campo País, sem a função de pesquisar no campo, talvez funcionaria, mas não onde mexer.

    O mesmo problema aqui, trava no campo de Estados.

    Moderador Claudio Sanches

    (@claudiosanches)

    Parece que já conseguimos encontrar o problema e estamos atualizando o WooCommerce ainda esta semana.

    Olá a todos, estou com o mesmo problema, o erro ocorre no internet explorer apartir da versão 10, já debuguei o javascript e não mostra erro algum!

    Postei o meu comentário mas não vi a sua postagem Claudio Sanches, muito obrigado!

    Consegui resolver. Percebi que na versão 9 do internet explorer funciona perfeitamente, então emulo o site na versão 9!
    Inseri o código no “<head>” do meu site segue abaixo:
    <meta http-equiv=”X-UA-Compatible” content=”IE=9″>

    Claudio, alguma novidade na atualização? Atualizei o site recentemente e continuo com o problema.

    Existe alguma forma de exibir um select normal ao invés do select2?

    Obrigado pelo help!

    Olá rapricardo, postei a solução acima do seu comentário, está funcionando perfeitamente pra mim!

    leandro_sj, em que pagina especificamente seria aplicado esse código??

    Desculpe pela demora:
    No head “<head></head>” do seu site!

    Coloquei dentro a tag dentro da Tag head e não funcionou, continuou dando o mesmo problema…teria outra solução?

    No meu funcionou tranquilamente, me passa o link do seu site para eu poder dar uma olhada, para saber oq houve.

Visualizando 15 respostas - 1 até 15 (de um total de 17)
  • O tópico ‘woocommerce – Problemas com o campo Estado’ está fechado para novas respostas.