Suporte » Ajustando o WordPress » Editor Visual desapareceu após atualização 3.1.1

  • Resolvido andregalegos

    (@andregalegos)



    Pessoal

    Após atualização da versão 3.1 para a 3.1.1 a barra de edição visual desapareceu e os botões deenvio de mídia não funcionam.
    Tentei desabilitar a opção no menu usuáios “opção desativar o editor visual ao escrever’ mas não deu certo

    Creio que não é imcompatibilidade de plugins, já que eles estavam funcionando antiormente e em várias edições anteriores isto não deu certo.
    http://img291.imageshack.us/i/editorvisual.jpg/

    Por favor peço ajuda.
    Obrigado

Visualizando 15 respostas - 1 até 15 (de um total de 24)
  • Se deu @%¨%¨@
    ….
    Eu basicamente sigo a seguinte regra.

    1) Desativo plugins.
    Se não resolver.

    2) Troco de tema temporariamente para o padrão do sistema.
    Se não resolver.

    3) Uso outro navegador
    Se não resolver.

    4) volto ao sistema anterior.

    ============================================
    Caso alguma medida tenha surgido efeito
    ============================================

    1) Desativo plugins.
    voltou a funcionar
    – Vou ativando um por um até que o erro ocorra novamente e eu saiba qual é o miserento do plugin que tá me causando problema.

    2) Troco de tema temporariamente para o padrão do sistema.
    Voltou a funcionar.
    – Procuro no meu tema algum código que possa estar fazendo alguma mudança no sistema na parte específica em que o erro acontece.

    3) Uso outro navegador
    Voltou a funcionar.
    – Limpo os cookies e temporários, fecho o navegador e abro ele novamente, em casos extremos até reinicio a maquina.

    =================
    Se o “navegador” usado é o IE tomara que fique dando erro para o resto da vida até que a pessoa tome vergonha e pegue um navegador decente.

    Brincadeira a parte, espero que vc consiga descobrir qual a causa do problema com as dicas.

    Caso nenhuma dessas Soluções funcione veja em Usuários -> Seu Perfil Verifique se está marcada a opção Desativar o editor visual ao escrever.
    Se estiver marcada desmarque e clique em atualizar perfil.

    Qualquer dúvida poste aqui no fórum que te respondemos.

    Eu tentei a mudança no perfil mas não funcionou. Esse problema esta acontecendo com diversos usuários como mostra o link abaixo e aparentemente sem solução
    http://wordpress.org/support/topic/wysiwyg-editor-not-working-after-upgrade-to-301?replies=19#post-2049785

    Eu sugeri que verificasse o seu perfil por que na maioria das vezes resolve mas uma vez que me deu este problema eu reinstalei o WordPress e foi o que resolveu de vez o problema.

    Mas antes salve todos os Plugins. Depois de reinstalar o WordPress vá instalando os Plugins 1 a 1 até encontrar o que está dando defeito.

    flb007,

    Muito obrigado pela ajuda. Se não conseguir resolver nos proximos dias, creio que a solução será reinstalar tudo mesmo.
    Acho que o problema é no jquery
    Aguardo sugestões.

    Dianakc,
    Realmente o seu tópico é impressionante.
    Desativei todos os plugins, mas infelizmente mantém o erro. Nada de Visual editor.
    Continuo na busca e agradeço o esforço de todos.

    To ficando preocupado, já vasculhei tudo na net e nada.
    O usário ” pdsketchbook” no topico abaixo, tentou tudo, até reinstalar o wp e não resolveu. Creio q talvez seja no banco de dados o que na fica cessível com a edição de arquivos ou desativação de plugins. Minha suspeita continua no jquery

    http://wordpress.org/support/topic/wysiwyg-editor-not-working-after-upgrade-to-301?replies=20

    Aguardando… e procurando….

    Tente instalar um plugin que modifique o editor, quem sabe se existe alguma código no plugin que faça ele voltara funcionar.

    Não custa tentar, já não está funcionando mesmo.

    Dei uma procurada e achei esse que diz funcionar com a versão 3.1
    http://wordpress.org/extend/plugins/wp-super-edit/screenshots/

    Testa ai e diz pra nós o que acontece.

    Eu tentei esse plugin hoje mais cedo e nada mudou.

    Tirei o dia hj p tentar resolver isso.

    mmuito obrigado

    Bom vc não deve nem estar conseguindo postar alguma coisa né.

    Neste link http://tinymce.moxiecode.com/tryit/full.php existe o editor sendo rodado, se escrevermos alguma coisa e clicarmos em enviar o código html é nos fornecido.

    Caso queira escrever algum post vc pode usar ele então, e depois copiar o html para fazer seus posts, fica ai uma alternativa desagradável, mas que pode ajudar em alguma coisa.

    Pessoal, após sugestão dos usuários pdsketchbook,e adaptando a do Myst1010 eu consegui uma solução paliativa.
    1) Desativei todos os plugins
    2) Reinstalei o wordpress ( instalação automática – Menu atualização)
    OBS: O erro ainda manteve-se
    3) Instalei o plugin : CKEditor for WordPress (http://wordpress.org/extend/plugins/ckeditor-12/ )
    4) Reativei os plugins

    OBS: Pode se que realizando a etapa 4 funcione.

    O local de armazenamento de imagens é diferente do Visual Editor nativo do wordpress, portanto o sistema de Midia não fica acoplado ao sistema.

    Espero que ajude até resolução definitiva.

    O que notei que após atualização aconteceram algumas coisas estranhas e acho que o probelma basal é o mesmo do Visual editor
    1) Deslocaram os links da “barra admin” que fica na parte superior do index e deslocou para o fim da página.
    http://www.brimages.com.br/?di=013023190743
    http://www.brimages.com.br/?di=10130231924015

    2) Apareceram imagens e palavras deslocadas na Dashboard:
    http://www.brimages.com.br/?di=1413023192959

    3) Quando se clica no botão de upload de imagens no área de edição de posts o sistema de upload não aparece no local normal e sim foi deslocado para o final da DAshboard a semelhança ao que aconteceu com a barra admin no index.
    http://www.brimages.com.br/?di=313023194752

    Não é problema do tema, pois mudei e os erros mantiveram.

    Acho q a partir de hoje não atualizo o wordpress por um bom tempo

    andregalegos

    Tente isso:

    • Marque a opção de desativar o editor visual para seu usuário
    • Vá em um área de edição (somente a edição HTML deve estar disponível).
    • Saia da sua conta e limpe o cache. Depois entre novamente.
    • Ative a opção de editor visual novamente, para seu usário

    Parece que o WordPress precisa re-escrever as opções para que façam efeito.

    Outras opções:

    Substituir toda a pasta wp-includes\js\tinymce.
    Faça download do wordpress original (inglês) e substitua a pasta.

    Instalar o plugin TinyMCE Extended.

    Dianakc,

    Infelizmente não funcionou.
    Por enquanto estou usando o plugin CKEditor for WordPress (http://wordpress.org/extend/plugins/ckeditor-12/ ) que criou um sistema similiar ao Visual Editor e aparentemente até é melhor, porém ainda fica o erro, e vou ter que continuar com um sistema com crash, mas pelo menos posso criar posts normalmente.
    Obrigado pelo esforço em me ajudar.

Visualizando 15 respostas - 1 até 15 (de um total de 24)
  • O tópico ‘Editor Visual desapareceu após atualização 3.1.1’ está fechado para novas respostas.