Suporte » Temas » Vídeo não roda na versão mobile

  • Resolvido renatapabst

    (@renatapabst)


    Olá!

    Inseri um vídeo no cabeçalho do site e roda perfeitamente no desktop, mas quando vou para a versão mobile um espaço em branco entra no lugar do vídeo. Nas minhas pesquisas encontrei algo como problemas de autoplay, mas não consegui fazer alguma configuração para corrigir o problema.

    Alguém sabe como adaptar ou corrigir isso?

    A página que eu preciso de ajuda: [fazer login para ver o link]

Visualizando 2 respostas - 1 até 2 (de um total de 2)
  • CB

    (@cbrandt)

    Olá @renatapabst,

    Não é só na versão mobile que está acontecendo isso. Na versão desktop com uma janela não-maximizada e largura abaixo de 900px também acontece. Para conferir, abra o Developer Tools (F12) e reduza a largura da janela para menos de 900px. Recarregue a janela do site, e verá que aparece o espaço em branco.

    Isso nos dá uma pista de que algum CSS de sua instalação contém regras específicas para acima ou abaixo de 900px que estão causando o problema.

    Veja se o seu tema ou seus plugins têm configurações específicas para tamanhos de tela que possam ser ajustadas. Do contrário, vc terá que identificar o arquivo CSS com essa regra e corrigi-la usando “Custom CSS” no painel do WP > Aparência > Personalizar.

    Moderador Ralden Souza

    (@ralden)

    saudações @renatapabst,

    no Elementor (pelo menos na versão PRO tenho certeza, mas acredito que na versão gratuita também) você tem a possibilidade de definir um vídeo como o fundo de uma seção. MAS isso só funciona em desktop.

    sendo que a diferença entre mobile, tablet e desktop, para o Elementor, é feita através da largura de tela. até X pixels é mobile, até Y pixels é tablet e acima de Y é desktop. nessa lógica, isso deve ser o que está acontecendo para sumir “menos de 900px”, conforme relatado pelo @cbrandt.

    apesar de você estar usando Elementor, conforme é possível ver algumas seções, o cabeçalho não parece estar sendo em Elementor. ai teria que ver se tem opção para isso em Aparência > Personalizar ou se tem no menu do WordPress algum seção, principalmente em Aparência, que se refira a opções do tema.

    conforme o código-fonte de seu site, está usando o tema Brand de wp-brandtheme.com. acessando o site, infelizmente a seção Documentation está vazia. ai fica difícil ter ideia de como ajudar.

    indicaria então entrar em contato com o desenvolvedor sobre essa questão,

    https://www.wp-brandtheme.com/contact/

    sei o quanto por vezes criamos apego com certas partes do WordPress. eu só uso o tema GeneratePress e não mudo nem a pau hahaha. mas se ver que o tema possui limitações complicadas e não tem suporte, é algo para pensar depois em buscar um outro tema, se achar que é o caso.

    boa sorte!

    [código é poesia]

Visualizando 2 respostas - 1 até 2 (de um total de 2)
  • Você deve estar conectado para responder a este tópico.