Suporte » Outros assuntos » Usando Publicar via Email – caracteres ficam confusos (problema no encode)

  • Resolvido ehm01

    (@ehm01)


    Bom dia pessoal,
    Tenho uma instalacao de WP.org rodando 3.3.1 em Portugues.
    E quero usar a opcao de Publica Isso (envio de email para uma conta do WP, que automaticamente joga na lista de novas mensagens)

    O processo he simples, so que o que acontece he que os fontes chegam todos baguncados.
    Dados:
    O banco de dados MYSQL esta usando encoding UTF8_General_CI
    Ja testei com UTF8_Bin e com UTF8_Unicode_Ci, sem que ocorra nenhuma mudanca no comportamento.
    O WP esta configurado como:
    define(‘DB_CHARSET’, ‘utf8’);
    define(‘DB_COLLATE’, ”);
    define(‘WPLANG’, ‘pt_BR’);

    O processo he assim:
    Um escritor escreve o texto no MS-word
    copia esse testo inteiro e cola no MS-Outlook
    e envia por email
    o que eu recebo dentro do WP he isso:

    ======================
    –_004_94678ACDD247424CBA53CB02041DE7D701337DF69DBBMAILSERVint_
    Content-Type: multipart/alternative;
    boundary=”_000_94678ACDD247424CBA53CB02041DE7D701337DF69DBBMAILSERVint_”

    –_000_94678ACDD247424CBA53CB02041DE7D701337DF69DBBMAILSERVint_
    Content-Type: text/plain; charset=”utf-8″
    Content-Transfer-Encoding: base64

    UXVhbCBvIG1lbGhvciBwcm9ncmFtYSBkZSBpbnRlcmPDom1iaW8gcGFyYSB2b2PDqj8NCkZhemVy
    IHVtIGludGVyY8OibWJpbyBlc3R1ZGFudGlsIMOpIG8gc29uaG8gZGUgbXVpdG9zIGpvdmVucywg
    ======================

    O que deveria receber he um texto normal, com acentuacao.
    Acredito que o problema seja o Encode + a acentuacao.

    Alguem tem solucao para isso?

    Obrigado

Visualizando 9 respostas - 1 até 9 (de um total de 9)
  • Criador do tópico ehm01

    (@ehm01)

    Tentei editar o post original… nao consegui.
    Estou colocando mais informacoes:
    Copiei o texto do WORD, e colei no Outlook, porem usando 3 diferentes Formatos de Saida no outlook (Tools–>Mail Format–>drop down men para “Compose Format”
    Plain Text
    Rich Text
    HTML

    os 3 formatos vieram basicamente com o mesmo problema, so mudando um pouco no cabecalho.

    Imagino que seja algo entre o que o Outlook manda, e o que o WordPress recebe.

    Criador do tópico ehm01

    (@ehm01)

    OK. desculpe… sei que devia estar colocando tudo num so post….
    testei novamente, agora enviando de um outro programa de email (theBat!)
    e funciona o “copiar do word colar no TheBat!”

    o texto vem perfeito, com todos os acentos.

    O problema esta na integracao do Outlook com o WordPress.org

    Alguem tem solucao para isso?
    (prometo que he o ultimo post corrigindo…)

    Olá,

    Publicar por email só aceita texto puro, não tem como usar Word ou código HTML. Mesmo no wordpress.com é um pouco melhor, mas tem que usar texto puro e tags próprias para preencher informações (categoria, tags etc).

    Porque não usa um cliente de publicação como o BlogDesk (bem rápido mas limitado) ou Zoundry ?

    Mais em http://codex.wordpress.org/pt-br:Cliente_de_Weblog

    O Livewriter do Windows é bem interessante, mas não sei se vem em todos os WIndows, ou se tem como fazer donwload, veja se não tem no botão Iniciar.

    Criador do tópico ehm01

    (@ehm01)

    Obrigado Diana.
    Conferi os aplicativos mas acabou que nao tem o que procuro exatamente:
    Tenho uma pessoa que escreve alguns assuntos e gostaria que os artigos dela nao tivessem que ser ‘redigitados’, porem nao quero dar permissao de postagem, pois leio tudo antes de deixar o post ir para o forum.
    A solucao de email estava se mostrando a ideal:
    ela enviava um e-mail com o post dentro do mesmo, eu conferia e liberava a postagem.
    as opcoes de blogdesk ou zoundry, pelo que vi, o usuario tem o acesso total a postagem…

    Se o usuário tem acesso de autor, o Blogdesk/Zoundry não deve permitir publicação direta, se isso acontece é um bug e tanto. No nível autor, a postagem fica como pendente de revisão por um usuário colaborador, editor ou administrador.

    Crie um usuário com nível autor e veja se isso está mesmo com problema.

    Criador do tópico ehm01

    (@ehm01)

    Diana,
    nao creio que seja isso que aconteca (nivel de author publicando).
    mas o que ocorre he que teria que mudar a ‘rotina’ do escritor entende?
    ela escreve em Word. Ja mudei muito para ela, pedindo que ‘copy and paste’ no email, pois a preferencia dela he mandar via attachment.
    agora, dizer que tem que instalar um software, criar a conta, etc, etc…
    tadinha… pessoa otima, mas he muito para as skills dela em computacao e tiraria totalmente o modo de operar.

    Pode parecer chatisse minha, mas a solucao de email ainda seria a ideal. Nada para se instalar no Author, e o administrador pode revisar…
    so que nao funciona! 🙁

    ehm01,

    pede pra ela copiar e colar no Bloco de Notas, depois copiar e colar de lá para o email. Isso vai resolver qualquer problema de formatação no e-mail.

    Sim Moraleida, mas vai remover todas a formatação.

    Não entendo porque escrever no Word, o cliente de email tem o suficiente para texto web.

    Talvez pudesse facilitar mais e permitir que crie posts pelo site (formulário no site). E você poderá revisar/moderar pelo cliente.

    Coloca o codigo

    utf8_decode($varivael);
        utf8_encode($variavel);

    no lugar da varável coloque o texto.

Visualizando 9 respostas - 1 até 9 (de um total de 9)
  • O tópico ‘Usando Publicar via Email – caracteres ficam confusos (problema no encode)’ está fechado para novas respostas.