Suporte » Temas » Títitulo do Post sem acentos

  • Resolvido enefink

    (@enefink)


    Olá Galera!

    To com um problema muito chato, me ajudem, por favor!

    Bem, é o seguinte: tenho um blog e no título dos pots não dá para escreve com acento. Por exemplo, se o título do post é: “Saiba o que Não fazer com seu WordPress”, ele é publicado assim: “Saiba o que no fazer com seu WordPress” ou seja: o sistema come as letras com acento, e as cedilhas, e tios também. Alguém poderia me ajudar/

    Será o tema? Se for, tem algum lugar específico onde mudo isso? Seria a codificação?

Visualizando 15 respostas - 1 até 15 (de um total de 24)
  • Moderador Leo Baiano

    (@leobaiano)

    1 – Coloque o link do seu blog aqui;
    2 – Mude para o tema padrão pra ver se a acentuação funciona;
    3 – Procure pela tag the_title(); no seu tema e cole aqui o código perto dela (umas 2 linhas antes e 2 depois de onde ela aparecer).

    Esse problema ocorre apenas no titulo ou os acentos são cortados apenas no titulo ou no texto também?

    Criador do tópico enefink

    (@enefink)

    Oi Leo!

    Mudei de tema, mas tenho um amigo que tem ums ite com o mesmo tema (porque eu indiquei). E o problema persiste.

    1 – O link: http://www.claudionor-ritondale.com
    2 – Mudei e funcionou. É frescura do tema.
    3 – `<h1 class=”general_title”><?php echo the_title(); ?></h1>

    <div class=”large-texts”>

    <div class=”texts”>
    <span class=”meta_blog”>
    <?php the_time(‘d/m/Y – H:i’); ?>, em <?php the_category(‘, ‘) ?> | <?php comments_number( “Comente” ,”1 Comentário”, “% Comentários” );?>`

    Não, só no título mesmo. No texto publica normal.

    Veja lá: http://claudionor-ritondale.com/blog
    Valeu por ajudar!!

    Moderador Leo Baiano

    (@leobaiano)

    É algum js que esta retirando a acentuação, no código fonte o texto aparece normalmente. Faz um teste, no arquivo index.php procure por <h4>……</h4> e altere os dois h4 por h6, só pra efeito de teste.

    Moderador Leo Baiano

    (@leobaiano)

    Onde pegou o tema? Talvez na documentação tenha algo que nos dê uma pista de como o titulo é modificado.

    Criador do tópico enefink

    (@enefink)

    Hahaha Cara, vc é um gênio! Era um odc js mesmo! um da cufon ainda!

    Valeu mesmo einh!

    Criador do tópico enefink

    (@enefink)

    Hahaha Cara, vc é um gênio! Era um doc js mesmo! um da cufon ainda!

    Valeu mesmo einh!

    Moderador Leo Baiano

    (@leobaiano)

    Massa parceiro!

    diegomoreno

    (@diegomoreno)

    Eu uso o tema Magzimus e tb tenho o mesmo problema… não consigo resolver… ja tentei olhar na documentação e nada…

    alguem sabe como ajudar??

    o meu blog é o http://www.audioreporter.com.br

    Myst1010

    (@myst1010)

    diegomoreno seu tema usa um recurso chamado cufon, pesquise no google sobre como trocar a fonte do plugin.

    Tive o mesmo problema, mas no meu caso a fonte que estava em uso pelo recurso cufon não aceitava acentuação.

    Vale checar antes de mudar qualquer código qual a fonte que está sendo usada.

    Boa tarde,

    to tendo o mesmo problema com o tema Tarnished.
    toda a letra com acentuação do título desaparece.
    Já fiz todas as alterações sugeridas aqui, troquei de fonte / usei o cufon / etc

    tem o link do site pra gente dar uma olhada?

    Moderador Leo Baiano

    (@leobaiano)

    O Tarnished resolveu o problema seguindo as orientações daqui, se estão com o mesmo problema tentem seguir as mesmas dicas e caso não dê certo voltem com mais detalhes.

    Tentei seguir todas as dicas postadas,

    so que ao tentar intalar tanto o plugin cufon, quanto o all-in-one-cufon da erro no mesmo código.
    A mensagem que aparece sempre quando ativo o plugin é:

    Warning: Invalid argument supplied for foreach() in /home/atitudes/public_html/wp-content/plugins/all-in-one-cufon/wordpress_cufon.php on line 27.

    refente a essa linha ” foreach (glob(WP_PLUGIN_DIR . “/cufon-fonts/*”) as $path_to_files) “.

    Realmente a fonte utilizado pelo tema Tarnished é para gringo, sem acentuação.
    Nas configurações do proprio tema tem a opção de trocar de fonte, testei todas descobri uma que aceita acentuação, apliquei ela, mais mesmo assim as letras acentuadas somem. Passei ela outra vez no http://cufon.shoqolate.com/generate/
    para marcas todas as opções possiveis. Mais nada mudou.

    geisinonato este tema pode fazer algum tratamento incorreto com os títulos e por este motivo, mesmo trocando a fonte do cufon o erro permaneceu.

    Verifique em seu function se existe alguma função fazendo alguma coisa com get_title() ou the_title, caso tenha pode ser ela a causadora do erro mesmo tendo uma fonte corretamente acentuada.

Visualizando 15 respostas - 1 até 15 (de um total de 24)
  • O tópico ‘Títitulo do Post sem acentos’ está fechado para novas respostas.