• Resolvido RTCADMIN

    (@rtcadmin)


    Não estou conseguindo fazer uma imagem aparecer quando não tem thumb,
    os posts que tem thumb estão aparecendo corretamente, mas os que nao tem nao aparece nada que esta dentro do else:

    ( os links estao corretos eu testei )

    Se alguem puder me ajudar agradeço!

     <?php $posts = new WP_Query( array( 'posts_per_page' => 3,
    									'orderby' => 'date',
            							
            							'order' => 'DESC'
    								   
    								   )); while( $posts->have_posts() ) : $posts->the_post(); ?>
      
       <div class="col-lg-4 col-md-8 .col-md-6"> 
           
        <a href="<?php the_permalink(); ?>">
        
    <?php if ( has_post_thumbnail('') ) : ?>  
    
    <?php the_post_thumbnail('post-thumb'); ?>  
    
    <?php else: ?>
    
    <img src="<?php bloginfo('template_url'); ?>/img/none/post-thumb.jpg" alt="alt text" /> <!-- CASO NAO TENHA POSTA UMA FOTO PADRAO DEFINIDA AQUI -->
    
    <?php endif; ?>
Visualizando 2 respostas - 1 até 2 (de um total de 2)
  • @rtcadmin Dá uma conferida no local onde a imagem destinada a posts sem thumb está armazenada.

    A pasta img está na raiz do tema?
    /img/none/post-thumb.jpg

    Ou existe uma pasta envolvendo a img, tipo assets?
    /assets/img/none/post-thumb.jpg

    Olá @theandersonn
    Então cara, foi erro meu mesmo, o cod esta funcionando certinho,
    é que eu importei post, e as imagens não vieram, como estava dizendo que tinha o thumbnail nos posts, mas as imagens não estavam lá. ele dava esse erro.

    Muito Obrigado!

Visualizando 2 respostas - 1 até 2 (de um total de 2)
  • O tópico ‘thumbnail’ está fechado para novas respostas.