Suporte » Ajustando o WordPress » Site não entra – página em branco

  • biancasp

    (@biancasp)


    Olá!
    De repente meu site não está mais abrindo. Já mudei de computador, de rede, já limpei cache, já verifiquei com o serviço de hospedagem que chegou a dar um restore de 7 dias e nada.
    Aparece uma página em branco e o admin não entra.
    Detalhe que a última vez que mexi efetivamente no site foi há 11 dias e até alguns dias depois estava tudo bem.
    Alguém consegue me dizer o que pode ter acontecido e como resolvo isso?
    http://www.nossomundoorganico.com.br

    Obrigada!

Visualizando 15 respostas - 1 até 15 (de um total de 17)
  • marcelo2605

    (@marcelo2605)

    @biancasp

    Bianca, habilite o modo debug do WordPress no arquivo wp-config.php

    define('WP_DEBUG', true);

    Depois, apague todo o conteúdo do arquivo .htaccess e suba ele novamente. Mas deixe uma cópia intacta no seu PC.

    biancasp

    (@biancasp)

    Marcelo, obrigada pela resposta.

    Essa ação de apagar o .htaccess já foi feita pelo meu host e não funcionou.

    O que posso adiantar é que tá dando um fatal error: “Failed opening required…” no wp-includes/load.php

    Mas eu não faço ideia do que isso signifique… 🙁

    marcelo2605

    (@marcelo2605)

    @biancasp

    Tente desabilitar todos seus plugins dirato no banco de dados. Aqui tem uma explicação de como fazer isso.

    Se der certo, vá ativando os plugins até descobrir o que está causando o erro.

    Se não der certo, renomeie a pasta do seu tema ativo.

    biancasp

    (@biancasp)

    Não consegui achar a opção para desativar os plugins como o link que vc me mandou mostra…
    Eu já tinha pelo FTP renomeado a pasta de plugins e nada aconteceu…
    Renomeei a pasta do tema e tbm nada…

    🙁

    marcelo2605

    (@marcelo2605)

    Você precisa acessar o PHPMyAdmin para desativar os plugins conforme o link que te passei.

    Você já testou seu site localmente para ver se funciona?

    biancasp

    (@biancasp)

    Entnao, via PHPMyAdmin, na opção wp_options não tem “active_plugins”…

    Não testei meu site localmente. Na verdade eu nem sei como fazer isso.

    marcelo2605

    (@marcelo2605)

    No arquivo wp-config.php, inclua a linha abaixo para ativar o debug log:

    define( 'WP_DEBUG_LOG', true );

    Rode o site e compartilhe o conteúdo do arquivo /wp-content/debug.log

    biancasp

    (@biancasp)

    A primeira parte eu consegui, mas não consigo fazer o debug….

    marcelo2605

    (@marcelo2605)

    É só pegar o conteúdo do arquivo debug.log, que está dentro da pasta wp-content e postar aqui.

    Moderador Miriam de Paula

    (@miriamdepaula)

    O site estava funcionando certinho … Aí de repente parou de funcionar.
    O que foi feito recentemente no site, que pode ter gerado este problema?
    Ativou algum plugin novo?

    Abra o arquivo wp-config.php e ative a diretiva WP_DEBUG, colocando “true”. Acesse o site novamente e veja se algum erro de PHP aparece na tela.

    Você pode desativar todos os plugins se for pelo FTP, acessar wp-content/plugins e simplesmente apagar todos os plugins desta pasta, lembrando, óbvio, de fazer uma cópia de segurança desses arquivos ANTES de apaga-los.

    Eu tenho cá pra mim, que trata-se de problema de memória exausta. Você deve estar rodando algo nesse site que está estourando o limite de memória da sua hospedagem contratada.

    biancasp

    (@biancasp)

    Miriam vc acredita que eu não tinha feito NADA?

    Inclusive foi uma pessoa que me avisou que o site estava fora do ar, fazia alguns dias que não mexia nele.

    Se fosse problema de memoria exausta o meu provedor de hospedagem não deveria me dizer?

    O log de erro que aparece é esse:
    [Fri Oct 28 09:43:29 2016] [error] PHP Warning: require(/home/storage/8/be/88/nossomundoorganico/public_html/wp-includes/load.php) [a/href=‘function.require’>function.require: failed to open stream: No such file or directory in /home/storage/8/be/88/nossomundoorganico/public_html/wp-settings.php on line 25

    BrunoCassoni

    (@brunocassoni)

    tente aumentar a memória do php no wp-config.php

    define('WP_MEMORY_LIMIT', '96M');

    biancasp

    (@biancasp)

    @brunocassoni fiz isso e agora na primeira tentativa não abriu em branco no Firefox.
    Deu o seguinte erro:

    “Não foi possível conectar-se
    O Firefox não conseguiu estabelecer uma conexão com o servidor nossomundoorganico.com.br.

    Este site pode estar temporariamente fora do ar ou sobrecarregado. Tente de novo em alguns instantes.
    Se você não consegue carregar nenhuma página, verifique a conexão de rede do computador.
    Se o seu computador ou rede forem protegidos por um firewall ou proxy, certifique-se de que o Firefox esteja autorizado a acessar a web.”

    Depois tentei novamente e voltou a abrir página em branco…

    • Esta resposta foi modificada 1 ano atrás por  biancasp.
    • Esta resposta foi modificada 1 ano atrás por  biancasp.
    BrunoCassoni

    (@brunocassoni)

    tente mudar de 96M para 64M

    Moderador Miriam de Paula

    (@miriamdepaula)

    Bianca, você postou alguns erros encontrados no log, certo?
    Esses erros tão dizendo que não foi possível encontrar arquivo ou diretório. Talvez sua instalação do WordPress esteja corrompida por algum motivo que não sabemos.

    1) Aumentar a memória limite do PHP não vai ajudar neste caso e também, é necessário ver se o seu plano de hospedagem comportaria tal aumento! Tem que falar com a empresa de hospedagem primeiro.

    2) Você pode baixar uma cópia limpa do WordPress em http://br.wordpress.org e enviar todos os arquivos, via FTP, sobrescrevendo os que estão lá. LEMBRANDO DE FAZER UM BACKUP DE TUDO ANTES DE QUALQUER ALTERAÇÃO!

    Talvez se você enviar os arquivos limpos pra lá, resolva … Tenta, não custa nada!

    FAÇA BACKUP DE TUDO ANTES!

Visualizando 15 respostas - 1 até 15 (de um total de 17)
  • O tópico ‘Site não entra – página em branco’ está fechado para novas respostas.