Suporte » Outros assuntos » Site não abre com a formatação dos temas e plugins

  • Resolvido rafaelfjorge

    (@rafaelfjorge)


    Boa Tarde,
    Bom galera, sou novato em wordpress, curioso pela praticidade resolvi implementar uma intranet usando o wordpress.
    Visando que meu server não comporta Vs 2017 versão atual, tive que instalar o 2017 mais antigo para carregar e instalar o Php e apache pelo wampserver.

    Configuração:
    Win server 2008 r2
    Wamp 3.1.0 64Bts
    Apache 2.4.27
    Php 5.6.31
    My sql 5.7.19

    Então, o site abre no localhost (Ip fixo) abre todos os plugins e formatações, fica ate lindo, porem quando vou acessar ele na mesma rede em outra maquina, ele carrega somente o site sem formatação do tema e nos links que inseri os plugins ele não carrega a pagina. Ex: tenho o ninja form para pesquisa de clima, quando clico no link que possui a pesquisa, no localhost abre, nas maquinas da rede carrega a pagina sem o form do plugin.

    Rezei para orichas, chorei em posição fetal, fiz promessa aos deuses do olimpo, prometi ser um humano melhor, mas nada disso resolveu, como programador, não sei o que fazer, mas como programador, não sei como deu certo ate aqui. Afinal de contas, como programador é sempre uma surpresa quando tudo da certo de primeira. rsrsrs.

    Ata, liberei as regras de firewall, desabilitei o openfire achando que pudesse ser, mas não é, as portas são diferentes, então, na real, sei o que fazer mais não.
    Quem puder me dar uma luz, eu seria um ser humano comedor de pizza mais feliz.

Visualizando 8 respostas - 1 até 8 (de um total de 8)
  • Moderador Felipe Elia

    (@felipeelia)

    Opa, depois de fazer isso tudo e não conseguir é triste mesmo, sei como é.

    Uma dúvida: como está a configuração de endereço do WordPress? Aquela que aparece indo no Painel em Configurações -> Geral (Endereço do WordPress (URL) e Endereço do site (URL)).

    Ola, Então, esta assim.

    Endereço do WordPress (URL) http://localhost/Intranet
    Endereço do site (URL) http://192.168.0.14/Intranet

    Moderador Felipe Elia

    (@felipeelia)

    O problema é esse então, os dois deveriam apontar para o 192.168.0.14, caso contrário os endereços dos CSS, JS e etc. apontam pra http://localhost, por isso funciona no localhost, mas não funciona fora dele.

    Faça um backup do banco de dados e substitua as ocorrências de localhost para o IP. Você pode usar o Better Search Replace pra isso, o wp-cli ou essa ferramenta da InterConnectIT.

    Mano, EU TE AMO. rsrsrsrs.
    Deu certo, deu super certo.
    Alterei o local para o ip e o site carregou normal.
    Obrigado pelo suporte nessa questão.
    Ótima semana, flws valws.

    Sou iniciante em wordpress, depois de um treinamento bem básico, comprei alguns livros, cujos os quais foram devorados, embora fossem bastante básicos inclusive um curso on line. Fiquei encantado com a ferramenta WordPress resolvi modificar a intranet da empresa que eram em html, num servidor de arquivos e backups. Está tudo pronto, mas estou com um grande problema. Tudo está no localhost/”intranet”, não encontro um passo-a-passo para que eu possa transferir tudo feito no localhost/”intranet” para o servidor para que todos tenham acesso a “intranet”.

    Moderador Rahmohn

    (@rahmohn)

    @arturfonsecacehop

    Crie um tópico separado. Dessa forma, é mais fácil de vc conseguir ajuda.

    Como faço isso?

    Moderador Mario Valney

    (@mariovalney)

    WordPress Cleric of Fire

    Olá Artur. Tudo bem?

    Por favor, não marque tópicos com modlook a menos que seja necessário uma olhada dos moderadores em relação às Regras do Fórum.

    Agora respondendo sua pergunta: para criar um tópico novo basta acessar o fórum: https://br.wordpress.org/support e então escolher um dos subforuns (sugiro “Instalando o WordPress”) e então clique no botão “Criar tópico”.

    Além disso, é sempre recomendado fazer uma busca, pois sua dúvida pode já ter sido respondida em outro tópico. Por exemplo:

    https://br.wordpress.org/support/topic/como-colocar-o-site-localhost-em-um-servidor/

    Abraços,

Visualizando 8 respostas - 1 até 8 (de um total de 8)
  • O tópico ‘Site não abre com a formatação dos temas e plugins’ está fechado para novas respostas.