Suporte » Ajustando o WordPress » Sem permissões suficientes para acessar esta página( Resolvido)

  • Estava com Este Problema, li vários Artigos alguns bons .. mais não resolveu meu problema…

    No meu caso Modifiquei a pasta Plugins para Plugins2 e nada! continuava sem acesso.

    Entre no cpanel.. PHPmyAdmin alterei algumas informações e nada.!

    Vamos la então a solução.

    1 – Acesse o Painel de Controle
    http://www.meusite.com.br/capanel

    2 – Crie um novo Banco de dados, Dei permissões total.

    3 – Fui ate a FTP do meu site que estava sem permissão, remomie o arquivo wp-config.php para wp-config2.php.

    4 -Acessei meu site http://www.meusite.com.br, ele solicitou que eu coloca-se a informações do banco de dados de novo, fui e coloquei a informações do novo banco de dados.

    5 – Acessei novamente http://www.meusite.com.br/cpanel , fui em PHPmyAdmin
    Selecionei o banco de dados com problema e excluir as tabelas Wp_usermeta
    e WP_User

    6 – selecione o segundo banco de dados copie as mesma tabelas acima para o banco de dados acima.

    7- Acessei a FTP, Apaguei o arquivo wp-config.php

    8- Renomeie o wp-config2.php para wp-config.php

    9 – Acesse o site com o admin normalmente!

    10- Apaguei o novo banco de dados! Pois ele so foi usado para criar novas Tabelas!

    Obs: Todos o outros usurios não existe mais! pois criamos uma nova tabalas usuario no banco de dados novo!

Visualizando 7 respostas - 1 até 7 (de um total de 7)
  • Moderador Leo Baiano

    (@leobaiano)

    Cara, você fez uma grande gambiarra, bom que resolveu o seu problema mas eu não recomendo essa solução para ninguém.

    Tive o mesmo problema migrando servidor. Fiz tudo isso @f3lim4, porém sem sucesso. Então decidir comparar com outros WP migrados, e descobrir que na tabela options, na coluna option_value tem uma chave q remete ao meu usuário.
    No meu caso foi assim:
    Valor encontrado:
    wp_user_roles
    Alterei para:
    wp_<prefixTable>_user_roles

    Para ficar mais claro, minhas tabelas seguem esse padrão:
    wp_<prefixTable>_options, wp_<prefixTable>_posts, wp_<prefixTable>_users, etc…

    Na coluna Option_Value começa com:
    a:7:{s:13:”administrator”…etc.

    Espero ter ajudado.

    Funcionou com esse tutorial

    Exatamente isso @luizvicenteps, mas não é só ai, existe vários lugares, você deve procurar pelo prefixo antigo e alterar pelo novo.

    Obrigado.

    • Esta resposta foi modificada 3 anos, 7 meses atrás por pedroarmindo1. Razão: agradecer

    Boas!

    Após actualização do site para a versão 4.7 fiquei sem acesso à área de administração do site, apesar de conseguir ver a barra de opções de administração. Após muitas tentativas junto da empresa onde tenho o alojamento e consultas na web, renomeei a pasta /wp-content/plugins para /wp-content/_plugins e voltei a ter acesso (Tentei desactivar todos os plugins mas o efeito não é o mesmo).

    Entretanto, e uma vez que ganhei de novo acesso ao painel de administração, reinstalei a actualização do worpress 4.7. Não sei se será importante ou não.

    De seguida, através de acesso ftp, c riei uma nova pasta /wp-content/plugins e estou a copiar uma a uma as pastas dos próprios plugins para dentro dela e a activar um a um dentro do painel de administração. Quando deixar de ter acesso, sei então qual o plugin “defeituoso”…

    Espero que ajude.

    • Esta resposta foi modificada 3 anos, 7 meses atrás por estudologosei.

    Obrigado, deu certo. Me ajudou muito!

    Ótima solução, tive este problema em um dos meus sites e agora estou testando os plugins.

    Mas o que resolveu mesmo o problema foi a solução apontada na descrição deste video: https://www.youtube.com/watch?v=853K97mDl8c

Visualizando 7 respostas - 1 até 7 (de um total de 7)
  • O tópico ‘Sem permissões suficientes para acessar esta página( Resolvido)’ está fechado para novas respostas.