Suporte » Ajustando o WordPress » Problemas com single e page.php

  • Resolvido rodrigodionizio

    (@rodrigodionizio)


    Olá pessoal! boa noite, bom dia, boa tarde … r.srs

    Estou realmente precisando de um help. Criei um tema para uma associação comercial de minha cidade e funfou legal, até quando cliquei no primeiro link, ou no primeiro post. O fato é que eu tinha outro tema funcionando legal, com todos os links sem problemas, tudo perfeito, mas foi preciso alterar o tema pois a logo da empresa mudou. Informei que o assunto deste tópico é um problema nos arquivos single e page.php, mais talvez seja outro o meu problema.

    eis o link do portal :: http://www.aciapsi.com.br ::// hoje mesmo postei um novo artigo sobre um evento que estamos realizando nesse final de semana e logo depois de publicá-lo todos os outros links de post e página abrem apenas este post… conseguem ententer isso?

    este é meu single.php

    <?php get_header(); ?>
    <div id="conteudo-pagina">
    <div id="textos">
       <h5><?php if ( function_exists('yoast_breadcrumb') ) {yoast_breadcrumb('<p id="breadcrumbs">','</p>');} ?></h5>
       <a href="javascript:ts('conteudo-pagina',-1)">
       <img src="<?=bloginfo('template_url')?>/images/icon_fonte_pq.gif" align="right" alt="diminuir fonte" title="diminuir fonte" style="width:30px; height:25px;" />
       </a>
       <a href="javascript:ts('conteudo-pagina',1)">
       <img src="<?=bloginfo('template_url')?>/images/icon_fonte_gr.gif" align="right" alt="aumentar fonte" title="aumentar fonte" style="width:30px; height:25px; padding-right:5px" />
       </a>
       <?php if (have_posts()): while (have_posts()) : the_post();?>
       <h1><?php the_title();?></h1>
       <p><?php the_content(__('Leia mais'));?></p>
       <small><?php if (function_exists('the_tags'))the_tags();?></small>
       <?php endwhile; else:?>
       <?php endif;?>
    </div><!-- FIM textos -->
      <div id="comments">
       <div id="comment-form">
        <?php comments_template(); ?>
       </div><!-- FIM comment-form -->
       </div><!-- FIM comments -->
    </div> <!-- FIM conteudo-pagina -->
    <div id="content-side">
      <div id="relacionados">
       <h2>Notícias Relacionadas</h2>
       <?php if(function_exists('echo_ald_crp')) echo_ald_crp(); ?>
      </div> <!-- FIM relacionados -->
    </div><!-- FIM content-side -->
    </div> <!-- FIM conteudo -->
    <?php get_sidebar(); ?> 
    
    <?php get_footer(); ?>

    page.php

    <?php get_header(); ?>
           <div id="conteudo-pagina">
        <div id="conteudo-pagina-esquerdo">
             <?php if (have_posts()): while (have_posts()) : the_post();?>
            <h1><?php the_title();?></h1>
             <p><?php the_content(__('Leia mais'));?></p>
             <?php endwhile; else:?>
        <?php endif;?>
        </div>
          <?php get_sidebar(); ?> 
    
        <div id="divclear"> </div>
       </div> 
    
    </div>
    <?php get_footer(); ?>

    Por favor…:: ajudem-me, pois o evento já começou e até amanhã a noite preciso botar o site no ar em perfeitas condições

    Rodrigo Dionízio
    email: rodrigo.dionizio [arroba] gmail [ponto] com
    MSN: rodrigo84dq [arroba] hotmail [ponto] com rodrigodionizio

Visualizando 2 respostas - 1 até 2 (de um total de 2)
  • Luís Victor Quintas

    (@luisvictorquintas)

    Aqui está abrindo normalmente os posts/páginas…

    Pelo que você disse, acho que seu problema era com os Permalinks.

    rodrigodionizio

    (@rodrigodionizio)

    Queridos amigos, venho aqui com grande alegria falar que o meu problema foi resolvido … o fato que ocorria era que não me atentei por uma lógica importante em desenvolver templates para wordpress que é não usar query_post no header.php…rs.r.s putz”!!!! Isso deve ser problemas de iniciantes… utilizei uma saída que ficou melhor do que a encomenda..rs.r.s um plugin de slider no lugar de query_posts…

    Bom depois de 30 longas horas os últimos dos moicanos, ops, os últimos neurônios me fizeram testar o header.php sem a query_post… e então tcham tcham tham… problema resolvido…

    Valeu muito a troca de experência.
    TÓPICO RESOLVIDO

Visualizando 2 respostas - 1 até 2 (de um total de 2)
  • O tópico ‘Problemas com single e page.php’ está fechado para novas respostas.