Suporte » Ajustando o WordPress » Links permanentes geram erro 404

  • Resolvido Paulo – Dash

    (@paulo-dash)


    Olá pessoal, tudo bem?

    Gostaria, primeiramente, de agradecer a todos os colaboradores desse fórum, sem esse apoio o meu trabalho seria inviável! Agradeço mesmo.

    Agora, vamos ao meu problema…
    Estou com um site de um cliente que está dando problema com permalinks. O site é o Toldos Universo. Quando clicamos em qualquer página do menu principal, ele mostra o famoso Erro 404, isso porque está com uma URL amigável no permalink. Essa é a atual usada:

    /%year%/%monthnum%/%postname%

    Mas, se eu volto para a URL padrão, ele volta ao normal, acessa as páginas e tudo, no entanto, todas as páginas internas serão acessadas nos links dentro do post, o que me permitiria mudar todos os links de novo… sem contar que esses links não podem ser usados. Política da agência.

    Então… eu gostaria de saber como conseguir arrumar esse erro. Quando atualizo para outro permalink sem ser o padrão, ele manda atualizar o arquivo .htaccess Já fiz isso mexendo com um cliente FTP, mas mesmo assim, nada aconteceu… como proceder, pessoal?

    Consegui ser claro? Estarei aguardando uma resolução. Obrigado.

Visualizando 9 respostas - 1 até 9 (de um total de 9)
  • Olá,

    Se seu servidor é baseado em Windows Server, o link permanente sempre tem que ter index.php no link.

    Carlos, você configurou manualmente seu windows server lá no IIS e tal? se sim é só você instalar um modulo chamado ISAPI_Rewrite que vai funfa de boa caso voce tenha uma hospedagem em uma loca web da vida tenta usar esse codigo no seu .htacess

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . /index.php [L]

    Delete o seu .htaccess original espere seu blog parar de funcionar e suba o novo seja feliz ^^

    Olá, agradeço pela ajuda, mas nada funcionou ainda. :/

    O servidor que eu saiba é Linux.

    No nosso painel está assim:

    Status: ATIVO
    Cliente: XXXXXXXX
    Plano: Linux
    Plataforma: Linux
    Servidor: tegea.uni5.net

    E não deu certo Francis… fiz como disse e não obtive nenhum progresso…

    cara manda seu msn pra mim dar uma fuçada nisso

    Opa. O msn é empire_disasters[@][hotmail].[com]

    Então gente… não consegui arrumar o problema e o jeito foi voltar para os links padrões. Tive que arrumar link por link nos posts porque o cliete estava impaciente…

    Enfim, o erro foi consertado. Obrigado pelos que apoiaram. ^^

    Paulo eu te adicionei no msn, mais não te vi por lá.

    Resolvido

    Pessoal, estou com o mesmo problema. WordPress 3.2.1 instalado em um servidor Windows. O site principal funcionando normalmente. Cria novos sites sem problema, mas aparece a famosa msg 404 ao tentar acessar qualquer um dos novos sites. Já mexi no .htaccess, criei um web.config, snfim, segui tudo que encontrei na net e até agora sem solução. Alguma solução? Só não vale indicar mudança pra servidor Linux porque tem que rodar no Windows mesmo.

Visualizando 9 respostas - 1 até 9 (de um total de 9)
  • O tópico ‘Links permanentes geram erro 404’ está fechado para novas respostas.