Suporte » Plugins » Problemas com o cálculo de frete dos correios

  • Resolvido dbk100

    (@dbk100)


    Boa tarde pessoal,

    Estou com problemas no frete… Estou recebendo a seguinte mensagem: Nenhuma opção de entrega foi encontrada. Até ontem, as 17, estava me retornando os valores mas de repente ele parou de calcular… o último log registrado foi:

    05-15-2019 @ 13:40:08 – Requesting Correios WebServices:
    [URL editada]
    05-15-2019 @ 13:40:17 – Weight and cubage of the order: Array
    (
    [weight] => 0,3
    [height] => 10
    [width] => 11
    [length] => 16
    )

    05-15-2019 @ 13:40:17 – Requesting Correios WebServices: [URL editada]

    Gostaria do auxilio de vocês para saber se o erro é na resposta dos correios…

    • Este tópico foi modificado 1 ano, 5 meses atrás por Felipe Elia. Motivo: Remoção de URLs com senha

    A página que eu preciso de ajuda: [fazer login para ver o link]

Visualizando 14 respostas - 1 até 14 (de um total de 14)
  • Alguém sabe informar quais plugins podem conflitar com o plugin dos correios?

    saudações @dbk100,

    antes de mais nada, uma sugestão. não poste uma resposta em seu tópico, mas antes edite o tópico para acrescentar ou modificar informações. alguns voluntários (eu sou um…) olhamos principalmente para a seção “Tópicos sem resposta”. ao colocar uma resposta, seu tópico sai dessa seção e você pode ficar sem ajuda.

    infelizmente queda do plugin dos Correios pode ocorrer por conta de queda do sistema deles.

    se você já está usando a última versão do WordPress, a 5.2, agora pode ir em Ferramentas > Diagnóstico e contar com um sistema que indica conflitos internos e até melhorias no servidor que deveria buscar. por favor, veja se há algo reportado nessa ferramenta.

    se sim, por favor poste aqui para algum voluntário tentar lhe ajudar.

    caso o problema do plugin dos Correios tenha parado, deve ter sido mesmo o sistema dos Correios. por favor, nos informe aqui.

    espero ter ajudado com essas informações.

    Gassho (mãos em prece), Namaste (eu lhe saúdo)

    Olá Ralden,

    Me desculpe…sempre nos primeiros posts fazemos algo de errado rss… prometo verificar as regras antes de postar algo…

    Possuo no Diagnóstico 3 melhorias recomendadas:

    1 – Temas alteram o visual do seu site. É importante mantê-los atualizados para que fiquem consistentes com a sua marca e para manter seu site seguro.
    Seu site tem 2 temas instalados e todos estão atualizados.
    O seu site não possui nenhum tema padrão. Temas padrão são utilizados pelo WordPress automaticamente se alguma coisa der errado com o seu tema normal.

    Estou utilizando o Tema Pai e Filho…

    2 – Os módulos PHP executam a maioria das tarefas no servidor que fazem seu site funcionar. Qualquer alteração deve ser feita pelo administrador do servidor.

    A equipe de hospedagens do WordPress mantém uma lista destes módulos, tanto recomendados quanto obrigatórios, no manual da equipe (abrir em uma nova aba).

    Atenção O módulo opcional imagick, não está instalado ou foi desativado.

    3 – O evento agendado action_scheduler_run_queue não foi executado. Seu site continua funcionando, mas isso pode indicar que agendamento de posts ou atualizações automáticas não funcionarão como o esperado.

    saudações @dbk100,

    tranquilo. a dica é para, como eu disse, seu tópico não deixar de ser visto por já ter uma resposta…

    sobre o Diagnóstico, o 1) é uma indicação para manter um tema padrão, para em caso de erros com o tema (tipo deixar de ser desenvolvido), o Diagnóstico usar o tema padrão para cortar algum erro; indicado manter o Tweenty Nineteen; o 2) é um módulo opcional que ajuda no carregamento de imagens, é interessante ter, mas nada que atrapalhe; mas se puder ativá-lo ou pedir sua hospedagem para ativar, seria bom; por fim o 3) é algo para ficar atento, pode ter sido um erro ocasionado naquele momento, uma coincidência, ou se for algo persistente é bom verificar uma solução.

    vi que você também abriu um tópico no fórum do plugin WooCommerce Correios. se ver outros tópicos recentes, observará que realmente estão havendo quedas e lentidão. pode ver, por exemplo, o tópico abaixo, aberto há 4 dias, mas com última resposta há 2 dias atrás:

    https://wordpress.org/support/topic/webservice-fora-do-ar-2/

    se for esse o caso, infelizmente é ter paciência.

    Ralden,

    Os correios estão com problemas constantemente… como os grandes MKPS utilizam esses correios?
    Complicado estar sempre com problemas, sendo que precisamos utilizar o frete para finalizar a compra..

    saudações @dbk100,

    se por MKPS quer dizer Marketplaces, eles não usam Correios. pelo menos não diretamente… usam serviços especializados em logística, como o Mandaê. os grandes mesmos tem é sua própria logística, como o Mercado Envios do Mercado Livre.

    além disso, até onde eu sei (pode ter mudado e eu estar errado) quem tem contrato com os Correios tem uma API diferenciada. essa API que dá problemas é a “pública”, que não recebe a mesma atenção e servidores.

    olha, uma solução para isso seria usar um plugin de frete offline voltado para a realidade brasileira. por exemplo, o @fernandoacosta tem uma solução para isso,

    https://fernandoacosta.net/meus-plugins/

    infelizmente essa questão da API é externa, o @claudiosanches não tem o que fazer contra os problemas da API “pública” dos Correios.

    Olá, @dbk100!

    Primeiramente, recomendo editar seu tópico e remover as URLs que postou, pois elas estão com seu login dos Correios.

    Mas também parece que esses dados não são de um contrato válido… Especialmente porque o código do serviço é de PAC sem contrato.

    Enfim, se clicar no link verá que ele não funciona, fica tela em branco. Mas os Correios estão funcionando (por incrível que pareça).

    O problema é que no campo senha há um #, que impede o processamento dos demais parâmetros. Remova esse atributo senha das configurações e tudo deve voltar a funcionar.

    Para remover a senha, marque nas configurações do método que tem contrato, apague os dois valores e depois mude novamente para sem contrato.

    Se não resolver, você terá que postar um pouco mais do log aqui, porque você não publicou a parte que mostraria a resposta dos Correios.

    Obrigado pela menção, @ralden! Espero que a solução ajude.

    Aaa sim… Imagino que o claudio não tem o que fazer mesmo… o complicado é conviver com esses problemas né…

    Vou verificar o que você me encaminhou e retorno em breve…

    Obrigado pela atenção!

    desenvolvedor especialista é outra coisa!!! valeu @amgnando

    @amgnando,

    Esse log foi o ultimo que tentei… o correio não está trazendo a resposta…antes estava…agora não mais…mandei o logo correspondente a esse teste que fiz…

    “Para remover a senha, marque nas configurações do método que tem contrato, apague os dois valores e depois mude novamente para sem contrato.” Pode dar mais detalhes?

    @ralden,

    Apenas moderadores conseguem editar o tópico após 30 min. Conseguem remover as URLS postadas?

    eu não sou moderador. como o tópico já foi reportado, agora é aguardar.

    @amgnando

    Em usuários, retirei o login e senha dos correios e a principio voltou… era isso que você quis dizer? Tinha apenas login e senha relacionados a correio, a parte do sem contrato não achei!

    Moderador Felipe Elia

    (@felipeelia)

    Editei a URL com as senhas, valeu pessoal!

Visualizando 14 respostas - 1 até 14 (de um total de 14)
  • O tópico ‘Problemas com o cálculo de frete dos correios’ está fechado para novas respostas.