Suporte » Ajustando o WordPress » Links Permanentes só funcionam na Página Inicial

  • Resolvido magdamartins

    (@magdamartins)


    Título original: Problemas com links permanentes

    Oi, pessoal!
    Estou com o seguinte site em WP http://www.pauloalexandrebarbosa45633.com.br e não consigo fazer os permalinks funcionarem corretamente.

    Já fiz tudo o que é indicado pelo codex e por várias dicas nos fóruns. Alterei as permissões dos arquivos e diretórios no servidor para 777, deletei o httacces para utilizar o gerado pelo WP, editei o httacces… enfim.

    Os meus links no menu estão assim para categorias:
    <a href="?cat=4">Notícias</a> e assim para páginas <a href="?page_id=3352">Propostas</a> , mas só funciona direito na home.

    Se estiver dentro da página “Propostas” e clicar no item “Notícias”, ele tenta achar a categoria “Notícias” dentro de “Propostas”, entendem?

    O .httacces gerado pelo WordPress para a estrutura /%category%/%postname/ foi esse aqui:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Se alguém puder me ajudar, agradecerei muito! =)
    Abraços

Visualizando 2 respostas - 1 até 2 (de um total de 2)
  • Oi, gente! =)
    Devo desencanar desse problema? Procurei mais e não econtrei a solução… ninguém teve esse problema? =(

    Nos arquivos do seu tema, coloque ma frente das URLs a função <?php bloginfo('wpurl'); ?>.

    Exemplo: <a href="<?php bloginfo('wpurl'); ?>?page_id=4">Perfil</a>

Visualizando 2 respostas - 1 até 2 (de um total de 2)
  • O tópico ‘Links Permanentes só funcionam na Página Inicial’ está fechado para novas respostas.