Suporte » Instalando o WordPress » Link para imagens quebrados após mudança de servidor

  • Resolvido Rics

    (@rics)


    Pessoal,

    Estou com um problema assaz irritante e não consigo encontrar a solução. Talvez esteja procurando no lugar errado, não sei, mas o fato é que não achei nenhuma referência nem no codex nem aqui nos fóruns.

    Seguinte, eu fiz uma instalação local (localhost) do wordpress e preparei tudo localmente, deixe o site pronto. Depois transferi ele pro servidor. O primeiro problema que deu foram com os links. Todos apontavam para o localhost.

    Esse problema eu resolvi usando as instruções do codex (http://codex.wordpress.org/Changing_The_Site_URL), ou seja, colocando aquelas as funções update_option() e update_option() no comecinho do functions.php, devidamente configuradas, claro.

    Problema resolvido! Estava ficando feliz já quando notei outra coisa. Todas as imagens do site que foram carregas pelo admin do WP também estão com endereços locais, então obviamente não aparecem.

    Vocês podem ver o problema acontecendo aqui: http://www.walbatroz.com/exemplo. Dêem uma olhada nos atributos src das imagens… Bizarro!

    O WP não usa URLs relativas para as imagens (mídias)?

    Alguém já passou por isso?

    Um grande abraço e obrigado desde já,
    Rics

Visualizando 4 respostas - 1 até 4 (de um total de 4)
  • Vei, provavelmente pq vc fez no localhost, dae ele ta puxando do localhost, mais o localhost é só pro local, então manda tudo pro servidor pow, eu jogo geralmente as imagens em servidores gratuitos como o Imageshack… Bem, flw ae, espero ter ajudado xd

    Você não leu o que eu escrevi, leu? :\

    A solução é substituir o endereço do localhost pelo novo endereço diretamente na base de dados.

    Acho que vc já consertou o problema, porque para mim as imagens apareceram normalmente. De qualquer forma, aí vão dois links que podem resolver o problema de outras pessoas:

    http://wordpress.org/extend/plugins/search-and-replace/

    Search and Replace in WordPress MySQL Database

    Não esqueça de fazer um backup antes!!!!

    O que eu fiz, na verdade, foi apagar a imagem do post e inserir novamente à partir da biblioteca de mídia. Por isso estava aparecendo.

    Acabei descobrindo depois só o motivo. O WordPress grava o endereço completo da imagem no post e não o endereço relativo. Aí quando você muda o domínio o link quebra.

    Obrigado pela dica dos plugins, vou usá-los.

    Outra dica, que eu estou fazendo agora, é configurar o seu servidor local com o mesmo endereço que você pretende usar online. Assim, quando você fizer o upload, tudo vai funcionar.

    O chato é ficar editando o arquivo hosts toda hora. Acho que o plugin é mais negócio mesmo.

Visualizando 4 respostas - 1 até 4 (de um total de 4)
  • O tópico ‘Link para imagens quebrados após mudança de servidor’ está fechado para novas respostas.