Suporte » Desenvolvendo com WordPress » Problemas com encode

  • Resolvido Hercules Macedo

    (@hercules-macedo)


    Boa tarde,

    Estou tendo problemas em padronizar os dados do site que estou dando manutenção, o site está com os caracteres corretos, porém os dados que trago do banco estão vindo despadronizados. Segue url do site( http://curriculomais2.azurewebsites.net )

    O arquivo wp-config está como uft-8, porém o site continua com esse problema acima.

    Imagino que muitos já tenham passado por este problema, podem me informar como resolvê-lo?

Visualizando 6 respostas - 1 até 6 (de um total de 6)
  • Moderador Deblyn Prado

    (@deblynprado)

    Hercules,

    aqui os caracteres aparecem corretos.
    Dá uma olhada se não é o encoding do seu browser que está errado.

    Criador do tópico Hercules Macedo

    (@hercules-macedo)

    Deblyn Prado, selecione algum nivel de ensino no dropdown pra vc ver, é nele q eu retorno dados do banco. Desculpa por n ter mencionado isso antes

    Moderador Deblyn Prado

    (@deblynprado)

    Dando uma olhada no site parece que a declaração do HTML tá errada, já tem caracter com problema nos comentários.

    Se quiser usar a declaração de HTML5 confere se ela tá assim:

    <!DOCTYPE html>
    <html lang="pt-br">
    <head>
    </head>

    Também tenta salvar o arquivo como UTF-8.

    Criador do tópico Hercules Macedo

    (@hercules-macedo)

    eh aparece diferente pq o template do site é antigo, infelizmente eu peguei o site depois de mts remendos e ainda n posso reescreve lo

    mas o charset esta como utf-8

    Olhando o código eu vi q aquela declaraçao vem do banco tbm, por isso está errada

    Criador do tópico Hercules Macedo

    (@hercules-macedo)

    eu consegui resolver o problema de retorno do banco apagando o db-charset=utf-8 do arquivo wp-config deixando apenas db-charset=”

    Porém em 2 páginas do site q n tem nada a ver com o banco esta acontecendo outro problema de caracteres

    http://curriculomais2.azurewebsites.net/sobre-o-curriculo-mais/

    Criador do tópico Hercules Macedo

    (@hercules-macedo)

    Tive que reescrever a página, mas os caracteres estão corretos agora

Visualizando 6 respostas - 1 até 6 (de um total de 6)
  • O tópico ‘Problemas com encode’ está fechado para novas respostas.