Suporte » Ajustando o WordPress » Problema em compartilhamento

  • Olá pessoal! Estou com um problema em meu site WP, ao fazer o compartilhamento de um determinado post em minhas redes sociais, está aparecendo informações no link que não devia, isso vem acontecendo a algum tempo, a maneira certa seria assim (link), porém aparece assim (link). Alguém sabe me dizer como fazer para ficar da maneira certa sem aparecer o nome do site e essas coisas na descrição?

Visualizando 8 respostas - 1 até 8 (de um total de 8)
  • Moderador Leo Baiano

    (@leobaiano)

    As informações que aparecem nas redes sociais normalmente vem das tags OG, essas tags são adicionadas no tema ou através de plugin e cada plugin ou tema trata isso de uma forma diferente. O que você está usando para inserir essas tags? Yoast? JetPack? Veio no tema?

    Moderador Mário Valney

    (@mariovalney)

    WordPress Cleric of Fire

    Olá @ucas.
    O compartilhamento em questão é no Facebook, certo?
    Eu explico nesse artigo como funciona, mas basicamente você precisa ter as tags certas para que o conteúdo compartilhado seja o que você queira.

    A forma mais fácil é um plugin de SEO como o Yoast. Porém existem plugins específicos para as essas tags do Facebook (og-tags). Além disso, é possível que seu tema tenha essa implementação, então tente dar uma olhada no código-fonte (Ctrl+U se estiver no Chrome) e verificar se já não estão lá.

    As tags OG vieram do próprio tema porém agora que está ficando dessa forma, antes ficava normal. Sim o compartilhamento é no facebook.

    Moderador Leo Baiano

    (@leobaiano)

    Tem que ver o que seu tema está escrevendo no title da tag OG. Da uma olhada ai onde o tema gera elas e cola aqui pra gente ver.

    Não entendo muito de desenvolvimento não, porém achei essa página (seria isso)->

    <?php 
    /*
    Template Name: Tags
    */
    ?>
    <?php get_header(); ?>
    	<div class="content">
    		<?php tie_breadcrumbs() ?>
    				
    		<?php if ( ! have_posts() ) : ?>
    			<?php get_template_part( 'framework/parts/not-found' ); ?>
    		<?php endif; ?>
    		
    		<?php if ( have_posts() ) while ( have_posts() ) : the_post(); ?>
    		
    		<?php $get_meta = get_post_custom($post->ID);  ?>
    		<?php //Above Post Banner
    		if( empty( $get_meta["tie_hide_above"][0] ) ){
    			if( !empty( $get_meta["tie_banner_above"][0] ) ) echo '<div class="e3lan e3lan-post">' .do_shortcode( htmlspecialchars_decode($get_meta["tie_banner_above"][0]) ) .'</div>';
    			else tie_banner('banner_above' , '<div class="e3lan e3lan-post">' , '</div>' );
    		}
    		?>
    		
    		<article class="post-listing post">
    			<?php get_template_part( 'framework/parts/post-head' ); ?>
    			<div class="post-inner">
    				<h1 class="post-title"><?php the_title(); ?></h1>
    				<p class="post-meta"></p>
    				<div class="clear"></div>
    				<div class="entry">
    					<?php the_content(); ?>
    					<?php wp_link_pages( array( 'before' => '<div class="page-link">' . __ti( 'Pages:' ), 'after' => '</div>' ) ); ?>
    					
    					<?php 
    						$args = array(
    						'smallest'                  => 8, 
    						'largest'                   => 22,
    						'unit'                      => 'pt', 
    						'number'                    => 0);
    						
    						wp_tag_cloud( $args );
    					?>
    						
    					<?php edit_post_link( __ti( 'Edit' ), '<span class="edit-link">', '</span>' ); ?>
    				</div><!-- .entry /-->	
    			
    			</div><!-- .post-inner -->
    		</article><!-- .post-listing -->
    		<?php endwhile; ?>
    		
    		<?php //Below Post Banner
    		if( empty( $get_meta["tie_hide_below"][0] ) ){
    			if( !empty( $get_meta["tie_banner_below"][0] ) ) echo '<div class="e3lan e3lan-post">' .do_shortcode( htmlspecialchars_decode($get_meta["tie_banner_below"][0]) ).'</div>';
    			else tie_banner('banner_below' , '<div class="e3lan e3lan-post">' , '</div>' );
    		}
    		?>
    		
    		<?php comments_template( '', true ); ?>
    	</div><!-- .content -->
    
    <?php get_sidebar(); ?>
    <?php get_footer(); ?>
    Moderador Leo Baiano

    (@leobaiano)

    @ucas entendo que você não compreenda muito de desenvolvimento mas para te ajudar precisamos que ajude um pouco. Primeiro, você disse que as tags OG estavam no tema, então imaginei que sabia onde era, por isso não te falei que provavelmente estavam no header.php. Agora que você postou esse arquivo, que claramente é o errado visto que não tem nenhuma tag OG ai, fiquei em dúvida se você sabia o que estava falando quando disse que estava no tema.

    Diante disto, você tem como compartilhar a URL do seu site para que eu tente identificar?

    Sim, o site é este! pensei que estaria pois antes eu compartilhava normalmente os links nas redes sociais, porém alguma coisa ocorreu que ficou daquela forma.

    Pessoal, gostaria muito de uma ajuda neste sentido também.

    A url do site é site e ao verificar no debug do facebook developers, encontro as seguintes mensagens:

    Warnings That Should Be Fixed
    Imagem muito pequena
    Provided og:image URL, http://portaldeguacui.com.br/wp-content/uploads/2016/11/polícia-civil.png was not valid because it did not meet the minimum size constraint of 200px by 200px.
    Share App ID Missing
    The ‘fb:app_id’ property should be explicitly provided, Specify the app ID so that stories shared to Facebook will be properly attributed to the app. Alternatively, app_id can be set in url when open the share dialog.
    Attempted Frozen Title Change
    It appears that you are trying to change the property og:title from Policiais civis prendem suspeito de tentativa de homicídio em Guaçuí to Policiais civis prendem suspeito de tentativa de homicídio em Guaçuí . If so, you are not allowed to for this object because too many actions have been published against it.

    A url da imagem aponta para um artigo (http://portaldeguacui.com.br/wp-content/uploads/2016/11/polícia-civil.png ) e também em URL canônica mostra este mesmo artigo.

    Quando tento compartilhar um artigo, só aparece um quadro branco no local da imagem e o título do site (não do artigo).

    Eu instalei o YOAST SEO mas não mudou nada ou quase nada.

    Agradeço desde já qualquer ajuda e esclareço que não tenho grandes conhecimentos sobre o assunto.

Visualizando 8 respostas - 1 até 8 (de um total de 8)
  • O tópico ‘Problema em compartilhamento’ está fechado para novas respostas.