Suporte » Ajustando o WordPress » Problema com Mídias e Bliblioteca

  • Bom dia!
    Não estou conseguindo inserir nenhuma imagem nas postagens do meu site. Elas fazem o upload, mas a galeria de mídias não abre as miniaturas, e não insere imagens mesmo que eu tente por url.

    Já fiz o teste com os plugins, desativando um por um, e não resolveu o problema.
    Também já verifiquei e não há nenhum erro de javascript no console.

    Meu site é este aqui: http://indumentaria.info/

    Imagem de como fica a biblioteca: file:///C:/Users/Hellen/Desktop/erro.png

    Ela parece ficar tentando carregar eternamente e não carrega. Faz o upload das imagens mas elas não aparecem ali, tampouco consigo inserir no post ou na imagem destacada.

    Muito agradecida!

    • Este tópico foi modificado 5 anos, 2 meses atrás por Mário Valney. Motivo: Removida menção
Visualizando 5 respostas - 1 até 5 (de um total de 5)
  • Criador do tópico halbus

    (@halbus)

    Mais uma coisa: ativei o debug do wordpress, aparece a seguinte mensagem:

    Notice: wpcf7_add_shortcode foi descontinuada desde a versão 4.6 do Contact Form 7! Utilize a wpcf7_add_form_tag no lugar. in /home/indum601/public_html/wp-content/plugins/contact-form-7/includes/functions.php on line 357

    E

    Notice: O método construtor chamado para WP_Widget em MostLikedPostsWidget esta depreciado desde a versão 4.3.0! Utilize
    __construct()
    no lugar. in /home/indum601/public_html/wp-includes/functions.php on line 3893
    • Esta resposta foi modificada 5 anos, 2 meses atrás por halbus.
    • Esta resposta foi modificada 5 anos, 2 meses atrás por halbus.
    • Esta resposta foi modificada 5 anos, 2 meses atrás por Mário Valney.
    Criador do tópico halbus

    (@halbus)

    Resolvi com o servidor.

    Moderador Mário Valney

    (@mariovalney)

    WordPress Cleric of Fire

    Vamos lá. Algumas dicas:

    1 – Não precisa mencionar ou marcar ninguém sem ser solicitado. Todo o trabalho aqui no Fórum é voluntário e ninguém tem a obrigação de te responder.

    2 – Tente não responder seu próprio tópico após criá-lo. Isso vai fazer ele sair da lista de Tópicos sem Resposta e geralmente focamos nessa lista para ajudar.

    Agora sobre os problemas:

    O primeiro erro que você viu é porque algum plugin ou tema está usando a função errada do Contact Form. Você pode tentar atualizar tudo ou procurar por wpcf7_add_shortcode nos arquivos do seu site e substituir pela nova função wpcf7_add_form_tag (não sei se são utilizadas da mesma forma, a melhor maneira, caso não tenha conhecimento de programação é comunicar o autor do tema/plugin que seu código está depreciado).

    O segundo erro é por causa de alguma widget do Tema ou de algum plugin que ainda não está usando a forma correta do WordPress mais atualizado. A solução é a mesma do erro 1: atualizar ou então procurar por MostLikedPostsWidget e trocar o método construtor (deve ser um método – function – dentro da classe com o mesmo nome dela) por __construct.

    Resolvi com o servidor.

    Isso era sobre o problema do tópico (upload)?

    Tive o mesmo problema e consegui resolver retirando os espaços depois da tag de fechamento do PHP no functions.php do child theme. Esse problema também pode acontecer caso tenha algum comentário HTML no mesmo arquivo (functions.php do child theme). Retirei os espaços e voilá! A biblioteca de mídia em modo grid voltou ao normal.

    Moderador Mário Valney

    (@mariovalney)

    WordPress Cleric of Fire

    @dmarchetti tudo bem?

    Para evitar esses problemas com espaços após a tag de fechamento do PHP, você pode simplesmente omiti-la. Ou seja, seu arquivo .PHP pode ser assim:

    <?php
    funcao_de_exemplo();
    
    ?>
    <a href="#>exemplo</a>
    
    <?php 
    
    mais_um_poquinho_de_php();

    Desde que o final seja PHP. Se for ter HTML depois, precisa fechar, claro.

    Abraços

Visualizando 5 respostas - 1 até 5 (de um total de 5)
  • O tópico ‘Problema com Mídias e Bliblioteca’ está fechado para novas respostas.