Suporte » Desenvolvendo com WordPress » Problema com Custom Permalink! Só consigo usar o estilo “plain”

  • Olá, sou iniciante com wordpress e estou com um problema que não consegui resolver mesmo pesquisando avidamente na web…

    Quando mudo a estrutura de permalinks do WordPress (em, Settings > Permalink), todas as páginas que estão fora da homepage param de funcionar e recebo o erro “Objeto não encontrado, erro 404…”. Isso deixa de acontecer quando eu volto o permalink para a opção “plain”, que é a dafault do WordPress.

    Até agora isso não era um problema muito grande pois todo o meu site estava concentrado na homepage, mas agora que quero criar outras páginas preciso resolver isso…

    Algumas informações adicionais:

    -Já tentei clicar em “Save Changes” em Settings > Permalinks, nada acontece
    -Estou utilizando o tema OnetonePro, mas já tentei trocar e verifiquei que o problema não está no tema
    -Tentei desativar os plugins e também não fez diferença
    -Minha .htaccess está conforme o recomendado e não adicionei mais nada a ela. Também já tentei criar uma nova, segundo o “padrão” básico e não fez diferença.
    -O .htaccess está com a permissão de valor 644
    -Tentei mudar a estrutura de permalink para todas as opções que o WordPress permite e somente “plain” é que funciona direito
    -O site é um subdomínio de outro site, mas possui endereço próprio. Não sei se faria diferença, mas nunca se sabe…
    -Já liguei no meu serviço de hospedagem (Locaweb) e eles disseram que não tem a ver com a hospedagem

    Obrigado pela atenção!

    • Este tópico foi modificado 2 anos, 4 meses atrás por alexnzion.

    A página que eu preciso de ajuda: [fazer login para ver o link]

Visualizando 1 resposta (de um total de 1)
  • olá @alexnzion,

    algumas considerações,

    “Já tentei clicar em “Save Changes” em Settings > Permalinks, nada acontece”
    se você está clicando no botão e não está salvando, sim, realmente tem algo de muito errado. como você instalou o WordPress? usando algum script ou você usou o arquivo no site br.wordpress.org?

    “-O .htaccess está com a permissão de valor 644”
    cada hospedagem tem suas regras de segurança e por vezes interferem no WordPress realizar ações. especialmente hospedagem compartilhadas.

    já usei várias hospedagens (atualmente estou no Google Cloud e não saio, é bom demais) e por vezes tinha que dar manualmente permissões de escrita, rodar algo do WordPress e depois voltar para a permissão normal.

    você pode ver no link abaixo, do Codex do WordPress, a documentação sobre permalinks. como você poderá ver, para funcionar, a mudança passa pelo arquivo .htaccess,

    https://codex.wordpress.org/Using_Permalinks

    inclusive há uma seção nesse link, “Fixing Permalink Problems”, você verá que a primeira recomendação é justamente mudar as permissões do .htaccess.

    “-Tentei mudar a estrutura de permalink para todas as opções que o WordPress permite e somente “plain” é que funciona direito”
    acredito que como seu WordPress não consegue alterar o .htaccess, por isso somente “plain” funciona. pois é o padrão. sem alterar o .htaccess, outros tipos de links não são registrados no .htaccess. ai o WordPress não consegue fazer a mudança nos links e gera erro 404 de página não existente.

    “-Já liguei no meu serviço de hospedagem (Locaweb) e eles disseram que não tem a ver com a hospedagem”
    se sua hospedagem é compartilhada, esse tipo de situação realmente não será resolvida pelo suporte. eles tem um padrão de regras e você que se adapte.

    o ideal seria um profissional especializado em hospedagem lhe dar orientações. pois esse tipo de erro provavelmente irá afetar também instalação e uso de plugins que você queira.

    eu, quando usava hospedagem de empresas gigantes, como uol e locaweb, partia para o setor de cancelamento e informava meu problema. pois para não perder o cliente ai eles costumam passar realmente para técnico de suporte. e não profissionais de atendimento que por vezes dão resposta padrão para certos casos…

    abraços e boa sorte,

Visualizando 1 resposta (de um total de 1)
  • O tópico ‘Problema com Custom Permalink! Só consigo usar o estilo “plain”’ está fechado para novas respostas.