Suporte » Outros assuntos » Problema ao tentar instalar um tema (php.ini, .user.ini, .htaccess)

  • Olá caros amigos!!

    Estou me deparando com um problema que para mim é atípico, pois instalei o wordpress, versões 4.9 e o mais atual 5.0 e nas duas versões encontro a dificuldade de instalar apenas o tema, plugin eu consigo instalar, mas o tema não.

    Toda vez que vou instalar o tema vem o erro a seguir:
    “O arquivo ultrapassa o limite definido em upload_max_filesize no php.ini.”

    Esse erro aparece com a versão 5.5 do php e superior, mas na versão 5.4 do php funciona normalmente.

    Independente de usar o php.ini ou .user.ini o erro aparece quando tento subir qualquer tema.

    Vejam as linhas dos arquivos php.ini e .user.ini
    =============================
    upload_max_filesize = 200M
    post_max_size = 200M
    memory_limit = 256M
    date.timezone = “America/Sao_Paulo”
    extension=pdo.so
    extension=pdo_mysql.so
    extension=pdo_sqlite.so
    extension=mysql.so
    max_execution_time = 90
    session.auto_start = On
    session.use_cookies = On
    session.use_only_cookies = On

    # session.save_path = “”
    extension=curl.so
    allow_url_fopen = On
    allow_url_include = On
    output_buffering = On
    implicit_flush = On

    # Corrigindo falha de PDO inativo para Acesso ao bco de dados
    extension=php_mbstring.dll
    extension=mysqlnd.so
    extension=mysqlnd_mysqli.so
    extension=mysqlnd_mysql.so
    extension=pdo_mysqlnd.so
    extension=pdo.so
    extension=pdo_mysql.so
    extension=pdo_sqlite.so
    extension=mysql.so
    extension=simplexml.so
    extension=xmlreader.so
    extension=xmlrpc.so
    extension=xml.so
    extension=xmlwriter.so
    extension=dom.so
    extension=ctype.so
    extension=gd.so
    extension=mbstring.so
    extension=json.so
    extension=ftp.so
    # session.cookie_domain = “www.dominio.com.br”;
    # output_buffering = On
    # session.cache_limiter = public
    # register_globals = On
    # register_long_arrays = On
    extension=mcrypt.so
    ===============================

    O site é um site provisório para apresentação e por isso não tenho o domínio registrado. o mesmo está locado na Locaweb, já recorri ao suporte mas eles alegam que o problema está no wordpress (acho muito difícil)

    Se alguém se deparou com esse problema e solucionou, por favor, compartilhe a solução aqui.

    Desde já agradeço a atenção e colaboração.

    A página que eu preciso de ajuda: [fazer login para ver o link]

Visualizando 3 respostas - 1 até 3 (de um total de 3)
  • CB

    (@cbrandt)

    Esse erro aparece com a versão 5.5 do php e superior, mas na versão 5.4 do php funciona normalmente.

    Olá, Eduardo,

    Não sei a resposta para o seu problema, mas usar PHP anterior a 7.1 passou a ser uma vulnerabilidade de segurança, uma vez que a versão 5.6 e a 7.0 chegaram ao “fim da vida” dia primeiro de janeiro, e não devem mais ser atualizadas. Para a 5.6 o php ainda lançou um update de segurança 5.6.40 dia 10, mas pode ser o último.

    Quanto ao erro em si, vc se lembrou de reiniciar (ou pedir para o Locaweb reiniciar) o http depois de editar o php.ini?

    Bom dia CB.

    Caro, antes de mais nada, agradeço sua atenção..
    Não havia pedido o reinicio do http, mas já pedi no chamado que o façam, tomara que seja algo neste sentido.

    Esse reinício eu consigo fazer através do Cpanel?

    CB

    (@cbrandt)

    Olá, Eduardo,

    Isso depende da sua configuração de cPanel. Geralmente em hospedagem compartilhada não fica disponível. Mas se estiver disponível vai ter um botão Restart Services (Reiniciar Serviços) onde vc poderá escolher Restart HTTP Server (Apache).

    Boa sorte!

Visualizando 3 respostas - 1 até 3 (de um total de 3)
  • Você deve estar conectado para responder a este tópico.