Suporte » Instalando o WordPress » Problema ao restaurar backup

  • rafaelbuarque

    (@rafaelbuarque)


    Olá pessoal.
    Essa é minha primeira postagem aqui.
    Estou com um pequeno problema ao tentar restaurar o backup do meu site. Utilizo o Wamp 2.5, e o WordPress 4.2.2

    Instalo o WAMP normalmente, depois crio um banco de dados e importo o arquivo SQL do meu banco de dados antigo. Até aí dá tudo certo. Copio a pasta zipada do meu site para o diretório www do WAMP, extraio, e ele aparece na sessão projetos do localhost. Só que quando clico pra abrir o projeto dá “SERVIDOR NÃO ENCONTRADO”. No Chrome dá “ESSA PÁGINA DA WEB NÃO ESTÁ DISPONÍVEL”.
    Se digito o 127.0.0.1/pindorama, que é o nome do meu site, ele abre o meu site normalmente. Só que só funciona a página principal. Se clico em qualquer outras das páginas aparece a seguinte mensagem:

    Not Found
    The requested URL /pindorama/youtube/ was not found on this server.

    Se digito 127.0.0.1/pindorama/wp-admin, consigo entrar normalmente no painel do meu site. Todos os post estão lá, as páginas, os plugins. Inclusive já atualizei tudo o que tinha pra atualizar. Mas persiste o problema. Se tento visualizar o site só consigo ver a página inicial. Todas as outras páginas dá o erro “not found”.

    Alguém sabe porque isso está ocorrendo? Qual a maneira de resolver esse problema?

    Desde já, muito obrigado a todos!

Visualizando 1 resposta (de um total de 1)
  • Boa noite,

    Espero que já tenha resolvido o problema, mas caso ainda não, o problema provavelmente é na migração do banco de dados, que acontece principalmente quando um site é online e o outro é offline. Ou seja, se você está usando um banco de dados de um site que estava online em servidor e agora quer importar para um site offline, em máquina local, as referências de url no banco de dados causam esse tipo de erro.

    A melhor forma de transferir site é com serviços de backup com restauração. Eu uso o BackupBuddy, da iTheme (aliás, uso é o pacote completo de plugins deles, pois o Security Pro e o Sync são outros plugins fantásticos), mas existem outros. Pois nesse caso basta um clique e uma importação e pronto, o próprio plugin reescreve as url no banco de dados, resolvendo o problema. Essa é a melhor maneira de resolver o problema.

    Favor informar se conseguiu resolver. Se sim, favor marcar o tópico como resolvido. E desculpas pela demora em receber uma resposta, mas aparentemente todos os usuários ativos do fórum estamos sobrecarregados em nossos projetos.

    Saudações e boa sorte!

Visualizando 1 resposta (de um total de 1)
  • O tópico ‘Problema ao restaurar backup’ está fechado para novas respostas.