Suporte » Plugins » Plugin Learnpress desativou os links do site

  • carollineprado

    (@carollineprado)


    Olá, baixei a versão atualizada do plugin Learnpress e depois não consegui mais acessar os menus e botões do site. Baixei a versão antiga na qual o site funcionava normal e instalei no meu painel mas mesmo assim os links não estão funcionando. Pode me ajudar por favor?

    A página que eu preciso de ajuda: [fazer login para ver o link]

Visualizando 15 respostas - 1 até 15 (de um total de 15)
  • Bom dia @carollineprado ,

    Todas as URLs estão redirecionando para a página inicial, se você desabilitar o LearnPress as páginas voltam a funcionar?

    carollineprado

    (@carollineprado)

    Sim, com o Learnpress desativado o site funciona normalmente. O problema é que eu preciso do learnpress no meu site. Com ele ativo eu também não consigo editar páginas com o elementor. Na versão anterior funcionava normalmente mas depois eu atualizei o plugin mesmo baixando a versão anterior de novo não funciona

    carollineprado

    (@carollineprado)

    Oi Filipe, conseguiu achar alguma solução?

    Bom dia,

    Me parece que esse problema é do plugin Membership Plugin – ARMember

    Você pode tentar desativá-lo e ver se volta a funcionar?

    carollineprado

    (@carollineprado)

    Bom dia Filipe, você pode me dizer qual erro você encontrou neste plugin? Eu desativei ele mas continua não funcionando. O pessoal do suporte da Learnpress me mandou um código dizendo que tem um erro no addon navmenu. Posso te mandar por e-mail o que eles me mandaram?

    Identifiquei que quando acessa alguma página do menu (Aulas, por exemplo), me redireciona para ?restricted=page. Esta querystring é do plugin Membership Plugin – ARMember

    Seguindo as diretrizes do fórum, peço que coloque aqui o código enviado pelo suporte do Learnpress, uma vez que não é permitida a divulgação de e-mail.

    carollineprado

    (@carollineprado)

    Ah sim, então essa página Aulas por exemplo está restrita mesmo ao login do usuário. Mas a questão é que quando eu desativo o Learnpress o site funciona normalmente. Então acredito que o erro não seja no ArMember. Aqui está o link do código que o suporte da Learnpress me mandou:

    http://colegioaprendizpraiagrande.com.br/wp-content/plugins/navmenu-addon-for-elementor/assets/js/frontend.min.js?ver=1.1.6

    Entendi, o que eles falaram sobre esse link? Não há nada errado com ele, o que está acontecendo é um redirecionamento no backend (algum código PHP)

    carollineprado

    (@carollineprado)

    Eu ativei uma opção no site pra quando houver página de erro redirecionar pro início. O que eles me mandaram no email foi isso aqui:

    Hi Carolline,

    I see there is javascript error in your website: TypeError: this.el is null in file: http://colegioaprendizpraiagrande.com.br/wp-content/plugins/navmenu-addon-for-elementor/assets/js/frontend.min.js?ver=1.1.6

    Can you try to clearcache or re-update/re-publish the menu?

    carollineprado

    (@carollineprado)

    Filipe eu falei uma coisa errada ali, eu não ativei nenhuma opção de redirecionamento em caso de erro.

    Ah entendi…

    Mas o redirecionamento está dando porque as páginas estão dando erro? Você consegue desativar essa opção para que possamos ver o erro? Assim fica mais fácil identificar o problema.

    carollineprado

    (@carollineprado)

    Oi Filipe então, eu me confundi. Não tem nenhuma opção pra redirecionar pro início em caso de erro. Eu vi algumas pessoas no fórum falando que tem uma incompatibilidade do Learnpress com o Elementor, você acha que pode ser isso? E esse email que o suporte da Learnpress me mandou falando sobre o erro no menu, você acha que faz sentido?

    Não acho que faça sentido, está acontecendo um redirecionamento no backend, esse e-mail que mandaram é apenas um erro no frontend…

    Já tentou ir em Configurações -> Links Permanentes e clicar em Salvar?

    carollineprado

    (@carollineprado)

    O pessoal da hostgator me instruiu a salvar as configurações dos links permanentes, eu fiz isso, mas não funcionou…

    carollineprado

    (@carollineprado)

    Boa tarde, consegui resolver o problema através de uma consultoria. O erro estava na página “minha conta” do Learnpress. Uma opção que precisava estar ativa e não estava. Mas, obrigada pela ajuda!

Visualizando 15 respostas - 1 até 15 (de um total de 15)
  • O tópico ‘Plugin Learnpress desativou os links do site’ está fechado para novas respostas.