Suporte » Ajustando o WordPress » O wordpress não identifica acentos e os troca por símbolos

Visualizando 15 respostas - 1 até 15 (de um total de 15)
  • enapupe

    (@enapupe)

    Veja o header do seu tema:

    <meta http-equiv="Content-Type" content="text/html; charset=UTF-3" />

    Primeiro experimente remover esta linha, se não resolver, mude o 3 pra 8:

    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

    Você está forçando um charset inválido (utf-3).

    Moderador Leo Baiano

    (@leobaiano)

    No wordpress.com é possível alterar o código fonte dos temas? Achava que não… Se sim, tenta isso que o enapupe sugeriu, caso contrário vai precisar mudar de tema. Apesar de que olhei seu blog e parece que só tem esse problema com caracteres na palavra “comentário”.

    Criador do tópico marcodsousa

    (@marcodsousa)

    Voltando..
    Não consegui editar meu CSS não..
    pra cutomizar tem que aprimorar..
    E aí..
    Minha única solução é mudar de tema?
    Mas o problema é até no painel do meu blog..
    (como se pode ver nas imagens)..
    Estou a espera de soluções..
    Obrigado pela ajuda..

    Criador do tópico marcodsousa

    (@marcodsousa)

    Agradeço a atenção do enapupe e leobaiano.. Estarei a espera de mais respostas..

    Criador do tópico marcodsousa

    (@marcodsousa)

    Bem, tentei encarar a realidade de trocar de tema.. Olha no que deu.. Os erros continuaram a persistir..

    http://docs.google.com/leaf?id=0B3MntD2pB0BUZjU0NTQwYjYtNDgxMy00NjVlLWJkMTgtN2Q3Yjc4NWY5ZWM0&hl=pt_BR&authkey=CL286eYK

    Socorram-me!

    Criador do tópico marcodsousa

    (@marcodsousa)

    Aqui,
    isto está ficando cada vez mais estranho..
    Olhem lá..
    Quando você clica no autor da postagem (Marco Sousa) os acentos são substituídos por <?>, equanto o erro de menu (início para inãcio) e outros como a palavra comentário (COMENTÁRIO para COMENTÁiRIO)consertam. Agora nem tenho a mínima ideia de onde possa estar o erro.

    LINK 1: http://meussims.wordpress.com/
    LINK 2 (Quando se clica no autor): http://meussims.wordpress.com/author/mundovirtualdossims/

    Moderador Leo Baiano

    (@leobaiano)

    Parceiro, no WordPress defina o charset como UTF-8. Notei que os erros só estão ocorrendo em palavras escritas diretamente nos arquivos, logo o problema deve ser no charset dos arquivos do tema, como são temas do diretorio sugiro que mude o charset do WordPress para utf-8.

    Criador do tópico marcodsousa

    (@marcodsousa)

    E como faço isto?
    Não sou novo no wordpress mas não sei de muita coisa..

    Moderador Leo Baiano

    (@leobaiano)

    Não uso o wordpress.com, uso instalação própria, aqui no meu é em Configurações/ Leitura ai tem a opção “codificação para páginas e feeds”, marca UTF-8.

    Criador do tópico marcodsousa

    (@marcodsousa)

    Bem isso ajudou num e atrapalhou noutro..
    Os menus consertaram mas os textos estão com falahas..
    Dê uma olhada lá..

    http://www.meussims.wordpress.com

    Criador do tópico marcodsousa

    (@marcodsousa)

    Será que não existe um outro UTF que deixe tudo em ordem?
    Obrigado…
    Pelo menos estou caminhando..

    **último post:**
    falhas e não falahas

    enapupe

    (@enapupe)

    Nova expansão de The Sims 3 permite que o jogador torne um vampiro.” É a frase que inicia um post publicado pelo Canal dos Games. Veja mais do post:

    Este parágrafo apresenta ‘erros’ nos acentos, mas me parece um texto vindo do BD (post), ao forçar o charset para ISO-8859-1 ele se apresenta de maneira correta.

    E o fórum correto para você pedir ajuda é o do wordpress.com, este fórum é destinado a instalações independentes do WP.

    Criador do tópico marcodsousa

    (@marcodsousa)

    Obrigado pessoal por tudo..
    Agora só precisei substituir os <?> pelos acentos adequados..
    Agora desculpem-me se começei no fórum errado..
    Mas valeu a ajuda..

    Criador do tópico marcodsousa

    (@marcodsousa)

    Mas, sem querer pedir muito..
    Quando coloco categorias com acentos elas simplesmente não aparecem.
    Mas o que já foi resolvido está de bom tamanho..

    Meu peoblema é um pouco diferente:
    Meu charset no wp-config e database está configurado para UTF-8, o blog parece perfeito no navegador, mas quando fui enviar para o Facebook as palavras foram trocadas para “não” ao invéz de “não”.
    Não consigo entender porque para o navegador as palavras vem perfeitas do banco de dados, mas o Facebook ocorre isso.
    Pesquisei no google e encontrei varias respostas diferentes, uns dizem que o melhor para Português é UTF-8 outros dizem que tem que ser ISO-8859-1. Pedi ajuda aos tecnicos do servidor e eles só fazem o que eu pedir, mas como vou pedir o que não sei?
    Alguem já teve esse problema?

Visualizando 15 respostas - 1 até 15 (de um total de 15)
  • O tópico ‘O wordpress não identifica acentos e os troca por símbolos’ está fechado para novas respostas.