• Resolvido Kallil

    (@kallil)


    Alguns dias atrás percebi que aquele painel de administrador que fica na parte de cima do blog quando você o acessa estando logado não estava aparecendo mais, no lugar ficava um espaço em brando, com isso também o rodapé sumiu, onde diz “Powered by..” mesmo eu acessando o meu blog não estando logado o rodapé não aparece, não me lembro se isso aconteceu quando reinstalei a versão 3.5.1 do WordPress.
    Tentei reinstalar o tema mas não funcionou, algumas alterações que eu fiz voltaram como eram, mas o problema não resolveu.

    Obs:Quando troquei o meu tema para algum outro padrão do WordPress o painel administrativo e o rodapé apareceram.

Visualizando 9 respostas - 1 até 9 (de um total de 9)
  • Kallil, isso é porque no tema que vocês estava utilizando, o footer está sem o <?php wp_footer(); ?>, isso faz com que a barra de admin do topo, apareça.

    E como você disse que o rodapé sumiu, provavelmente seu footer.php, está com problemas ou foi deletado :D, da uma olhadinha no template.

    Criador do tópico Kallil

    (@kallil)

    Não funcionou 🙁 adicionei essa linha no foother.php mas não obtive êxito, o estranho é que já substitui o arquivo foother.php botando o original de volta mas o problema continua. Segue abaixo os códigos para um melhor entendimento:

    ESSE É O DO FOOTHER.PHP DE UM TEMPLATE PADRÃO DO MEU WORDPRESS:

    <?php
    /**
    * The template for displaying the footer.
    *
    * Contains footer content and the closing of the
    * #main and #page div elements.
    *
    * @package WordPress
    * @subpackage Twenty_Twelve
    * @since Twenty Twelve 1.0
    */
    ?>
    </div><!– #main .wrapper –>
    <footer id=”colophon” role=”contentinfo”>
    <div class=”site-info”>
    <?php do_action( ‘twentytwelve_credits’ ); ?>
    ” title=”<?php esc_attr_e( ‘Semantic Personal Publishing Platform’, ‘twentytwelve’ ); ?>”><?php printf( __( ‘Proudly powered by %s’, ‘twentytwelve’ ), ‘WordPress’ ); ?>
    </div><!– .site-info –>
    </footer><!– #colophon –>
    </div><!– #page –>

    <?php wp_footer(); ?>
    </body>
    </html>

    JÁ ESSE É O ORIGINAL DO TEMA QUE ESTOU USANDO E ESTÁ COM ESSE PROBLEMA (já resetei usando ele mas não resolve):

    <div class=”span-24″>
    <div id=”footer”>Copyright © “><?php bloginfo(‘name’); ?> – <?php bloginfo(‘description’); ?></div>

    <div id=”credits”>Powered by WordPress</div>
    </div>
    </div>
    </div>
    <?php
    wp_footer();
    echo get_theme_option(“footer”) . “\n”;
    ?>
    </body>
    </html>

    Eduardo

    (@eduardozulian)

    Kallil, o seu tema é filho de algum ou você começou um do zero? A barra superior é chamada via javascript, então pode tar rolando um conflito (acesse o console de erros dentro do seu navegador). Outra possibilidade é que você tenha usado um filtro para remover a barra de admin, então seria bom procurar por algum desses padrões dentro do seu arquivo functions.php.

    Ali em cima, também percebi que você escreveu foother.php, então aproveita pra dar uma olhada se não tá editando o arquivo errado!

    Criador do tópico Kallil

    (@kallil)

    O tema que eu uso é um que eu comprei mesmo, antes funcionava a barra normalmente mas de um tempo pra cá não mais, inclusive hoje mesmo eu vi que já tinha a versão 4.0 desse meu tema, a que eu estava até então era a 3.1 fiquei com esperança de que fosse esse o problema e de imediato atualizei o tema, mas mesmo assim não resolveu 🙁 segui suas instruções de possíveis problemas que pudessem estar ocorrendo mas nenhum deles foi o meu, quanto ao “foother.php” eu estava escrevendo errado mesmo, o arquivo que quiz dizer era footer.php
    O estranho é que problema em uma sistemática além do tema não seria, porque senão os meus outros temas teriam o mesmo problema, e mesmo com esse meu tema zerado o problema persiste, mesmo quando não estou logado e dou uma olhada no site, o rodapé não aparece, é pra ser no tema mas onde será oO

    Prezado Kallil,

    Para verificar se pode ser o Javascript, da uma olhada no firegbug -> console ao entrar no seu wordpress com esse tema em questão, verifica se ele retorna algum tipo de erro no console.

    Porque se não, seria de grande importância, ter o original desse seu template, para que possa comparar.

    Atenciosamente,
    Agencia Dev4
    Consultoria em wordpress, joomla e prestashop.

    Criador do tópico Kallil

    (@kallil)

    Olá, dei uma olhada no firebub mas EU não consegui identificar nenhum erro, sou leigo nesses assuntos de códigos, quanto ao meu template ele é original sim, o meu site em questão é esse > Lucro Ideal podem ver que o rodapé não aparece, se precisar que eu disponibilize algo para uma pesquisa mais aprofundada no problema é só pedir.

    Muito obrigado

    Eduardo

    (@eduardozulian)

    Vamo confirmar: seus arquivos estão chamando a função get_footer()?

    Criador do tópico Kallil

    (@kallil)

    Nosssaaa, problema resolvido! nunca imaginei que fosse algo tão simples, e de tão simples tão improvável também, o problema era um banner em flash meu de afiliado que eu havia posto na lateral do blog, eu uso o Opera sabe, mas como o Chrome é mais compatível acessei o meu blog dele e fui na opção “Console JavaScript” (coisa que não achei no Opera) dali apareceu um único erro, vi que fazia referência a esse meu banner, dai experimentei retirá-lo da lateral do blog e tudo voltou ao normal 😀
    Obrigado ai pessoal!

    Prezado Kallil,

    Parabéns por encontrar o problema, sempre que precisar estamos ai.

    Atenciosamente,
    Agencia Dev4
    Consultoria em wordpress, joomla e prestashop.

Visualizando 9 respostas - 1 até 9 (de um total de 9)
  • O tópico ‘O meu painel de administrador e o rodapé não aparecem mais’ está fechado para novas respostas.