Suporte » Outros assuntos » Não envia email de ativação

  • Olá

    Por favor solicito ajuda pois já pesquisei muito e não encontro o problema, o Meu site em WordPress funciona tudo certinho, com exceção de envio de email de ativação de novo usuário, os outros emails funcionam, como redefinição de senha, cancelamento da conta, novas publicações etc… enfim todos os emails que o wordpress enviam de notificação tanto para os usuários como para o administrador estão ok. estou usando o plugin WP MAIL SMTP ja tentei com conta gmail e com email do dominio.

    Agradeço a ajuda

    A página que eu preciso de ajuda: [fazer login para ver o link]

Visualizando 6 respostas - 1 até 6 (de um total de 6)
  • bom dia @edupoli,

    olha, vendo uma resposta a outro tópico que tem um pouco a ver com o seu,

    https://br.wordpress.org/support/topic/redirecionamento-2/

    é possível ver que o tema pode influenciar nisso.

    sugiro que dê o máximo de informações possíveis, como o tema que está usando (se é free ou pago) e se há outros temas envolvidos nessa solução, além do WP MAIL SMTP.

    assim pode ser que algum desenvolvedor possa lhe dar uma ajuda ou talvez indicar qual suporte pode melhor lhe ajudar para resolver esse problema.

    abraços e boa sorte!

    Ola Ralden

    Primeiramente muito obrigado pela ajuda, então após ter postado a duvida aqui no forun, eu acabei descobrindo que o problema não esta no WordPress e sim no plugin BuddyPress, ocorre que quando eu desabilito o Buddypress o sistema de cadastro de usuarios funciona perfeitamente da maneira como eu preciso, entretanto, tambem preciso do buddypress então não tenho como deixa desabilitado, mais da forma como esta eu terei que ativar manualmente usuario por usuario o que nao é viavel, preciso de ajuda para solucionar o problema do buddypress, ou ficaria perfeito se houver uma forma de deixarr o buddypress habilitado porem com o sistema de cadastro sendo gerenciado pelo wordpress e nao pelo buddypress.. alguma sugestão ?

    boa tarde @edupoli,

    siga as instruções informadas no tópico de suporte abaixo,

    https://wordpress.org/support/topic/activation-emails-from-forums-not-sent/

    é praticamente o mesmo problema que o seu. e se a solução funcionou para eles, deve funcionar para você. basicamente você deve colocar o código informado no arquivo functions.php que se encontra na pasta do seu tema.

    abraços e boa sorte!

    Ralden

    Eu já havia tentando essa dica, infelizmente não funcionou 🙁

    Pelo que pesquisei parece haver um Bug no Buddypress, já foi aberto um ticked para a equipe de desenvolvimento conforme link abaixo:

    https://buddypress.trac.wordpress.org/ticket/7869

    Não entendo muito bem o inglês mais parece que estão corrigindo de uma olhada por favor
    inclusive tem um patch para correção mais eu não entendi se é para substituir o codigo destacado em vermelho pelo codigo destacado em verde ou se é para adicionar.

    Abraço

    boa tarde @edupoli,

    o patch é para substituir o que está em vermelho para ficar como está na área verde. você pode perceber isso pela linha 3390, que inicia a parte vermelha e também a verde. ou seja, onde era vermelho, deve ficar apenas o que está em verde. por isso a numeração das linhas tem duas colunas, pois a coluna da esquerda como a numeração atual das linhas e a da direta a numeração que irá ficar após você substituir o código em vermelho pelo verde.

    o que faz todo o sentido, pois acredito que você tenha um site simples, e o código do BuddyPress é para multi-site, o que não faz sentido para o seu wordpress.

    abraços e boa sorte!

    Fiz a correção conforme indicado no patch, porem, ainda assim continua o problema, acredito que se esta solução fosse definitiva, haveria uma atualização do plugin buddypress, se for possivel voce instalar o plugin e testar se cadastrando um novo usuario é enviado o email de aivação, para sabermos se realmente é um problema do plugin para todos os usuarios, ou se por ventura possa ser alguma coisa nas minhas configurações que possam estar conflitando.

    Abraços

Visualizando 6 respostas - 1 até 6 (de um total de 6)
  • O tópico ‘Não envia email de ativação’ está fechado para novas respostas.