Suporte » Gerenciamento de conteúdo » Não consigo publicar nada no meu site!

  • Olá Boa tarde!

    não achei solução em lugar nenhum, resolvi vir aqui para ver se alguém pode me ajudar.

    Eu não consigo publicar nada no meu site do wordpress. Sempre que vou criar uma página, está escrito ” publicar” e embaixo está escrito “imediatamente” mas depois que eu publico, a página fica automaticamente como “agendado” e não publica nada.

    Eu instalei o wordpress no meu servidor da digital ocean ontem. o site está ativo, mas nada é publicado, falei com algumas pessoas e ninguém conseguiu me ajudar a finalmente resolver isso. se alguém souber como, por favor respondam !

    Desde já, agradeço pela atenção de todos!

Visualizando 3 respostas - 1 até 3 (de um total de 3)
  • saudações @thowlete,

    difícil alguém conseguir dar uma resposta exata para o caso apenas com essas informações. porque é preciso entender o contexto onde a questão está ocorrendo:

    na DigitalOcean, você criou o Doplet e então criou o WordPress? não alterou alguma configuração de servidor, como PHP, segurança, instalou NGINX? o WordPress é uma instalação nova ou você está migrando de outro servidor?

    no WordPress, você não instalou algum plugin que pode mexer nas configurações? como o Jetpack? que versão do WordPress está usando?

    por padrão, o WordPress publica imediatamente ou você pode programar a publicação. mas da forma que relata, há alguma alteração que está fazendo essa programação. e ai há um mundo de possibilidades.

    se já está usando a nova versão WP 5.2, sugiro ir em Ferramentas > Diagnóstico e ver se essa ferramenta não aponta algo “estranho” que você deveria dar atenção.

    informações detalhadas que possa fornecer sobre configurações personalizadas de seu servidor, plugins do WordPress, enfim, coisas que podem modificar o WordPress, ajudam a que os voluntários do Fórum possam tentar lhe ajudar.

    Gassho (mãos em prece), Namaste (eu lhe saúdo)

    Obrigado por responder @ralden !

    desculpa a falta de detalhes, vamos lá…

    na digital ocean, criei o droplet e instalei o wp pelo ” termius ” escolhi o sistema centOS do droplets. é uma instalação nova do wp, não instalei o NGINX, e não instalei plugin nenhum dessa vez.

    fiz o diagnóstico no wp agora e apareceu isso.

    4 melhorias recomendadas
    Você deve remover plugins desativados Segurança
    Você deve remover temas desativados Segurança
    Sua versão do PHP deve ser atualizada Desempenho
    Um ou mais módulos recomendados estão faltando

    essa parte me chamou atenção >>> Um ou mais módulos recomendados estão faltando
    Os módulos PHP executam a maioria das tarefas no servidor que fazem seu site funcionar. Qualquer alteração deve ser feita pelo administrador do servidor.

    A equipe de hospedagens do WordPress mantém uma lista destes módulos, tanto recomendados quanto obrigatórios, no manual da equipe (abrir em uma nova aba).

    Atenção O módulo opcional bcmath, não está instalado ou foi desativado.
    Atenção O módulo opcional imagick, não está instalado ou foi desativado.

    o que pode ser isso ? lembrando que eu sou um leigo de verdade sobre sites, só tive 1 no wp e faz algum tempo.

    outros detalhes que eu lembrei agora, eu instalei tudo pelo ” TERMIUS” como eu já disse, mas ativei o SSL pelo VPSSIM que instalei pelo termius mesmo. eu não domino o uso do termius, eu fiz dessa forma porque um amigo me auxiliou a fazer por lá. eu estou a 3 dias tentando resolver isso e não consigo de forma nenhuma, só queria meu site funcionando corretamente. com SSL, e publicando tudo sem dar esses problemas. se faltou alguma informação me diga por favor, e muito obrigado pelo seu tempo e pela intenção de ajudar.

    MUITO OBRIGADO !!!

    saudações @thowlete,

    há quase 1 ano venho me especializando em infraestrutura porque sei como isso é incômodo para quem só quer ter o seu WordPress e trabalhar nele sem interferências do servidor.

    bem, sobre os módulos, que lhe chamou a atenção, tranquilo, pois os 2 são opcionais. claro que se você puder instalar esses módulos, há ai um ganho, mas são opcionais.

    como eu uso o Runcloud (runcloud.io) para gerenciar meus servidores no Google Cloud, fica bem facinho com eles, pois basta entrar no servidor pelo próprio Console do Google Cloud e digitar os comandos que o próprio Runcloud dá… 🙂

    aliás, se você é programador, beleza usar o Termius. mas se não é, bem, é tipo quem tá aprendendo a surfar e vai pra praia de ondas grandes… eu, por exemplo, sou designer, mas me especializei em servidor para WP. então o Runcloud cuida da parte de sysadmin e eu personalizo o servidor com o sistema deles e quando preciso usar código pelo terminal eles me dão a referência.

    eu acho que você complicou um processo simples e aconteceu algum erro no Termius que ficou esse bug. eu sugeriria você simplificar da seguinte forma:

    1. sobre o SSL: como o DigitalOcean não facilita ter certificado gratuito do Let’s Encrypt, sugiro você usar o Cloudflare. é gratuito e quando add seu site e atualizar os DNS do seu domínio para os do Cloudflare, basta ir na seção “Crypto” e escolher a opção “Flexible”. essa opção é justamente para servidores sem SSL, ai o Cloudflare vai fazer seu site ter SSL, o que é ótimo pra você não ter que fazer toda a configuração de servidor para o Let’s Encrypt. deixa isso pra lá e usa o Flexible do Cloudflare, eu já fiz isso para 2 clientes com loja virtual usando Moip e PagSeguro e o SSL/TLS foi aceito sem problemas. (não pode usar a opção Full, pois ai dá erro, pois essa opção é apenas para servidores com SSL, tipo o Runcloud pago dá Let’s Encrypt com 1-clique, ai no Cloudflare eu preciso usar a opção Full.)

    eu sugiro que não mesma seção “Crypto” ative duas opções ótimas: a) Always HTTPS; b) Rewrite HTTP to HTTPS. com isso, mesmo quem digitar seu site com http será obrigado a acessar com https.

    2. depois que os DNS do Cloudflare propagarem, ai você pode ir no SFTP de seu servidor do DigitalOcean e jogar os arquivos de instalação do WordPress. como não sei se o DigitalOcean facilita descompactar dentro do servidor, se for o caso já mande descompactado. ai faça a famosa instalação de 5 minutos (que faço em 1 minuto 🙂

    pronto, WordPress rodando em SSL/TLS e com instalação limpa. beira ao impossível que com essa instalação você tenha algum problema. ai é ir lá em Ferramentas > Diagnóstico e ver que sugestões ele dá e que você possa fazer. por exemplo, esse módulo opcional imagick é ótimo para acelerar carregamento de imagens.

    o Runcloud tem um plano free para 1 servidor, 1 único usuário (runcloud) e sem o SSL com 1-clique. mas ainda assim é repleto de recursos. pode colocar a instalação do WordPress com 1 script de 1-clique. e pode gerenciar o PHP de uma forma absurdamente fácil, mais fácil que o cPanel. então quem sabe você não cria um novo droplet e testa com o Runcloud. ajuda muito.

    espero ter ajudado. muito boa sorte!

    Gassho (mãos em prece), Namaste (eu lhe saúdo)

Visualizando 3 respostas - 1 até 3 (de um total de 3)
  • Você deve estar logado para responder a este tópico.