Suporte » Instalando o WordPress » Não consigo mais acessar o wp admin

  • Olá,

    recentemente decidi criar um site de vendas, comprei o dominio e o pacote de hospedagem +ssl da Locaweb. Instalei o wordpress, cheguei ate fazer algumas configurações, estava tudo uma belza.

    Entretanto, nao verifiquei no site o cadeado de seguranca, entrei em contato com locaweb, e eles me passaram um link ensinando a forçar o https: incluir um codigo no arquivo htaccess…Bom, não entendo nada de programação, sou totalmente leigo nisso e no tutorial (nao foi feito para leigos) nem mostra como acessar esse tal arquivo, fui saber fuçando pela internet.

    Segue o codigo fornecido por eles:

    RewriteEngine On
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://www.seudominio/$1 [R,L]

    Pois bem fui la no filezilla e incluir esse bendito codigo, e quando atualizei site já aparecia o cadeado no meu site..POREM agora vai começar minha dor de cabeça!!!

    Ao tentar acessar o meu wp-admin, nao está mais disponivel e meu site (que tinha um template, daqueles bem simples) aparecia agora uma pagina so com textos!

    Retornei na central de novo e os informei desse novo problema e eles me informaram que era preciso agora inserir um novo codigo no meu htaccess para redirecionar 301 e que logo depois teria que mudar o endereço no banco de dados, ou seja, NAO ENTENDI NADA.

    Segue os codigos que eles indicaram para incluir no

    Forçar uso do HTTPS

    RewriteEngine On
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://www.dominio.com.br/$1 [R,L]

    Até aqui ainda consegui “entender” e incluir no htaccess..Mas nos codigos abaixo, ficou complicado, faltou bagagem intelectual(programação, mesmo a mais simples):

    Mudar domínio

    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^dominioantigo.com.br$
    RewriteRule (.*) http://www.novodominio.com.br/$1 [R=301,L]

    Mudar ponto de publicação

    redirect 301 /antigo/arquivo_antigo.htm
    http://www.seudominio.com.br/aquivo_novo.htm

    O fato é que após a tentativa(não sei se fiz certo) de colocar esses codigos no meu arquivo htaccess, ele ficou assim:

    ##### LOCAWEB – NAO REMOVER #####
    AddHandler php71-script .php
    suPHP_ConfigPath /home/perfectafitness1/
    ##### LOCAWEB – NAO REMOVER #####

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^perfectafitness.com.br$
    RewriteRule (.*) http://www.perfectafitness.com.br/$1 [R=301,L]
    RewriteEngine On
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://www.perfectafitness.com.br/$1 [R,L]
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPressde

    Obs: eu também incluir um codigo no wp-config.php (ja estava de cabeça quente de tanto pesquisar na net solucoes para o problema):

    linha inclusa:
    define(‘FORCE_SSL_ADMIN’ , true);

    * @link https://codex.wordpress.org/Debugging_in_WordPress
    */
    define(‘WP_DEBUG’, true);
    define(‘FORCE_SSL_ADMIN’ , true);
    /* That’s all, stop editing! Happy blogging. */

    E pra minha tristeza (estava adivinhando que ia dar zebra), agora eu NAO consigo visualizar o meu site (estava com um layout feinho, mas parecia um site), nao consigo acessar wp-admin e o cadeado de segurança (inicio de todo o problema) tambem NAO aparece!

    Bom galera é isso, fiz um chamado pro site Locaweb e estou aguardando a resposta deles também, mas acho que eles nao vao conseguir resolver e provavelmente pedirao pra que eu entre em contato com um desenvolvedor de minha confiança!

    PS. Se nao tiver solucao mesmo, existe a possibilidade sei la de “resetar” isso e fazer tudo de novo – o site nao tinha nada mesmo, estava em construção…

    Obrigado!

    A página que eu preciso de ajuda: [fazer login para ver o link]

Visualizando 1 resposta (de um total de 1)
  • saudações pablobahia,

    acessei seu link e também adicionei o /wp-admin/ ao link e ambas as páginas estão funcionando perfeitamente.

    por favor, nos informe se já resolveu o problema. gratidão.

    • Esta resposta foi modificada 3 semanas, 1 dia atrás por  Ralden Souza.
Visualizando 1 resposta (de um total de 1)
  • Você deve estar conectado para responder a este tópico.