Suporte » Instalando o WordPress » Não consigo logar no wordpress

  • Resolvido raphaele

    (@raphaele)


    Olá a todos!
    Instalei o wordpress no servidor IIS… a instalação deu ok, mas no momento de logar no admin coloco o usuário e a senha e ele redireciona pra página de login novamente… acredito que seja alguma incompatibilidade de alguma função php como $_SERVER[‘REQUEST_URI’] com o IIS… alguém tem alguma solução? Infelizmente não tenho como mudar o servidor para apache!

    Obrigada

Visualizando 7 respostas - 1 até 7 (de um total de 7)
  • Oi Raphaele,

    Você consegue ler inglês? Se sim, esse rapaz resolveu um problema que, pelas características informadas por ele, era exatamente igual o seu. A solução está aqui.

    Caso tenha alguma dificuldade, ou não consiga resolver o problema, avise-nos.

    []’s!

    Criador do tópico raphaele

    (@raphaele)

    Olá rghedin,

    Fiz as alterações e sugestões do tópico que vc sugeriu mas o problema continua… ao contrário do tópico que vc sugeriu, quando tento logar no admin ele simplismente redireciona para a mesma página de login sem dá erro algum… eh como se existisse um problema de redirecionamento ou de criação da sessão… vc tem outra sugestão?

    Obrigada

    ps.: Estou usando o wordpress MU versão 2.6.3

    Hm, WordPress MU não é exatamente minha praia…

    Dê uma lida neste tópico. É antigo (da época do WPMU 1.2.3), mas como o problema é similar, talvez haja alguma solução.

    A propósito, em qual domínio você instalou o WPMU?

    []’s!

    Raphaele,

    Desencorajo plenamente você a utilizar o WordPress-mu no IIS, pois este não tem suporte a rewrite de URLs como o Apache tem. Uma outra solução, pode ser você instalar o Apache no teu servidor Windows e incluir o mod_rewrite nele. Do contrário, você pode até conseguir funcionar fazendo chunchos no core do WordPress (uma vez eu até consegui), mas o sistema fica tão instável, que você vai ver que tudo foi tempo perdido.

    Abraços,

    Criador do tópico raphaele

    (@raphaele)

    Consegui resolver o problema do login, adicionei as seguintes linhas no arquivo wp-config.php:

    define(‘ADMIN_COOKIE_PATH’, ‘/’);
    define(‘COOKIE_DOMAIN’, ”);
    define(‘COOKIEPATH’, ”);
    define(‘SITECOOKIEPATH’, ”);

    Mas realmente não eh possível criar novos blogs por conta desse suporte a rewrite. Conseguimos um servidor para instalar o apache e vamos instala-lo nesse servidor. Instalamos o wp-mu na intranet do domínio sfiec.org.br.
    Muito obrigada pela ajuda!

    ramonmisse

    (@ramonmisse)

    Consegui resolver o problema do login, adicionei as seguintes linhas no arquivo wp-config.php:

    define(‘ADMIN_COOKIE_PATH’, ‘/’);
    define(‘COOKIE_DOMAIN’, ”);
    define(‘COOKIEPATH’, ”);
    define(‘SITECOOKIEPATH’, ”);

    Mas realmente não eh possível criar novos blogs por conta desse suporte a rewrite. Conseguimos um servidor para instalar o apache e vamos instala-lo nesse servidor. Instalamos o wp-mu na intranet do domínio sfiec.org.br.
    Muito obrigada pela ajuda!

    No meu eu adicionei essa linha

    define(‘ADMIN_COOKIE_PATH’, ‘/’);

    com a pasta do meu wordpress na frente da barra’/’ funcionou.

    Eu alem de não conseguir logar, quando tento redefinir a senha do admin me aparece a mensagem:
    The e-mail could not be sent.
    Possible reason: your host may have disabled the mail() function…

    E a função mail do PHP está funcionando perfeitamente.

Visualizando 7 respostas - 1 até 7 (de um total de 7)
  • O tópico ‘Não consigo logar no wordpress’ está fechado para novas respostas.