Suporte » Multisites » Multisites configurando os domínios no Apache

  • Olá pessoal, essa é minha primeira postagem no Fórum, pelo o que li estou no caminho certo, mas caso esteja postando na área errada favor me avisar.

    Bem, eu estou com o seguinte problema, fiz 10 sites para 1 cliente e agora ele precisa que eu configure em um VPS dele os domínios, com base em algumas buscas que fiz na internet a primeira coisa que eu precisava fazer era criar um novo arquivo de configuração dentro do /etc/apache2/sites-available e habilitar ele com o a2ensite, perfeito fiz isso e ficou da seguinte forma:

    <VirtualHost *:80>
        ServerAdmin (meu email)
        ServerName (domínio configurado)
        ServerAlias (domínio configurado)
        DocumentRoot /var/www/html/10_sites/
        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
    	<Directory /var/www/html/10_sites>
    		AllowOverride All
    		Require all granted
    	</Directory>
    </VirtualHost>

    Depois disso eu tinha que ir nos sites do Multisites e alterar o Endereço do site, fui lá e alterei para o endereço correto.
    Beleza, após habilitar as 2 configurações ficou show de bola funcionou como eu queria hoje ele abre o site no domínio, então teoricamente estaria tudo certo.
    Mas ai me deparei com um problema, quando abro o site e vou por exemplo acessar uma outra tela além do index (home) ele dispara a seguinte mensagem de erro:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    
    Please contact the server administrator at (meu email) to inform them of the time this error occurred, and the actions you performed just before this error.
    
    More information about this error may be available in the server error log.
    
    Apache/2.4.25 (Debian) Server at (domínio do site) Port 80

    Pessoal eu já alterei pelo banco de dados o link para as telas, mas o problema é o seguinte o site em questão esta dentro da seguinte pasta /var/www/html/10_sites no /var/www/html/ tem uma outra instalação de um outro WordPress para um outro site, então eu estou trabalhando no /var/www/html/10_sites já fiz diversos ajustes e diversos testes até então nada deu certo, alguém tem alguma ideia?

    • Este tópico foi modificado 6 meses, 3 semanas atrás por nasseroth.
    • Este tópico foi modificado 6 meses, 3 semanas atrás por nasseroth.

    A página que eu preciso de ajuda: [fazer login para ver o link]

  • O tópico ‘Multisites configurando os domínios no Apache’ está fechado para novas respostas.