Suporte » Gerenciamento de conteúdo » miniatura não aparece ao compartilhar no whatsapp

  • tiagotrento

    (@tiagotrento)


    “Eu levantei um tópico antigo, agora a pouco, mas lá li que o moderador indicava abrir um POST novo caso não fosse resolvido com a solução proposta… se eu entendi errado (podem fechar)”

    No código-fonte do site de vocês, dentro da tag <head> existe uma tag como <meta property=”og:image” content=”http://dominio.com/endereco-imagem.jpg” />
    Esta imagem está no formato JPG ou PNG
    Esta imagem tem menos de 300kb de tamanho
    Esta imagem tem dimensões superiores ou iguais a 300x200px
    ___________________________________________________

    Vamos lá!
    link: taisatrento.com/altopadrao/tt373/

    <meta property=og:image content=”https://taisatrento.com/wp-content/uploads/2018/07/TT373-1-150×150-1.jpg”/>

    Atende a todos os requisitos mas não estou conseguindo obter a miniatura
    Plugin desinstalado: yoast seo
    Plugin instalado: Smartcrawl

    • Este tópico foi modificado 1 ano atrás por  tiagotrento.

    A página que eu preciso de ajuda: [fazer login para ver o link]

Visualizando 11 respostas - 1 até 11 (de um total de 11)
  • tiagotrento

    (@tiagotrento)

    atualizando o POST!
    não consegui re-editar o de cima
    _____________
    YOAST ativado, apenas ele ativo de SEO
    ________________________________________
    Acheium link de depurador de compartilhamento do facebook, isso ajudou a achar sanar alguns dos erros! 🙂

    https://developers.facebook.com/tools/debug/sharing/?q=https%3A%2F%2Ftaisatrento.com%2Faltopadrao%2Ftt358%2F

    embora…. No facebook compartilhe perfeitamente, para o whatsapp ainda não funciona
    <meta property=og:image:secure_url content=”https://taisatrento.com/wp-content/uploads/2018/06/TT358-1.jpg”/>
    <meta property=og:image:width content=1280 />
    <meta property=og:image:height content=960 />

    • Esta resposta foi modificada 1 ano atrás por  tiagotrento.
    • Esta resposta foi modificada 1 ano atrás por  tiagotrento.
    tiagotrento

    (@tiagotrento)

    Um teste com imagem ainda menor:
    https://taisatrento.com/altopadrao/tt372/

    https://developers.facebook.com/tools/debug/sharing/?q=https%3A%2F%2Ftaisatrento.com%2Faltopadrao%2Ftt372%2F

    <meta property=og:image content=”https://taisatrento.com/wp-content/uploads/2018/07/TT372-1-300×225-1.jpg”/>
    <meta property=og:image:secure_url content=”https://taisatrento.com/wp-content/uploads/2018/07/TT372-1-300×225-1.jpg”/>
    <meta property=og:image:width content=300 />
    <meta property=og:image:height content=225 />

    no Facebook funciona perfeitamente, no whatsapp, puxa o titulo mas não a imagem

    tiagotrento

    (@tiagotrento)

    … olha só: (funciona tanto no facebook como no zap)
    https://Youtube.com/

    <meta name=”description” content=”Enjoy the videos and music you love, upload original content, and share it all with friends, family, and the world on YouTube.” />
    <meta name=”keywords” content=”video, sharing, camera phone, video phone, free, upload” />
    <meta name=”theme-color” content=”#ff0000″ />
    <meta property=”og:image” content=”/yts/img/yt_1200-vfl4C3T0K.png” />
    <meta property=”fb:app_id” content=”87741124305″ />

    imagem deles tem: 1200x1200px e apenas 20kb =P

    • Esta resposta foi modificada 1 ano atrás por  tiagotrento.
    tiagotrento

    (@tiagotrento)

    Apenas atualizando… desabilitei o yoast seo, estou usando o plugin “Complete Open Graph”. É um plugin voltado para o facebook… Comentei com o desenvolvedor desse plugin sobre o problema com o whatsapp, ele falou que futuramente irá implementar algo sobre o problema… (vou aguardar se não conseguir nenhuma outra solução, espero que ele realmente o faça, kkkk, ele se mostrou entusiasmado)

    Com esse plugin, no facebook tudo está funcionando OK.
    Mas ao compartilhar no whatsapp infelizmente não abre a imagem, ja segui várias recomendações que encontrei no google e aqui no fórum
    Como Height: 200 e Width: 300, e tamanho do arquivo pequeno…

    fcpresentesevariedades

    (@fcpresentesevariedades)

    Boa tarde, vc resolveu? estou com o mesmo problema

    Bom dia, @hugonapoleao,

    Quanto à imagem que deve ser compartilhada:

    Há duas imagens “principais” nesta URL, uma do Moro, outra com a frase “Ataques no Ceará”. Além delas somente icones de redes sociais e o seu logo e favicon. Pra um bot, é tudo imagem.

    Qual delas o Facebook/WhatsApp deveria incluir? De que maneira o Facebook/WhatsApp deve fazer essa escolha?

    A maneira correta é indicar uma imagem (uma das duas) como a imagem a ser compartilhada, usando as tags open graph, especificamente a tag og:image.

    Dá uma olhada no depurador de compartilhamento do Facebook, e note como há um alerta de que, mesmo que haja imagens no post, é preciso que seja especificamente definida uma via og:image.

    Veja se seu tema não está gerando essa tag og:image, se algum otimizador não está retirando. Se for o caso, use um plugin de SEO, como Yoast SEO, para incluir em cada post a imagem destacada como og:image.

    Detalhe: como tanto o Face quanto o Whats buscam a mesma imagen que está na tag og:image, não pode ser uma imagem muito pequena, deve ser grande o suficiente para ficar bem no Face.

    Quanto ao problema da miniatura no WhatsApp:

    Depois de corrigido este problema, ainda assim o WhatsApp pode ou não mostrar a miniatura, mas isso tem pouco a ver com o seu site. Depende muito do instante em que vc coloca o URL no app WhatsApp, da velocidade da rede naquele instante. O WhatsApp é muito rápido para buscar a imagem, e se não conseguir fazê-lo em poucos milisegundos, não vai insistir. Vai criar o snippet sem a foto, e provavelmente fazer um cache desse snippet.

    A sugestão nesse caso é reduzir ao máximo (em kilobytes, não tem tamanho) a imagem que vai no og:image, usando plugins ou ferramentas de compressão e otimização de imagens. Mas mesmo com a imagem otimizada ao máximo, é sempre possível devido a uma lentidão da rede que o WhatsApp não consiga gerar a miniatura no pequeno espaço de tempo de que dispõe. Entretanto, o fato de não aparecer no seu celular, não significa que não vai aparecer no celular de quem recebe. E vice-versa, pode aparecer a miniatura no seu celular, mas não no Whats de quem recebe.

    Instalei esse Plugin
    https://br.wordpress.org/plugins/facebook-thumb-fixer/

    Resolveu tanto pra Facebook como pra Whatsapp.

    Usei imagem em JPG, qualidade em 60%, tamanho 1200px x 630px

    O Problema atualmente se mostra corrigido para mim! funcionando perfeitamente, porem demora!

    Fala pessoal, estava tendo este problema após ter ativado o plugin Yoast SEO também, mas descobri como resolver por ele mesmo.
    Basta ir la no SEO > Redes Sociais > Facebook e “Enviar imagem”, então envie uma imagem JPG com menos de 100KB numa proporção entre 300px e 400px. A minha imagem tem 390px por 370px e 35KB. Resolveu para mim.

    Amigos, atenção!

    Quebrei muito a cabeça até encontrar a solução para este problema de não aparecer a thumbnail na URL compartilhada no Whatsapp.

    As dimensões e tamanho da imagem são importantes, sim, desativar o YOAST SEO não funcionou, mas desativar os otimizadores (compressores de css e js funcionou pra mim), mais especificamente o Autoptimize.

    Tentem desativar Autoptimize, Minify HTML e outros, apenas para gerar a imagem, depois ativa-os novamente.

    Friends, attention!

    I broke my head a lot until I found the solution to this problem of not showing the thumbnail in the shared URL in Whatsapp.

    Image size and size are important, yes, disabling YOAST SEO didn’t work, but disabling optimizers (css and js compressors worked for me), more specifically Autoptimize.

    Try disabling Autoptimize, Minify HTML, and others just to generate the image, then turn them back on.

    Amigos, atención!

    Me rompí mucho la cabeza hasta que encontré la solución a este problema de no mostrar la miniatura en la URL compartida en Whatsapp.

    El tamaño y el tamaño de la imagen son importantes, sí, deshabilitar YOAST SEO no funcionó, pero deshabilitar los optimizadores (los compresores css y js funcionaron para mí), más específicamente la optimización automática.

    Intente deshabilitar Autoptimize, Minify HTML y otros solo para generar la imagen, luego vuelva a encenderlos.

Visualizando 11 respostas - 1 até 11 (de um total de 11)
  • Você deve estar conectado para responder a este tópico.