Suporte » Ajustando o WordPress » Minha configuração de meta tags não aparece nos resultados de busca

  • Resolvido matheusocs

    (@matheusocs)


    Boa tarde.

    Estou nas etapas finais de configuração de meu blog e brevemente iniciar as postagens de conteúdo.
    Entre uns ajustes e outros, por fim verifiquei que nas buscas (google) as meta tags, description e outras não aparecem no visualização do resultado. Ao invés disso, o resultado me aponta a descrição utilizando trechos do site “Welcome to WordPress. This is your first post. Edit or delete it, then start writing! Uncategorized. Pesquisa. Posts recentes. Hello world! Copyright 2018.”

    Já li a documentação do Codex, já pesquisei diversos vídeos, já li vários artigos e não consigo alterar da forma que desejo.

    Estou utilizando a versão 4.9.8 do wordpress, o tema é o ZeroGravity e utilizo os seguinte plugins:
    Akismet Anti-Spam
    Better Search Replace
    Cloudflare
    CloudFlare Flexible SSL
    Contact Form 7
    Editor clássico
    GA Google Analytics
    Jetpack por WordPress.com
    Login No Captcha reCAPTCHA
    Loginizer
    Pretty Links
    Tradução (Loco)
    UpdraftPlus – Backup/Restore
    WordPress HTTPS
    Yoast SEO
    YouTube

    Desde já agradeço.

    • Este tópico foi modificado 4 anos, 4 meses atrás por matheusocs. Motivo: Edição para adição de agradecimento ao final da postagem

    A página que eu preciso de ajuda: [fazer login para ver o link]

Visualizando 9 respostas - 1 até 9 (de um total de 9)
  • olá @matheusocs,

    você deve ter instalado seu WordPress e cuidado de várias coisas, mas deixou aquele post de exemplo que vem com o WordPress. então o Google indexou seu site com esse post.

    agora você colocou um post inicial no seu site, conforme vi no link. então dê 1 a 2 dias para o Google indexar e modificar.

    é importante usar o Google Search Console para melhorar a indexação do Google. e como está usando o Yoast SEO, aproveite para gerar o sitemap e inserir no Google Search Console.

    mas basicamente é isso, não se preocupe. em no máximo 48 horas já estará atualizado pelo Google.

    abraços e boa sorte,

    Criador do tópico matheusocs

    (@matheusocs)

    Oi @ralden,
    desde já agradeço pelo retorno.

    Na verdade esse post padrão foi um dos primeiros a serem excluídos, mas entendo que de início o Google tenha indexado-o. A questão é que em outro site que eu fazia o mesmo tipo de alterações que estou tentando fazer no meu, com algumas horas o resultado era visto na pesquisa, o que não aconteceu no meu caso. A configuração das meta tags do site teoricamente deveriam não depender de postagens já feitas ou não…

    Quanto ao Google Search Console, já fiz o cadastro e inseri o sitemap lá também.

    No mais eu já testei algumas outras configurações e estou aguardando pra ver se vai gerar o resultado esperado.

    Novamente muito obrigado pelo retorno.
    Um abraço.

    olá @matheusocs,

    você já usou o Assistente de Configuração do Yoast SEO? Ele é composto de uma série de 9 ou 10 páginas de configurações que colocam a melhor configuração de SEO para seu site.

    Você pode acessar no menu do WordPress SEO > Geral e então vai aparecer um desenho de uma menina acenando e o texto “Configurações de SEO pela primeira vez: Comece rapidamente com o Yoast SEO assistente de configuração!”

    Clique em “assistente de configuração” e preencha tudo. Isso ajudará bastante na indexação do Google.

    abraços e boa sorte,

    Criador do tópico matheusocs

    (@matheusocs)

    Oi @ralden,
    boa noite.

    Foi o primeiro passo ao instalar o plugin. Configurei todas as etapas e já reconferi se poderia ser algum erro, mas não encontrei.

    Acredito que algum plugin, ou o tema não sei…algo está “bloqueando” a configuração. Já tentei colocar códigos em functions.php e no header. Nada…

    Na esperança de alguém traga a luz rs

    Obrigado novamente.

    olá @matheusocs,

    olha, pesquisando no Google seu domínio “cadastrovipracco.com.br”, todas as páginas estão indexadas pelo Google e com conteúdo coerente. apenas a homepage está com esse problema.

    o provável problema é que o Google indexou quando estava com o post de instalação e agora não consegue visualizar nenhum conteúdo que gere a mudança.

    então a solução é fazer o SEO para a homepage “no braço”. como seria?

    acesse o Codex do WordPress sobre Meta Tags,

    https://codex.wordpress.org/Meta_Tags_in_WordPress

    logo na primeira seção “What Are Meta Tags?”, você vai ver as principais meta tags que deve inserir (ou editar! pois já pode haver) no arquivo header.php.

    então você vai em Aparência > Editor e procura no seu tema o arquivo “Cabeçalho do tema” (header.php)” e ai você insere ou edita as meta tags.

    o ideal é que você use um tema-filho, para que não venha a perder essas informações no arquivo header.php em caso de atualização do tema. pois no caso desse arquivo fazer parte de uma atualização do tema, irá sobrescrever seu arquivo editado e você perde essas atualizações.

    com isso, você com certeza resolve o SEO da homepage.

    maaaaaaaaas… esse header.php entra na composição de todas as páginas do WordPress. então pode interferir no SEO das outras páginas.

    para TALVEZ não dar problema, você vai precisar usar o Yoast SEO em todas as páginas e posts que criar, naquela caixa que fica abaixo de onde insere o conteúdo. se bem me lembro, o Yoast SEO sobrescreve as meta tags quando gera as páginas e posts. então, em teoria, o Yoast SEO vai substituir as meta tags que estão no header.php pelas que você inserir em cada página e post.

    se fosse eu, como designer, procurava outro tema. ainda mais que uso o Elementor Pro e essa questão de tema não faz mais a mínima diferença para mim. mas como pode ser um tema que já tem o layout que você deseja e que você já saiba personalizar, então para manter esse tema você vai precisar nesse momento se arriscar nessa solução.

    abraços e boa sorte,

    Criador do tópico matheusocs

    (@matheusocs)

    @ralden,

    Eu fiz essas alterações no “braço”. Li a wiki do wordpress pra entender como funcionava e como disse tentei colocar tanto em functions, quanto em header. E nada funcionou até o momento.

    Mas a questão do tema filho realmente pode ser a solução, visto que eu não criei um quando habilitei o tema que utilizo. Vou tentar também configurar as outras páginas pelo Yoast SEO e ver o que acontece.

    Eu fiz um breve teste no Elementor versão free, não estou muito por dentro das funcionalidades. Com a experiência que você já possui, o que poderia me dizer de benefícios sobre esse plugin? E poderia me explicar porque não faz diferença nessa questão? Não terei problemas em trocar o tema, mas foi um que acabei gostando pela simplicidade e facilidade de configurar.

    Testarei as configurações e retorno com os resultados.

    Obrigado!

    olá @matheusocs,

    o Elementor permite gerenciar o layout de uma página muita facilidade. a versão Free já permite fazer páginas muito boas, mas com soluções mais simples ou quem ainda exigem mexer no código do tema.

    já o Elementor Pro possibilita fazer páginas com efeitos avançados. praticamente dá pra copiar qualquer página na web, muitas vezes precisar mexer em código, apenas configurando.

    outra grande vantagem do Elementor é que você consegue configurar tanto a versão desktop como mobile (responsiva) no Editor do Elementor. isso ajuda a ter certeza tanto da versão que será vista em monitores e notebooks como nas versões para celulares. podendo gerenciar diferenças nas duas versões.

    o problema com seu SEO é que você está usando em Configurações > Leitura > Sua página inicial exibe, você está usando a opção “Seus posts recentes”. e por algum motivo que não entendo e só posso “culpar” o tema, o Google não está conseguindo ler essa página e atualizar a indexação.

    se sua homepage fosse uma página criada, esse problema dificilmente ocorreria. pois na página do tema diz que ele é “SEO friendly”.

    com o Elementor Pro esse problema não existe porque não se usa essa opção em leitura de “posts recentes”. você cria uma página e no Editor do Elementor (na versão Pro) tem uma opção de gerenciar como exibir os últimos posts. e isso com opções de layout fantásticas, que tornam a página muito bela, dependendo do trabalho do designer.

    e como você criou uma página nova para exibir os últimos posts, o SEO funciona e o Google indexa o que você colocou na página.

    um tema que há algum tempo adotei e adoro porque é muito rápido de carregamento e com muitas opções de personalização em Aparência > Personalizar é o WP Astra.

    https://br.wordpress.org/themes/astra/

    indico pelas qualidades. e nunca tive problema com SEO com ele.

    abraços e boa sorte,

    Suas meta tags estão corretas. O que está acontecendo é que o Google ainda está usando uma versão em cache de algumas páginas. Fazendo uma busca site:exemplo.com.br vc verá que tem algumas páginas em cache. Além da home, há também a conhecida Hello World e algumas páginas de arquivo.

    Use a ferramenta Remover URLs na versão antiga do Google Search Console. Ali aparece um botão Ocultar Temporariamente. Em algum momento deve aparecer uma pergunta se vc quer remover do índice ou remover o cache. Se não aparecer a pergunta, escolha remover do índice mesmo. Após remover do cache/índice a página, solicite sua inclusão novamente na ferramenta Buscar como Google.

    Outro problema em relação a meta tags, é que o Yoast SEO cria as meta tags, mas dependendo de como o tema é configurado, o Yoast pode não remover as meta tags criadas pelo tema. Aí ficam 2 conjuntos de meta tags. Isso aconteceu no meu site. Como as meta tags do Yoast apareciam primeiro, as do tema é que eram respeitadas pelo Google. Sempre que atualizo o tema tenho que lembrar de “comentar” uma linha num php (infelizmente não consigo alterar pelo tema descendente).

    Edição: Uma coisa parecida acontece na página inicial do seu site. Dê uma olhada na linha 131 do código-fonte, onde tem og:title/descritption repetidas e com conteúdo diferente das que o Yoast SEO incluiu. Se os robôs do Facebook e Twitter forem como o do Google, são essas últimas tags que vão aparecer quando seu post for compartilhado! Vc precisa investigar quem está incluindo essas tags repetidas e removê-las.

    Mesmo com as meta tags corretas para <title> e <meta name="description"...>, as páginas podem e vão aparecer no Google com títulos e descrição alterados, em função de mudanças recentes que o Google fez no algoritmo deles. Basicamente, o título e a descrição que o site oferece nas meta tags serão usados sempre que o Google não encontrar conteúdo melhor na página que represente essas tags (na minha opinião, elas caminham para a extinção como aconteceu com as <meta name="keywords"...>).

    Boa sorte!

    • Esta resposta foi modificada 4 anos, 4 meses atrás por CB.
    Criador do tópico matheusocs

    (@matheusocs)

    @ralden

    Obrigado pelas dicas.

    @cbrandt

    Já utilizei essa ferramenta, mas não resolveu infelizmente. Já limpei cache do wordpress, do navegador. Praticamente fiz de tudo.

    Já testei com o yoast desabilitado também e não funcionou.

    Com a sua dica sobre o “og:title” eu percebi que eu estava errando nesse ponto mesmo, estava utilizando no header as tags og, mas não estava com as meta name configuradas corretamente. Ainda assim, não funcionou também.

    No geral estive pesquisando algumas coisas a respeito e resolvi deixar assim mesmo, visto que a tendência é o google não indexar mas os sites baseados nessas tags e sim em outros critérios.

    Enfim, não consegui resolver por incompatibilidade de tema ou outro motivo qualquer, mas por fim deixarei do jeito que está pois gosto do tema que estou utilizando e não pretendo mudá-lo por enquanto, tão menos refazer toda a instalação do wordpress e plugins, visto a demanda de tempo que isso teria.

    Obrigado a todos os envolvidos.

Visualizando 9 respostas - 1 até 9 (de um total de 9)
  • O tópico ‘Minha configuração de meta tags não aparece nos resultados de busca’ está fechado para novas respostas.