Suporte » Instalando o WordPress » Migração com multilinguagem

  • Resolvido augustobsb

    (@augustobsb)


    Bom dia Amigos, estou fazendo a migração de um site com três idiomas (pt, en, es). Utilizei para criação do layout o plugin Live Composer, consegui migrar os posts e páginas sem problemas.

    O problema é quando tento criar as páginas estáticas e templates em outros idiomas, o Live Composer não permite isso. Já procurei o suporte do plugin e lá eles indicam o uso do WPML, mas tenho que disponibilizar os posts antigos do cliente, que estão no formato do Qtranslate X.

    Resumindo: Alguém pode me dar uma dica de como resolver levando em consideração que tenho o conteúdo antigo do site do cliente e as limitações do Live composer?

    Versão antiga 3.9.18, atual 4.7.4.

    Antecipo meus agradecimentos!

Visualizando 4 respostas - 1 até 4 (de um total de 4)
  • Moderador Mário Valney

    (@mariovalney)

    WordPress Cleric of Fire

    Olá @augustobsb, tudo bem?

    Cada plugin de tradução funciona de uma forma particular, sendo assim, a única forma de garantir a migração, seria migrar todo o conteúdo e todos os temas/plugins. Quando fizer isso e tudo estiver OK, aí sim você parte para alterar o plugin de tradução ou qualquer outra atividade que seja necessária.

    Para migrar o WordPress basta ler esse artigo da documentação:
    https://codex.wordpress.org/pt-br:Movendo_o_WordPress

    Ou então usar algum plugin de migração.

    Abraços

    Olá @mariovalney, bom dia e muito obrigado pela resposta! Já consegui fazer a migração de todo o conteúdo, minha dificuldade agora é fazer o WPML funcionar junto como QTranslate X, o WPML será utilizado para páginas estáticas (Home, Postview, etc…) e o Qtranslate X para os posts. O conteúdo migrado está no forrmato QTranslate X, por isso tenho que permanecer com o Plugin. E para as páginas que criei com o Live Composer irei utilizar o WPML, só que não estou conseguindo fazer funcionar… Mais uma vez muito obrigado!

    Moderador Mário Valney

    (@mariovalney)

    WordPress Cleric of Fire

    Eu recomendo alterar os posts para usar apenas um plugin de tradução.

    Mas de qualquer forma, você vai precisar entrar em contato com o suporte do WPML e verificar a compatibilidade.

    Como é um plugin pago, não podemos te ajudar além disso (leia as Regras do Fórum), sem falar que o próprio desenvolvedor é a melhor pessoa para informar se é possível trabalhar desse modo.

    Valeu @mariovalney! Muito obrigado!

Visualizando 4 respostas - 1 até 4 (de um total de 4)
  • Você deve estar logado para responder a este tópico.