• Olá! Meu site está apresentando um malware. Fiz pesquisas e descobri que há uma vulnerabilidade no site, e que esse vírus explora uma vulnerabilidade conhecida como BlackHole Exploit Kit. Esse vírus infecta todos os arquivos de extensão .js, e faz com que ao acessar um dos meus sites, o navegador do usuário abra um Iframe que pode conter um vírus Cavalo de Troia, ou outro qualquer. Verifiquei os arquivos, e nele há um código malicioso informando o Iframe que deve ser aberto. Tentei manualmente apagar o código, o problema é que todos, absolutamente todos, os arquivos do tipo .js estão infectados. E como tenho muitos sites, não consigo remover manualmente. Até tentei, mas por algum motivo, mesmo depois de apagar o código malicioso, ele volta a aparecer.

    Fiz uma análise com o WordFense Scan para WordPress. Que detectou vários arquivos estranhos na minha hospedagem, e que confirmei que estavam com o código malicioso. Apaguei todos esses arquivos, mas o problema persistiu. Num desses escaneamentos que fiz usando o Wordfense deu que o vírus utilizava “eval” e “base64” para funcionar.

    O suporte da minha hospedagem está tentando resolver, mas até agora ainda não achou uma causa.

    Tenho sites em WordPress, e sites feitos em puro HTML, e todos eles foram infectados. Nos do WordPress tento reinstalar o CMS e deletar todos os plugins, e o site fica limpo. Mas depois de um tempo volta a ficar infectado novamente,

    Em anexo envio alguns dos locais onde foi detectado o malware, e um print screen do código malicioso que está sendo usado.

    Alguns dos meus sites são http://www.performancefantastica.com.br http://www.minutodosaber.com http://www.daalivro.com

  • O tópico ‘Meu site foi invado por um malware’ está fechado para novas respostas.