Suporte » Instalando o WordPress » Links permanentes com erro

  • Resolvido Sheila Mas

    (@sheila-mas)


    Boa Tarde pessoal, estou com problemas na index de um site com links permanentes, o servidor do cliente é windows.
    Alterei o web.config de acordo com o que o servidor passou, mas ainda não funciona.
    Quando acesso o domínio direto ele abre a pagina com header e footer, mas a index com erro 404.
    As outras paginas acessam normalmente e se eu digitar dominio.com.br/index.php ele funciona normalmente também.
    Código do webcongif que me passaram:

    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
      <system.webServer>
        <rewrite>
          <rules>
            <rule name="wordpress" patternSyntax="Wildcard">
              <match url="*" />
              <conditions>
                <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
                <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
              </conditions>
              <action type="Rewrite" url="index.php"/>
            </rule>
          </rules>
        </rewrite>
      </system.webServer>
    </configuration>

    Se alguém puder me ajudar agradeceria muito…

Visualizando 1 resposta (de um total de 1)
  • Para quem passar pelo mesmo problema, consegui resolver.

    Segue código do web.config que funcionou:

    <?xml version="1.0"?>
    <configuration>
    <system.webServer>
    
    <httpErrors errorMode="Custom">
    <remove statusCode="404" subStatusCode="-1" />
    <error statusCode="404" prefixLanguageFilePath="" path="/EXEMPLO_404.php" responseMode="ExecuteURL" />
    </httpErrors>
    
    <rewrite>
    <rules>
    
    <rule name="wordpress" patternSyntax="Wildcard">
    <match url="*"/>
    <conditions>
    <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true"/>
    <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true"/>
    </conditions>
    <action type="Rewrite" url="index.php"/>
    </rule>
    
    </rules>
    </rewrite>
    </system.webServer>
    </configuration>

    Links de referências:
    http://ajuda.uolhost.com.br/index.php?p=resposta&res=530#rmcl

    http://br.forums.wordpress.org/topic/erro-404-nos-posts

Visualizando 1 resposta (de um total de 1)
  • O tópico ‘Links permanentes com erro’ está fechado para novas respostas.