Suporte » Ajustando o WordPress » links permanente não funciona

  • olá pessoal tenho o seguinte problema, quando configuro os links permanentes com a opção nome do post o arquivo page.php redireciona para 404.php (pagina não encontrada) e quando configuro com a opção link padrão o arquivo page.php funciona normal, e aí que ta o problema eu preciso que funcione com a opção nome do post, desde já agradeço a ajuda de todos.

Visualizando 4 respostas - 1 até 4 (de um total de 4)
  • Moderador Mario Valney

    (@mariovalney)

    WordPress Cleric of Fire

    Olá @marcelo-sampaio

    Como o arquivo page.php é usado quando o WordPress vai renderizar uma página, ele não é acessado diretamente (como um link/página do site), então creio que está fazendo alguma confusão.

    Após salvar os link permanentes, vá em Páginas e na página que quer acessar, escolha “Ver” ou entre na edição e verifique como aparece o SLUG ou a URL dele (fica logo abaixo do título).

    Abraços

    Cara estou passando pelo mesmo problema, to procurando igual um louco aqui.

    Já Testei dando permissão 777 no htaccess

    Coloquei no htaccess:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /mxcurso/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /mxcurso/index.php [L]
    </IfModule>

    Mas não resolveu.

    Meu servidor é locaweb

    Alguém já passou por isso ai ?

    • Esta resposta foi modificada 4 anos, 3 meses atrás por Mario Valney.
    Moderador Mario Valney

    (@mariovalney)

    WordPress Cleric of Fire

    Olá @devisac5, tudo bem?

    Por favor, exclua seu .htaccess e salve os links permanentes duas vezes. Um novo .htaccess deve ser criado com a configuração.

    Teste se funciona.

    Se o arquivo não for criado ou não funcionar, entre em contato com a Locaweb pois pode ser algum problema de configuração no seu servidor.

    Abraços

    @mariovalney

    Mario muito obrigado cara, foi isso mesmo.

    Problema resolvido.

    Muito obrigado.

Visualizando 4 respostas - 1 até 4 (de um total de 4)
  • O tópico ‘links permanente não funciona’ está fechado para novas respostas.