Suporte » Outros assuntos » Link manual de "like" do facebook com ação estranha!

  • Resolvido brunofilipevf

    (@brunofilipevf)


    Estou inserindo o link manual de “like” do facebook em meu blog, porem, alguns posts ele mostra corretamente o titulo e imagem thumbnail, e em outros, sem quaisquer diferença com os que funcionam me retorna apenas o link.

    <a class="curtir" href="http://www.facebook.com/share.php?u=<?php the_permalink(); ?>" title="Compartilhar no Facebook"></a>

    Alguém opina alguma solução?

Visualizando 7 respostas - 1 até 7 (de um total de 7)
  • Criador do tópico brunofilipevf

    (@brunofilipevf)

    De principio pensei que era algo a ver com facebook mesmo, e notei que tem um blog chamado YouToba.tv que usa a mesma maneira que estou tentando utilizar e funcionando numa boa.

    Já tentei dessa forma, e ainda não funciona:

    <a class="curtir" target="_blank" href="http://www.facebook.com/share.php?u=<?php the_permalink(); ?>&t=<?php the_title(); ?>" title="Compartilhar no Facebook"></a>

    O problema é que não exibe a miniatura então?

    insira o seguinte no cabeçalho do seu tema:

    <link rel=”image_src” href=”URL-DA-IMAGEM”/>

    Quanto mais dessas você inserir, mais opções o usuário vai ter de escolha de miniatura quando o link for postado no Facebook.

    Além desta maneira, existe um manual completo com alguns parâmetros do próprio Facebook para repassar os dados.

    Você pode combinar tags condicionais do WordPress para exibir imagens diferentes em cada post, ou apenas em posts que não possuem miniatura.

    Com uma busca por “Facebook Thumbnail” no diretório do WordPress, você encontra diversos plugins que facilitam esse processo.

    Abraço.

    Criador do tópico brunofilipevf

    (@brunofilipevf)

    Não é esse o problema! A questão é que o facebook detecta informações de alguns posts sim, e de outros não. Como falei, achei que era problema no facebook, mas em outro blog citado acima e que usa a mesma função, está funcionando numa boa. Ai vai um print-screen de como fica:

    Normal: http://i.imgur.com/aq5vR.png
    Problema: http://i.imgur.com/uil9h.png

    brunofilipevf,

    vc está usando as OpenGraph Tags corretamente? Quando a API do Facebook detecta um like button, ela busca essas infos primeiro nelas, e depois, se não tiver, no restante do conteúdo da página.

    Veja se no header.php vc inclui esse código logo antes da tag </head>:

    <!-- Facebook OpenGraph Tags -->
    <meta property="og:title" content="TITULO DA PAGINA" />
    <meta property="og:type" content="TIPO DE CONTEUDO" />
    <meta property="og:url" content="URL DO LINK" />
    <meta property="og:image" content="URL DA IMAGEM" />
    <meta property="og:site_name" content="TITULO DO SITE" />
    <meta property="og:description" content="DESCRIÇÃO DA PÁGINA" />
    <meta property="fb:admins" content="ID DO ADMINISTRADOR" />
    <!-- Facebook OpenGraph Tags -->
    Criador do tópico brunofilipevf

    (@brunofilipevf)

    Eu fiz isso mas ainda não corrigiu!
    http://www.iaemanolo.com

    …é neste site que to com o problema, se você tentar compartilhar no facebook, vai ver que alguns posts funcionam, outros não!

    brunofilipevf

    Conseguiu mudar???
    Estou com o mesmo problema!

    Use o Jetpack para inserir os links de redes sociais, é ótimo e funciona muito bem.

Visualizando 7 respostas - 1 até 7 (de um total de 7)
  • O tópico ‘Link manual de "like" do facebook com ação estranha!’ está fechado para novas respostas.