Suporte » Instalando o WordPress » Instalação local com erro de Extensão MYSQL do PHP.

  • manaus2

    (@manaus2)


    Saudações wp maniacos. Recentemente fui instalar o wordpress 5.3 localmente no meu ubuntu 18. Eu não uso xamp, nem wamp, eu faço instalações do php, mysql, apache2 separadamente e me deparei com o seguinte erro no meu browser:

    “Parece que em sua instalação do PHP está faltando a extensão MySQL, que é requisitada pelo WordPress.”

    • Este tópico foi modificado 9 meses atrás por manaus2.
Visualizando 3 respostas - 1 até 3 (de um total de 3)
  • Moderador Mario Valney

    (@mariovalney)

    WordPress Cleric of Fire

    Olá, tudo bem?

    Basta instalar a extensão do PHP para MySQL.

    Você pode atualizar o PHP para ver se resolve.
    Ou então instalar a extensão.

    Acho que seria: sudo apt install php-mysql.

    Abraços,

    igorvalerio92@Igor-Valerio-Web-Dev:~$ sudo apt install php-mysql
    [sudo] senha para igorvalerio92: 
    Lendo listas de pacotes... Pronto
    Construindo árvore de dependências       
    Lendo informação de estado... Pronto
    php-mysql is already the newest version (2:7.4+72+ubuntu18.04.1+deb.sury.org+1).
    Os seguintes pacotes foram instalados automaticamente e já não são necessários:
      libllvm8 php7.3-common php7.3-curl php7.3-soap
    Utilize 'sudo apt autoremove' para os remover.
    0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
    igorvalerio92@Igor-Valerio-Web-Dev:~$ php -v
    PHP 7.4.2 (cli) (built: Feb  1 2020 17:49:29) ( NTS )
    Copyright (c) The PHP Group
    Zend Engine v3.4.0, Copyright (c) Zend Technologies
        with Zend OPcache v7.4.2, Copyright (c), by Zend Technologies
        with Xdebug v2.9.1, Copyright (c) 2002-2020, by Derick Rethans
    igorvalerio92@Igor-Valerio-Web-Dev:~$

    Atualizei o php e tentei instalar a extensão que você me disse. tbm não deu mudei para a versao do php para 5.6 sem sucesso tbm.

    • Esta resposta foi modificada 8 meses, 3 semanas atrás por Mario Valney.

    eu atualizei o PHP dos meus dominios para 7,3 e agora fica dando o erro (Parece que em sua instalação do PHP está faltando a extensão MySQL, que é requisitada pelo WordPress.) como posso resolver isso?
    – Ja conferi para ver se os dados de acesso estavam errados no wpconfig.php e estão certos.

    DADOS SERVIDOR:
    Pacote de hospedagem mlacerda_Ilimitado
    Nome do servidor ca887
    Versão do cPanel 86.0 (build 20)
    Versão do Apache 2.4.43
    Versão do PHP 5.6.40 (EU ATUALIZEI MANUALMENTE PARA 7,3)
    Versão do MySQL 10.2.27-MariaDB
    Arquitetura x86_64
    Sistema operacional linux
    Endereço IP compartilhado 54.39.158.159
    Caminho para envio de email /usr/sbin/sendmail
    Caminho para Perl /usr/bin/perl
    Versão do Perl 5.16.3
    Versão do kernel 3.10.0-962.3.2.lve1.5.25.6.el7.x86_64

Visualizando 3 respostas - 1 até 3 (de um total de 3)
  • Você deve estar conectado para responder a este tópico.