Suporte » Outros assuntos » Imagens quebradas na biblioteca de mídia

  • Olá eu migrei de servidor e após a migração verifiquei que existia imagens salvas com caracteres especiais o que resultou na quebra das minhas imagens. Então algumas eu renomeei e outras eu movi (porque antes eu usava o CDN Amazon e lá é criado uma pasta para cada imagem, na migração eu vi que esse caminho se perdeu então aproveitei para mover e minhas imagens voltaram a aparecer) porém as imagens renomeadas via ftp aparecem quebradas na biblioteca de mídia no wordpress.

Visualizando 4 respostas - 1 até 4 (de um total de 4)
  • complementando com o print da tela onde as imagens estão quebradas – https://i.imgur.com/YcHkBzT.png
    O engraçado é que se eu abrir o post a imagem aparece mas quando abro a página de blog a thumb não aparece.

    • Esta resposta foi modificada 1 ano, 2 meses atrás por tiicaa.

    saudações @tiicaa,

    antes de mais nada, nunca adicione você mesma uma resposta ao seu tópico. a maioria dos voluntários olha por “Tópicos sem resposta” e, ao você dar uma resposta, seu tópico sai de lá, né… 😉

    só vi esse seu tópico porque, por acaso, tirei para ver “Todos os tópicos”.

    não sou desenvolvedor, sou designer. então não vou saber te dar a explicação “correta” para o caso. isso acontece porque o que você na galeria de mídia são miniaturas (thumbnails) da imagem. por isso a imagem no site aparece, mas na galeria de mídias não, porque o que está dando erro é o link para a miniatura.

    tanto é que na sua print, veja que ao selecionar a imagem, aparece na coluna do lado direito uma série de informações. na última, “Copiar link”, perceba que está “http://146.6668.114/”. ou seja, se é um endereço IP, ou é de sua instalação localhost ou é do servidor origin da sua CDN. e ai esse endereço não deve mais está funcionando e, assim, não aparece a miniatura. e se a imagem também estivesse com esse tipo de endereço, provavelmente não aparecia no site também.

    espero ter ajudado. muito boa sorte e sucesso com seu projeto!

    [code is poetry]

    Oi Ralden
    Obrigada pela dica, eu vou prestar mais atenção quanto as respostas, pois como não consegui editar achei melhor escrever. Sorry.

    O endereço das imagens na biblioteca de mídia está ok, esse endereço de IP é uma url temporária, porque ainda não quero fazer os apontamentos, então a questão do endereço está correto, tanto que se eu copio o endereço e jogo no navegador ele mostra a imagem referente. O meu problema mesmo são as miniaturas, pois elas não aparecem.

    Como ajusto o link de miniaturas que aparecem na biblioteca?

    • Esta resposta foi modificada 1 ano, 2 meses atrás por tiicaa.
    • Esta resposta foi modificada 1 ano, 2 meses atrás por tiicaa.
    Moderador Felipe Santos

    (@felipeloureirosantos)

    Então, complementando a resposta do estimável @ralden, o que acontece é que você tem os seus arquivos de mídia, mas os mesmos não estão cadastrados no banco de dados (ao menos não da forma correta).

    A melhor forma de resolver isso é apagando esses arquivos de mídia que não estão adequados, e subir novamente pelo painel administrativo, dessa forma, serão cadastrados corretamente dentro do banco de dados, além de gerar todas as thumbnails para as imagens em questão.

Visualizando 4 respostas - 1 até 4 (de um total de 4)
  • O tópico ‘Imagens quebradas na biblioteca de mídia’ está fechado para novas respostas.